Problems board shapeoko 3 XL

Hi guys,

I’ve been working with my shapeoko more than some weeks now, got quite familiar with the machine.

Now I can’t get it to run anymore. I was putting a V-bit for an important project that needs to be finished first week of January and all of the sudden the router fell down (as if it had no more power). Luckily, not injured.

My computer can’t connect to the cutter anymore, so I tried switching off the shapeoko and putting it on, alas no solution.

I opened the protection cap of the board and I think there should be blue lights flashing?
When I put the switch of my power supply on, there is a short flash of blue lights together with the motors starting up, but only very short (less than one second), and everything dies again.

Could there be some help? I hope my board isn’t fried, cause this project is important :roll_eyes:

Thanks again guys.

I love how this forum is so active!


Does your power supply itself have an indicator led on it?

Yes, the light of the supply itself is on, but it’s as if the board doesn’t want to get the power. If I put on and off the switch, the board has brief lights and dies out within one second…

Maybe try to unplug the stepper motors from the controller and see if the power still fades instantly ?
In any case get in touch with about this problem

1 Like


I just tried unplugging all from the controller except for the power supply, and the problem’s still te same.

Brief lights when flipping the power switch and then nothing…

I’ve send a mail to carbide, but thought this forum would be faster? :blush:

Thanks for the reply!

Let’s see what support says, but this does not sound too good :frowning:
Hopefully they will have you up and running again in time to meet your deadline

1 Like

Have you sent in an email to:

That’s typically the fastest way to get support issues resolved. :slight_smile:

1 Like

Yes, I’ve sent a mail to this adress, but have no response. I’ve already sent a mail once, which was never answered. That’s why I threw this case on here :blush:

1 Like

I had something similar once and it was the rocker switch being bad. If you are good with soldering and understand electronics you could try replacing it. Or even desoldering it and checking with a meter. Fixed up my power supply

1 Like

I checked with a multimeter, everything is fine. So I’ll order a new motherboard tomorrow. Hope this will solve my problem and get me up and running! :blush:

This topic was automatically closed after 30 days. New replies are no longer allowed.