Project failure after several successes

I had a similar problem with my first ever project and I asked for help here. I ran the file again and everything worked fine so I didn’t really worry about it. However, I have run into almost the same issue again now. I have run this file over 20 times, with only one issue (I’m almost certain it was a user error where I did not tighten the nut on the router enough) and so I have gotten comfortable working on other things in my shop and not staring at my machine run its course. This time, something got screwed up but I have no idea what. I was working on something else when I realize that my Shapeoko was louder than usual, I turn around and see this. Since I wasn’t watching it directly, I’m not sure what happened exactly, but the Sweepy had come off (one of the screws popped out) and there was a pile of sawdust on the workpiece since my vacuum had filled. Here is my code (1.4 MB)
Any ideas on what happened and how to prevent it from happening again?

Ali Ghafuri

No vacuum = chips stuck in path = too much force = stepper skipped steps.

Maintain your dust collection.

Also, check your pulley set screws because there’s always a good chance they’re the problem.