Shapeoko 2 CNC Upgrade GRBL 1.1f

Hello, Lighturn community. I’m working on upgrading a shapoko 2 with a J-tech laser. The firmware was 0.9 I did the upgrade to 1.1f, the laser is mounted and soldered in. I have a couple of issues that I can’t seem to figure out. Starting lightburn the machine connects I can more the machine but I get an error 9 and can not set a home position for the machine. Also, none of the limit switches seem to engage if pressed. The machine just wants to keep going even when at the end of the tracks. I’m not too familiar with the wiring for these machines. From what I read these issues could be a wiring problem or a configuration problem. I did all the configuration as instructed from this link, This is the link I’ve been using for the upgrade and have followed everything they suggested in there. I can’t seem to figure out why the error 9 is coming up and why none of the limit switches are engaging when pressed down. Has anyone done this upgrade that could help with figuring out how to fix these problems? I attached 4 pictures of the wiring maybe something is missing? Thank you in advance for your time and effort.

1d672b456f364a6e5a1f1c7c6a48c4925e9dedaa_2_375x500 99042ba2ca642fa8b11005df2ff3f507e2c14846_2_666x500 c69a2e38ca7c9c610698103899ad901fe3f41f9d_2_375x500 ea1ad0ecc71deafd478c2f1d04652d737aee61e7_2_666x500

This forum is for machines sold by Carbide 3D — the Shapeoko 2 was carried by Inventables — unfortunately the forum for that:

doesn’t see as much activity as once, so it may be that you’ll have better luck getting help here.

Please note that laser add-ons are not supported by Carbide 3D.

Could you post the configuration of your controller (I did not see this in the link)

To get this, use your gcode sender to send $$ to the controller and post the list that is retuned.

Ok thank for the advise Will. I’ll check out the form.

So these are the confirmations I put in and still the same problem but instead of error 9 I’m getting an error 5. Could this be a wiring issues?

You don’t have homing ($22) or hard limits ($21) enabled. Your switches won’t do anything.
Error 5 is most likely because you tried to home the machine with homing disabled.

1 Like

I’ve enable them by switching it from 0 to 1 and it’s still giving me the same problem. The switch are pressed but the machine still wants to keep going. The still don’t engage.

When homing?
Set $22 = 1
Leave $21 = 0

When you restart, you should be in an alarm state. Try homing.

What controller?

I apologize for the late reply I’m only around the machine on Saturday. Out of town during the week. When I hit home it dose nothing I get this message after it loads.

That last photo is a power supply.

Your controller is most likely in a metal enclosure at a corner of the machine.

It looks like reflashing went well — have you tried using it per: (though that will need to be adjusted for Grbl 1.1 and the specific software you are using — concepts should still apply).

Okay, that’s the controller (well, the gShield on top of the Arduino).

Thank you for the quick reply. The software I’m using is lightburn. And I’ve setup the confirmations specified for this laser upgrade. And still the limit switch will not engage. I’m thinking there may be a wiring issue.

Dose the wiring look correct on the controller?

Wiring color order is consistent, so seems fine.

There’s a diagram on the SO2 docs pages.

I’ll check that out. If I have the limit switches enabled would you have an idea why they are not engaging when pressed? I’ve searched and tried everything I could find and nothing seems to be working. I just keep getting error 9 I lightburn and the machine just wasn’t to keep moving even when the limit switches are pressed down. I am at a stand still with this because I have no idea when the problem could be.

Anything here help?

I would suggest checking in with the Grbl folks.

I’ll look at this and check with the GRBL folks. Thank you for you help Will.

@josephkerr, I’m not familiar with the wiring of limit switches on the Shapeoko2 and this controller, but I can’t picture where the wires for each limit switch go on the controller ?

Do you have happen to have Carbide Motion installed ? If you do, there is a handy feature in the Settings page that will print out a message when any switch is pressed. That would be a good way to check whether the controller actually sees the switches being triggered when pressed.

Carbide Motion won’t connect to non-Carbide 3D boards — this is an Arduino and gShield.