Shapeoko 3 - weird noise when jogging on all axes

Hey all,

I recently bought a well-used Shapeoko 3 Sparkfun edition from a local makerspace. I finally finished rebuilding it with the parts kit I ordered, and it seems to be working! However, there is a weird, sort of chugging noise on every axis when I jog it.
Example here:

Since it is every axis, I figure it must be something to do with the settings. As seen here: Stepoko: Powered by grbl Hookup Guide - SparkFun Learn on the official Sparkfun guide for the board that this machine has, all of the settings on my machine are as listed on this page.

The micro steps on this board are set to 1/8, like they are in this image:

Any ideas? I am going to try to make a simple gcode file and dry-run the machine tomorrow, but figured I’d post here before I did that in case it is an obvious issue that someone else can spot.

Thanks in advance!

Does the Sparkfun board have 4x or 8x micro-stepping? Are there DIP switches for changing between the twain?

Maybe try calibrating for belt stretch?

I will use that calibration guide next time I get out to the shop, thank you!

The DIP switches on the board are labeled “step size” and the options are: “FULL”, 1/2, 1/4, and 1/8. It is set to 1/8.

1/8 micro-stepping is correct for 8x micro-steps which is our current default, so that’s good to go.

I’m in the middle of a cut now, so can’t listen to your video — hopefully someone else will be able to evaluate it — usually odd noises are belt tension issues.

The noise I hear is the steppers taking small steps. Does it change when you increase or decrease the movement speed?

1 Like

Yup, looks like you were right! Took me a bit to get back to it, but I upped the movement speed and it sounds just fine. Thanks for responding!

There’s some rubbing noise when I manually move it on the y-axis, but I’m still testing things. I did successfully cut a 5 inch circle, though!

1 Like

Manually move it?? By jog buttons or by hand?

If you are moving it by hand, go slow. They are DC motors and will generate feed back to the board possibly causing problems.


Yes, by hand. I’ve heard this, thanks for the reminder!

I’m moving it by hand because I don’t have an limit switches yet, so I’m just setting the home position by moving it into place by hand then zeroing out the x, y, and z in UGS.

Limit switches so it can self-home are high on my list, as is getting a proper e-stop that will turn off the router as well as the movement of the machine.

Small update: got it working! It definitely was just the tiny steps causing that noise. Whoops. The homing switches are working now, too.

The Z-axis belt had slipped off the wheel at the bottom, but I fixed got that back on and snugged it up with the pulley on the motor shaft, and it’s real solid now.

Haven’t figured out the weird “rub” noise on the y-axis, but it doesn’t seem to happen during actual use. Finally cut out some test pieces and it seems super accurate. Excited to be able to start pumping out parts! Now to decide what to make…

1 Like