Shapeoko 5 pro and vfd spindle issues

I just got my shapeoko 5 pro assembled and vfd spindle. I can get everything to work except I cannot get the spindle to turn on.

I plugged it into the spindle port on the controller and I am getting lights. I can get the spindle to turn on, but on the spindle controller I cannot adjust the rpm below 24000.

When I try to send commands from my win 11 laptop, the commands send but it will not adjust the rpm nor turn it off.

Any help would be greatly appreciated!


Please check and see if you have enabled the BitRunner and not the VFD spindle — check in at

Are you saying in carbide motion? There is no options menu in settings on carbide motion for me.

I plan to call support tomorrow as well if I can’t figure it out.

I also am going to try on my macbook pro here in a bit too.

Did you do what Will Adams suggested?

1 Like

I am not sure where I enable that. Is that in carbide motion? Like I mentioned there is not an options tab in settings.

When I checked the debug it says bit runner enabled: false

I should also clarify that when I turn my SO5 Pro on then the spindle turns on to 24000 rpm and I have to manually stop it. No commands stop it.

Called support and sent an email. Left a message as no one answered. Hopefully I hear back :crossed_fingers:.

Please let me know in a PM what e-mail address you are using — I’m not seeing an open ticket under your name.

Were you able to get this to work? IF so what did you do, I seem to be having the same issues. ;(

1 Like

Hey is the spindle active button illuminated?

Are you asking about the spindle e-stop/yes its really the only way I can control the spindle as of right now. If you mean the spindle controll in the jog settings no, that button doesnt seem to do anything.

Dang, sorry, that was my issue, thankfully. Hopefully yours is an easy fix. GL

so what did you do to fix yours? was it a bad VFD?>

So I did get a hold of someone from support. They are thinking possibly bad controller but maybe bad vfd. They said since Saturday isn’t full staff they won’t be able to ship anything until Monday but he also isn’t sure if there are more troubleshooting steps needed :man_shrugging:.

Is your spindle turning on when power is turned on? I too have to use the stop at the back to turn it off.

I was hoping to do some cutting this weekend. I was super excited to have a quality and reliable machine to play with. Hopefully the next controller has no issues if that is what it ends up being.

is the red button on the vfd dim?

Nope. Pretty bright to me

Support is send me a new VFD. So I will test it once it arrives.

Support probably walked you though this, but just in case…

When you initially set up the machine, on the first run of Carbide Motion did you answer the spindle question “VFD Spindle” and make sure that BitRunner is off. Because that will influence whether the spindle control pin (green wire) is on/off (0 volts off, 5 volts on) or 5 volts pulse width modulated (PWM) - which is what the VFD expects to be able to vary its speed. If it is set to on/off, the spindle will be either all on (=24000) or off.

You can look on the “Settings” tab in CM, and look at the “Debug” tab to check. Scroll down that list of settings and look for the “Spindle type” line. It should be set to “1”. Here’s the relevant part of mine.

Machine: Shapeoko 5 Pro
GRBL Version: 1.1h

Carbide Motion 618
Machine Controller State: INIT
Grbl Cycle: Idle

“bitRunnerEnabled”: false, ------------------ BitRunner is not enabled
“bitSetterEnabled”: true,
“bitSetterX”: -1.5,
“bitSetterY”: -604.5,
“bitZeroType”: 2,
“connection”: 5,
“lastConfigSent”: 0,
“lastProbeIndex”: 0,
“lastSizeOption”: 1,
“odometer”: [
“cleared”: false,
“minutes”: 1828.625483333333,
“startDate”: “2023-07-25”,
“travelX”: 2472024.808167219,
“travelY”: 1250756.1670565903,
“travelZ”: 364846.7115054559
“showCarbideRouterRpm”: true,
“spindleType”: 1, ------------------------------ This line is the other one you’re looking for.
“travelX”: -1237.0,
“travelY”: -623.0,
“travelZ”: -155.0,
“version”: 0, …

You can always re-initialize as a new machine if necessary.

They did walk me through this but these are wonderful steps to have just in case. Thank you for posting!