Shapeoko 5 pro Bitsetter

Hey Gerald,

There are a few of us the just made 5 pro purchases and have had a problem with the Bitsetter
as per this thread in the forums. That being said, some of us have just received correcting parts that have corrected the problem. I just received my parts today, but too late for me to do anything tonight. Will post results tomorrow. So, I still have been able to use the machine with great results and feel the construction of the unit is awesome. The support staff have worked hard to get this issue resolved and I’m sure they will be there in the future. I’m for one am happy with my 5 pro and confident that any future issues that may come will be quickly addressed by their support. Just my 2 bits worth…

4 Likes

I got a new controller, bit setter and front panel today. I just installed them and so far so good. Hopefully it lasts, knock on wood, …still waiting for parts for my backwards spinning spindle.

1 Like

Hey Y’all,

Woo I’m in the club too! Same probe issue for me, no burnt board, however I have not plugged my bitzero in yet :grimacing:.

Here’s to a solid fix to this issue so we can all get back to making stuff :beers:

Update for me. I received the new Control Board, and on a phone call with Carbide support, we went through and tested.

Same scenario as before with the bitzero. Plugged in, powered on, and it shows as triggered. Support thinks it may be another bad front panel board.

I did receive my replacement bitzero, but did not plug it in, as I do not want a repeat of the previous issue of burning up the board and the bitzero.

Support advised me that they are going to get some front panel boards out to the west coast, and test before sending the replacement.

I will say that Support has been pretty good going through this, and are really working to make it right. I imagine some places would not acknowledge a problem, or would blame the customer by this point.

I agree with Jonah, hoping to get a solid fix!

1 Like

According to support, I had a unique sitation with the burnt board.

2 Likes

Hey all,

Finally got a chance to get the replacement front panel, extension wire and main wiring loom install this afternoon. Went thru the setup process and my Bitsetter is now operational and seems to working as it’s supposed to. Sure hope the rest of you are getting the parts you need and will be up and running with your Bitsetter soon. Thanks to support for working thru the problem and giving us the solution.

Bob

2 Likes

Welp - no luck.

New board came quickly (thank you for that).

Plugged them while the machine was powered off. Plugged in the BitSetter and BitZero, turned on the machine, 3 seconds later SMOKE.

Guess new plan time.

So sorry to here that. Hang in there!

Congrats Bob! I’m hoping the fix lasts. My bitsetter was working fine on first assembly but after three days it quit. I don’t have the Bit Zero, so that wasn’t the issue. Good luck to all the folks still waiting on a fix and hope its permanent.

Waiting for a reply from support. Looks like I’m in the same boat with the alarm error. Mine was working initially after I assembled the machine. After i removed the bitsetter to resurface the spoil board and re-installed I get the alarm 4 error and it won’t go away despite following the instructions to reset/configure etc.

Quick update. New board and cable came in, I replaced them and it worked… for the first 4 times, then same problem again. I did check the board and notice the old board did have something that looked burnt, the R103.

I checked the new board after this new failure but nothing looks burnt and I didn’t smell anything or see any smoke this time.

Emailed support again and waiting for the next steps.

I’m starting to think every positive post on here is a carbide employee making it seem like everything is fine. My experience thus far has been absolute garbage. They ship you the cheapest part they have over and over because they either don’t know what’s wrong or don’t want to fork over the expensive part. 3 weeks and my 5 grand purchase is still a paper weight. Claim they’ve sent me a different part and i receive the same part again which was obviously not the issue last time. So now it’s another round of dont respond for a day take another day to send a part that takes 3 more days to get here and not work. Some support.

Looks like I have been plagued with the same problem. Already Contacted support and they say the engineers are working on a solution and told me to run it without the bitsetter.

We had the same problem with the Shapeoko Pro. The solution was to switch the wiring/plug and the problem was solved. Let’s hope this is the same for you guys and it’s fixed.

Definitely not an employee. Also, still don’t have working bitsetter/bitzero. Sorry you’re experience has been so sour.

You received the spindle that spins in the wrong direction right? It’s too bad they lock down the settings in the VFD controller, because on other VFD that I own, I have full access, and there are settings to where you can set the default spin direction to clockwise or counter-clockwise. On that controller, I have to force it to spin in the correct direction (clockwise from the top of spindle) unless I incorporate some kind of switch to change which signal is sent.

I have been running mine without the bitsetter/bitzero, although it would be so much easier if they were working.

Update; Well I’m 5 days in since getting the bitsetter working and everything seems to be working as it is supposed to. I’m not 100% sure, but I think it was a combination of things that resolved the problem for me. I’ve changed out the controller and the bitsetter on the first go around without resolving the problem. Then support shipped out a new wiring harness, front plate and extension cable and those got it working. I’m still a little gun shy as my original bitsetter quit after 3 days when I first built the machine and I really don’t know why or what part fixed it. I talked with a dozen or so people who just purchased and built the 5 pro and only one other had an issue with the bitsetter and his fix was a new front plate. So, I think it’s just an unfortunate few that are getting machines with problem parts. I’m happy with support and the way they handled my case. Now just keeping my fingers crossed that the fix is permanent and not a temporary resolve. Good luck to those still waiting for a fix.

3 Likes

Very similar issue - my bitsetter seemed to work fine when first got the machine set up, then I plugged in the bitzero and got a bit of smoke and a burned out R103 as well. Support sent out a new faceplate and cable. Same problem again. For some reason the bitzero still works fine but I have a constant “on” signal from the bitsetter. Still working with support - who have been very responsive to date.

Update: I received the new front panel (third one including the original). This one the bitsetter seems to be working so far. Cut one project, and initialized the machine several times.

I went to get the BitZero, and opened the replacement they sent me only to find that it was the wrong version. I have reached out to support, so hopefully they will get me the correct version for my 5 pro.

At least most of the problem is resolved now.

Incidentally, it was R103 that burned out on my previous front panel board as well.

Thomas,
Glad you’re getting closer to final resolution.
Mine has been working fine since i recieved new front panel and wiring. Fingers are crossed!
Bob

1 Like