Shapeoko XXL - Can't connect to cutter

Can’t connect to cutter in Carbide Motion but I have blue lights on connection box, my laptop sees the usb connection, device manager says my Shapeoko device is working properly. I ahve uninstalled and reinstalled CM but that didn’t help.

In doing research, one post said I have to enter a sparkfun activation code before Motion can talk to the cutter, but nothing in my emails or the assembly instructions said anything about any activation code. Is this something I need?

I emailed support, but since it is Sunday night I thought maybe someone on here may have a suggestion for me.


Ran the update to GRBL 1.1 (which is already installed), let it find my machine, then cancelled and now it works. Hope I don’t have to do that every time…

If you do, then your machine has an out-of-spec part — let us know at and we’ll get this sorted out.

Hi Will:
Once it got connected, I ran my first job and it lost connection after the first 10 seconds of a cut and threw a bunch of port error messages at me. Now I’m back to not being able to connect. Man this is frustrating.

Yes, it is, but we’ll work with you until we get it sorted out.

The community has some EMI recommendations at:

Do you have another USB cable to try?

I have another cable I can try tomorrow. I gave up for the night so I can let my blood pressure come down a bit. I’ve been fighting this thing since about noon before seeking help and was to the point of smashing the damn thing lol.

I will say I’m down for trying a new cable or 3 prong plug, but when it comes to all the other stuff on the link you sent, I’m not going to start ordering all those things and doing a bunch of soldering/crimping, etc. I’d rather send it back. When I spend 2 grand on something, I just want it to work, not spend a bunch of time and more money trying a bunch of things that may or may not solve an issue.

Hopefully a new USB cable solves it.

Appreciate the help on a Sunday night. That’s nice service.

1 Like

Also, I don’t need to do anything with the Sparkfun activation (whatever that is)?

Correct. The Sparkfun activation is only for Stepoko boards (opensource sold through Sparkfun)

John please keep us updated on your progress. Mine is on order and posts like this concern me. I’m anxious to see how it gets resolved.

I am happy to see someone from C3D monitor the posts here. Good job!

If it helps to ease any concerns, I had an issue with connecting to my machine that turned out to be an out of spec part. Emailed support and they shipped me out a new board within a day or 2 which solved the issue I had been running into.

1 Like

It does…a little. LOL I’ll admit that I’m more concerned about the build rather than issues with the machine. I originally looked at the X-Carve when I first started looking at cnc machines and after watching many build vids I didn’t feel confident enough to take the project on. From there I went to a Pirhana (sp?) as almost ready to go out of the box. I decided on the Shapeoko as kit enough that I could handle and it fit my needs more in regards to size and such.

I’m super stoked to have the opportunity to learn so many new things through this project. I feel confident that if I have any issues that customer support will be there to lend whatever hand I need to resolve it.

The worst part is the waiting…and it’s only been a couple days. LOL

1 Like

Hi all - this sounds like some trouble I initially had, as well, and I wanted to add some (maybe only small) re-assurance.

I got my Shapeoko 3 XXL about 6 months ago and I now love it. I did have about 2 weeks of considerable doubt at the very beginning, related to some of the same issues the OP reported.

When I first got my machine assembled and started in doing some tests, I had some very frustrating issues connecting or keeping the connection the cutter. I can’t tell you all the steps I did, being so long ago, so unfortunately I can’t give any solutions, but I can tell you that, after upgrading to the latest GRBL and Carbide software and after some fiddling and back-and-forth with Carbide support (and a defective limit-switch which was swiftly replaced by Carbide), I now have a working machine which I really like.

Here are the quirks and limitations:

  1. I often have to “reset” the controller board to get the cutter to connect. I used to keep the metal cover off the board so I could access the reset button. I used quotes around reset here because, more recently, I’ve found that I can flip the power off then quickly back to on, with the same effect as using the reset button. So, I’ve replaced the metal cover and now accomplish my “reset” by toggling the power switch (quickly).

  2. the gantry move to back-right/home corner is really annoying. And seemingly unnecessary. I must be missing something.

  3. tool changing sucks. Essentially, don’t even try because you’d need some kind of external tool to keep a new tool end at the same Z as the tool you’re changing from. The work-around (I believe this is corroborated by Carbide) is to just run separate jobs on the same piece. So, do your one job, keep everything in place, load a new job w/ the same zero, re-z-zero with a new cutter and run the new job. Repeat as necessary. Really, I think this could be a big area for improvement, especially with the auto-z-zero puck thingy that Carbide sells.

  4. Default feeds or speeds seem really off, but I haven’t experimented extensively. But the ABS settings are clearly off; I kept melting/glomming around the tool within 30 seconds. I have the dial#/rpm sheet for the DeWalt and I think I set it to match the feed/speed chart. You definitely need to experiment with your own settings, the auto-settings don’t work (or didn’t for me). In the end, I dodged the issue, changed to polycarb material and haven’t experimented since.

Those are the biggy cons. The pros?

  1. the tab feature works great. Kudos!

  2. make really cool, large platform stuff on a budget!

  3. the software works fairly well. I’ve yet to have a failed part because the software froze/crashed or whatever. Once you get used to Motion, you can zero quickly and be off and running. I was doing a run of 10 parts through it recently and kept clocking myself to see what the cycle time was and was kind of amazed (maybe I’m naive) at how fast I could cinch down a new piece of material, zero everything and get started… it was like 90 seconds.

  4. The service is pretty darned good. I had problems with my system and someone there from Carbide responded right away and even sent a limit-switch kit that had failed. That person told me a lot of the same things as the OP heard, like “change your USB cable” and “try grounding the metal shield around the control board” and stuff like that, some of which I did but all of which didn’t seem to make a difference. It was the well-timed reset that did it for me. Which is essentially, whenever you see that “can’t connect to cutter” message, toggle the power toggle switch with maybe a half second between off and on. With possibly more than 1 try, it magically connects. Not that the service person identified that, but he did thrash around a lot to try to fix things.

In general, I love the machine. I love that I can easily create CAD, import the DXF and the Carbide software reliably creates the toolpaths. I’ve never had toolpath generation fail. It just works.

So, this user’s perspective of using the Shapeoko is “fun”/good rather than “hassle”/bad, which is quite an accomplishment considering the complication of CN routing. The first two weeks pointed to trouble, but after that, it was off the races. The biggest issues I now have relate to setting up material holding and chip management/vacuuming, not the software and not the operation of the machine (ie via Motion).

I hope that info helps.

Update: Carbide got in touch with me and told me how to fix the issue w/ the board, to get rid of the “reset” requirement. They also offered to swap out the board. Kudos to them for great service! (note: I haven’t tried the fix yet)

1 Like

Please contact us at about the board needing to be reset to connect.

I have been having the same can’t connect problem. They sent me a new board and I still have to reset the control box… now that I know that’s the problem. I’m just resetting when ever I have to.

Shapeoko xxl

Please let us know about the board still needing to be reset at and we’ll hopefully get this right on our 3rd try.

I am having the same error message, received touch probe tried to connect it, then error message begun, prior to this machine worked fine, sirs please help v2.2

If the machine works without the Probe, and doesn’t work when the Probe is connected, the only work-around I’m aware of is connecting using the adapter as if there isn’t a header to plug in directly — if that doesn’t work, let us know at (send in a photo of your Probe/wiring and how it’s connected to the controller) and we’ll do our best to help sort this out.

Since hooking up touh probe, it does not work with or with out

Please let us know all the details, and send in photos to and we’ll do our best to sort this out.

Mr. Adams,
First off I thank you for responding as quick as you did, also the support teams response was quick, at least till I sent picture as requested of the board and wiring, since then no response, I was hoping to have finished a few products by now, I am sure there is a reason, please help ty