SO3: Anyone using Jtech laser kit?

Anyone using it with the SO3 (I have an XXL)? If so, anything I should know regarding compatibility, setup, mounting, etc?

Nobody? Biggest thing I want to know is how people attach it to the spindle mount.

It’s on my Shapeoko To-Do list (Laser Adaptation), as is a replacement router bracket (an extra 1/16" further away from the Z-Axis plate would eliminate the annoying interference with the homing switch plate when removing the DWP611).

I’d have it sit in the router hole in some fashion, and it needs to be modulated. I know there are adaptations on the Wiki page I have glanced at in passing that might lead to some example implementations.

The limit switch / router removal conflict is easily resolved by pushing down the Z carriage and putting a small block of wood to keep it down, while you remove the router DW611 .


This is almost exactly how I remove it… I simply power down and manually press the Z-carriage downward in order to angle it past the switch plate. Alternatively, one can in fact use a wooden block as you describe. Personally, that’s an annoyance to me that I plan to mitigate by making this my first Al project.

I can also see the potential of having the ability to perhaps transition from router to laser without the impractical annoyance of jogging or power down in a specific multi-platform project.

Is the Jtech laser kit powerful enough to cut through 2mm MDF?
I would really be interested in making some miniature wargame scenery.

Just put one on my XXL today. I’ll have to update you after I get it running though.

1 Like

It’s not their kit but it’s a removable laser I use. Ebay special very simple metal bracket to hold it and I use the PWM pin from spindle to change intensity. I just sandwich the aluminum plate between the snap ring on the router and the router mount. I hold a simple aluminum plate against the work piece standing up and lower the Z until it just touches the laser plate to the measuring plate and it’s in focus at that point.

To get shades of grey though you have to play with it a lot. There are issues with PWM because GRBL attempts to pause to let a spindle spin up before cutting so it’s actually easier to either make it go faster and slower, or you have to install new firmware that allows you to ignore the spindle synch.

1 Like

Hello David, could you adapt your laser to your XXL?

Yep I got everything working great. First laser only lasted a couple days. They replaced it for free and are great to work with. Second laser has been running strong. I just leave it mounted all the time and it seems fine. Just blow some air on lens before doing any burning projects. If you have any questions just ask.

1 Like

and do you have problems reflashing the board with the jtechphotonics software?

nope everything work just like it did before the flash. No problems at all.

Anyone have a picture or instructions on wiring an Ebay laser to the controller? Or is it just the the JTech?

BTW, I have a 2.8W Laser Head Blue Violet Light Module 450nm with Diode LD Driver that I am trying to connect

There are some links at: which may help

Also look through the project galleries — some folks document their setups.

1 Like

I have the 3.8W 445nm JTech Photonics laser and like it. It has worked well with simple vector shapes and Universal Gcode Sender. Although I want to laser engrave photos, so I purchased their recomended PicSender and PicEngrave software, but am having trouble with reflashing their 0.9 grbl firmware.

I’m using their recommended X-Loader and holding the PROG button on the board, but it just hangs so I don’t know what I’m doing wrong.

1 Like

Is there a button or something which has to be pressed on the board to enable it to be re-flashed?

Hopefully this will get built into Carbide Motion for Grbl 1.1

Since you have a PROG button on your PCB, that indicates to me you have a v2.3 or v2.4 CM controller. While I never tried reflashing my v2.3 CM controller, I had fits getting a v2,2 controller reflashed for alternative CNC controls. I came to the conclusion that the bootloader was corrupt and/or inoperable. Luckily I had an AVR JTAG-ICE unit so I could reflash the bootloader. I documented this process here:

This may be your fault and thought I’d give you something to consider for remediating your issue.


Sorry that I missed your request for info in September; a group of us had this discussion last year over on the Shapeoko Forums and had the pinouts identified over there. This is great information to have; thanks for posting it in these forums.

1 Like

No worries, and you’re welcome @RoguePirin

I searched on the Shapeoko forums, Wiki, and even posted in the Electronics section… I was unsuccessful and just dug deeper. I understand how folks looking for info often can’t establish the correct search term. It’s often needle in a haystack or contextual terminology that gets in the way. I hope my efforts benefit someone down the road that’s in the same boat.

1 Like

I just ordered the J tech 3.8w laser and am looking for any tips,images of your work and projects.

For reflashing Will Adams helped me:

If you need to roll back to Grbl 0.9: Re-flash using Xloader (Windows-only): select - (Uno Atmega 328 and 115200)