SO3: Carbide Motion 356 Homing Cycle Limitation

Continuing the discussion from Carbide Motion Test/Beta:

I downloaded and am now running Carbide Motion Ver. #356 for my ShapeOko 3 (using a newer HP laptop with Windows 10). After setting the parameter 1005 to “true” and then running the Homing Cycle I can only get a working space (within the homing process) of roughly 8” by 8” in the middle right side of the routing table. The zero coordinates are set to the bottom left corner of this smaller area. And the rapid movement feature will only stay within this 8” x 8” zone. I was expecting a cutting area of 420 mm by 430 mm (~16”x 16”). Note, I can jog the spindle outside this smaller space and start a process, but I cannot get the homing cycle to reflect the larger ShapeOko 3 cutting area. Any suggestions?

Hi Mike,
In your device manager, does sit say your connected to a Shapeoko or a Nomad?

Windows 10 Device Manager says ShapeOko 3. Is there also a device manager for Carbide software? Also, parameters 1003, 1005, 1006, and 1007 all reference ShapeOko 3.

Hey Mike-

Are you doing the homing thru the MDI or in the Jog screen?


I’ve been using the Jog screen.

Can you post a screenshot of your settings pane?
Are you using our limit switch kit?
Have you changed the GRBL settings at all?

I will send a screen shot when I get back to the house. I have used the MDI to try homing - I.e., $21=1 and the $h. I also inadvertently set $22=1.

Yes, I’m using your limit switch kit.

Rob, another oddity in the homing cycle. When I run the homing cycle and check the coordinates (via the Rapid Position option on the Job Screen) the program thinks it’s gone 15.78" on the x-axis and 13.780" on the y-axis. But in reality the homing area covers only half these distances (~8" x 7"). I sent my Settings page to you via e- mail. I haven’t figured out how to copy an image into these posts.

Mike Huebsch

If the machine goes to half distance when you run the homing cycle then maybe this is your answer:

I might be wrong but deserves a try to find out if thats the problem.


That fixed it! Thank you. I must have loaded bad commands into the system. Now I get 400 mm by 350 mm cutting area (within the homing window). This is 15.748" by 13.780". I assume this is the expected cutting window. And the jogging measurements coincide with the cutting area on the machine.

Rob, thanks for your input and keeping me in line.


1 Like

Hello, I know it’s been a couple months for this thread, but I’m having the same issue – the rapid movement feature only moves the spindle around the right half of my SO3 XL – however, following the instructions on the link that Xaros posted doesn’t help me. I just installed the limit switches and after homing, I get this problem.

It’s as if Carbide Motion thinks I have the regular-sized SO3. Any help out there?

You do have to set the size inside Carbide Motion… you do that in the last screen… I don’t know what the official number are but you could start in the top right set zero and jog the machine all the way to the bottom left and look at the position -x -y and that should give you the correct figures … I think. Sorry I’ve only been awake for an hour.

Thanks, Alex. I appreciate your reply (and with just waking up, too!).

You’re right. And I also contacted Carbide support (since I didn’t know how quickly I’d get a response in each of these places). Apollo Crowe told me to change the Carbide Motion settings to the following:

Change the values to:

Shapeoko XL Table Specs:
Shapeoko Table Y: 430
Shapeoko Table X: 850

Shapeoko XXL Table Specs:
Shapeoko Table Y: 850
Shapeoko Table X: 850

And this solved the problem. I must have missed this step in the SO3 XL instructions…

1 Like

Having the same problem. Finally finished building #1403 and trying to figure all this out. The links that were posted here and over at Shapeoko forums are now dead.

Figured it out. Grbl settings for $100, $101, and $102 were not correct. I set them to 40.00mm and it fixed the problem.

1 Like