The return of the g2/g3 error with Fusion360 post

Hi folks, back into it, and running into a different flavor of error from Fusion, following up on this:

I’ve found that it seems to crop up wherever the Fusion post decides to throw in a G19 plane change. An example line:
G19 G3 Y5.76 Z-6.829 J-8.765 K-29.517

This hangs and gives the g2/g3 error. When I’ve tweaked my tool pathing such that this doesn’t get generated, it fixes it, but this seems like something better fixed by fixing the post. @wmoy am I missing something? (77.8 KB)
:point_up: No G19, runs successfully. Has some other feedrate issues, but works. (76.7 KB)
:point_up: This has G19 G2 Y-8.132 Z-6.916 J11.609 K-30.34 F344 and fails

G19 should be supported, but I’m not entirely comfortable with 3 decimal places. Around line 77 in the post processor is where precision is defined. Change the “3 or 4 places” to “4 or 5 places”.

Should look something like: var xyzFormat = createFormat({decimals:(unit == MM ? 4 : 5)});

Heck, you can even try 5 or 6 places. Give that a shot and let me know how you make out, I’m curious…

1 Like

What’s odd is that it seems there’s nearly always one, and only one G19 move. At the start and end there’s G17 specified.

here’s another example, at line 102: (82.6 KB)

Will try tweaked post now. (it still has only one G19)

@wmoy no joy with the increased resolution count: (100.6 KB)

CM build 4.0.428
GRBL 1.1f
Original Nomad883 (sn 137)

Update for a workaround:
line 34 is for setting circular plane allowance, where I’ve told Fusion to cut that out, and do XY plane arcs only:
allowedCircularPlanes = (1 << PLANE_XY) | (0 << PLANE_ZX) | (0 << PLANE_YZ);

Currently trying that.

@UnionNine Have you tried a different sender?
I checked the gcodes you said threw an error, and none of them created an error with grbl.

I’ve asked this a few times, but @wmoy, maybe you know…does Motion do its own checks for arc errors?

1 Like

@neilferreri I don’t have one handy that I’ve messed with. I’ve seen the Universal Gcode sender and other stuff tossed around, but haven’t dove into those. My above workaround worked a charm though for now.

1 Like

I’ve run into this as well, well I assume it’s the same issue. Created some simple toolpaths and it blows up about half way through using the latest carbide3d post processor. Attached are the screenshot etc…

I did report this to the Carbide3D support folks also. (1.2 KB)

If you’re comfortable messing around with the post processor, can you try making 2 changes:

around line 20:
tolerance = spatial(0.002, MM);
change that to
tolerance = spatial(0.0002, MM);

and around line 77:
var xyzFormat = createFormat({decimals:(unit == MM ? 3 : 4)});
change that to
var xyzFormat = createFormat({decimals:(unit == MM ? 4 : 5)});

Curious if just bumping up the precision fixes it, or if there’s a deeper issue. Could perhaps even push further. ie. Tolerance to 0.0001mm and 5-6 decimal places…

Unfortunately modifying the post processor (and verifying a change in the resultant .nc) was not successful. Tried a tolerance of .0001 and 5-6 decimal places with the same results… nc attached and a screenshot with updated motion. (on mine it was line 26 and 77) (1.2 KB)

Try a different sender.

We’ll take a look at your file tomorrow and see what happens

1 Like

Removing lead-in and lead-out seems to fix it… but that’s not really viable if I want to get the finish that I’m looking for

@jcummings I checked your files and grbl does not give an error. I use Fusion 360 frequently, and I have only seen this error come up with Carbide Motion. Try CNCjs, UGS, bCNC or something else.

Can you try the 429 beta at ? I cannot duplicate the problem but we made a small internal change to see what happens for you.

(Also, it’s notarized for OSX)


That build won’t load on my Mac running Catalina

What error do you get? (Screenshot would be great)

1 Like

None, it just loads a blank grey outline where the application would normally be but never progresses to the % loading on the top bar… I can get a screenshot but there is no error unfortunately… I’ll check logs in a second

1 Like

I can duplicate it now- we’ll look into it.

EDIT: Looks like a code signing problem related to Catalina. We’ll get it figured out (I hope).

Ok- can you download it again and try? I think we got the code signing fixed.

1 Like