Tool path not touching stock when job starting

Rookie here, have only had 1 project go successful and I am having issues with the CNC router after zeroing.

So I created a simple part to practice engraving/make sure I can do it in Fusion 360. I am using a stock piece of roughly 17" x 24" and trying to cutout a 12" x 12" square that is engraved. The code I made should engrave first and then cutout the piece.

In Fusion, I made the Part Position at the lower left corner, top of the stock piece. The part sits in the direct middle of the stock. After putting in all the information on the tool paths (aka engraving the pieces as well as the cut out of the piece). I save the code using the “NC Program” button.

Here is where the problem comes in. I squared the piece of stock in the CNC and used double sided tape to hold down the piece. I am using a BitZero V2 to probe the zero location of the bottom left corner of the stock. I then reset and save the zero location and get ready to run the job.

Once I tell the program to start, it prompts a tool change in which I do. It then goes to the silver cirlce, calibration button at the lower right side and does its normal function. Then it moves back to the “tool change location” and prompts me to turn the spindle on, in which I do (with a BitSetter). After that, the spindle moves to the lower left (away from zero) of the machine and starts running the program. So the X, Y, and Z are all away from the part (say -x from where zero should be, -y, and +z).

Can someone help me figure out why the machine is not taking in account for where I zero the part and where it should be cutting?

I have tried restarting the machine, the software, re-loading the gcode, re-saving the g-code, etc. with no luck.

Let’s remove the complexity of Fusion.

Create a simple project in Carbide Create, using the standard settings of:

  • Lower-left corner origin
  • Top of Stock

then try cutting that in a piece of scrap — if it works, try creating an equivalent file in Fusion and compare how that turns out.

If it doesn’t work, let us know at and we’ll do our best to work through this w/ you.

I will give this a shot!

This happened the for the first project and support told me to re-load the g-code and it worked. That file was created using Fusion. Was hoping the fix would be as simple.

EDIT: But I did add the Bit Setter and BitZero V2 this time around.

Okay, I tried this and the x and y locations are working.

The Z is still above the stock though… Any thoughts?

Where is the origin set in the file?

How are you setting zero relative to the stock?

How are you managing all tool changes?

Origin is set in the lower left corner of the model. Here is the simple piece I am trying to engrave.

I am using the BitZero to probe the XYZ and using those values to set all to 0.

For tool changes, everytime I change the tool it goes to the BitSetter touches it (twice) and then goes to work.

The only tool changes I make are the probe and the tool. Do I need to move the tool to the piece and reset 0? I thought the probe would get those values?

At the top or bottom of the stock?

Where do you have the BitZero positioned? See:

When you change the tool, make sure this is only done when prompted, and that after, the tool is measured.

I put the BitZero at the lower left corner with the “raised edges” off the side of the stock piece. Then told it to probe. While its probing I hold the BitZero just to make sure it doesnt move during the process.

So I took the BitZero off after it probed the Corner Setting (XYZ) and then set the Z manually in that position and that seemed to work.

Now I just need to figure out why Fusion’s gcode is not running the correct path, rather not cutting the area of the stock.

How familiar are you with Fusion 360? It has a steep learning curve, but once you get the hang of it, its excellent. Asking because there are a few “Gotchas” that creep up on you when create the Machining Setup step as well as the tool path.

IE: default in Setup is the stock rounding up to the nearest 1/2" which cause a 3/4" stock to be set up as 1". Thus often we see a tool that is trying to cut above the stock or cutting deeper than expected depending on WCS location.

IE: Is the WCS have the arrows for each axis in the right directlon? Is X and Y reversed?

Most of the time in Fusion, I model the exact size project I want. Then put an oversize board in and set my XYZ location a little bit inside the edges of the oversize board on the machine. Or even lightly draw where you want the project to cut out, then use that lower corner of the drawing to set XYZ.

Very familiar with Fusion as its my everyday Software. Not very experienced in the tool paths/machining setup as I usually only use it to design.

Here is a picture of the “Setup” portion where I position (what I believe to be) the zero location:

The piece is correctly orientated in the router as per the x and y coordinates.

Once I zero the machine and hit run, the machine goes down and left and starts to run. Maybe the orientation is flipped in Fusion?

hard to see in the pictures, but I assume the Z is pointed upwards? (towards you in the pic). Then it looks correct.

When I zoom in, it looks to be pointing down.

1 Like

If it does, then that is this problem. Its flipped and will run the opposite of the way we see it now


1 Like

Here is a better look at the origin:

Z pointing at the screen (not through the piece), X pointing Right, and Y pointing Up.

1 Like

That looks correct. Based on that, when you hit go, the tool (Z) should lift up and go to the right and away from you to the first tool path. Then lower to the surface and start the cut.

Also, just for clarity, the model is within the stock, right? Right now, it looks like the model sits on top of the stock. It might just be an allusion from the angle.

Can you share what the second tab of Fusion setup looks like? This is the tab where you set the stock size and how it fits the model in.

Yes the model is in the stock piece, here is a picture of the parameters.

Looks right. Sometimes that “round up to nearest .500”” bites you but in this case your stock is only .500 so it doesn’t need to round up.

Thank you all for the support! I think I figured it out. I had saved an incorrect NC Program and then saved the correct one on the same Model. I deleted the incorrect one and it didn’t work, but that lead me to delete all the tool paths and restart. Once I did that, the machine ran correctly!

1 Like