Touch probe help on S3

How to set up touch probe on S3 with stock controller v2.3.Can anyone steer me in the right direction as to what software i can use to probe home location

I have not had a chance to try this yet with my probe, but I will use Universal GCode Sender.

Here are the instructions that came with my limit switch/probe kit:

Move the tool close to your probe point using the jog commands.

  1. Plug the banana plugs from the probing wires into the mount on the -Y limit switch
  2. Clip one wire to the conductive surface, and the other wire to the end mill. The probe will only work with conductive surfaces, otherwise an additional metallic touch plate must be used.
  3. To probe, use the G28.2 command, followed by an axis, max travel distance and direction, and federate.
    For instance: G28.2 Z-15 F10
    The probe command moves in the –Z direction a max of 15mm at a federate of 10mm/min.
    The tool will automatically stop when contact is made, or at 15mm if contact is not made.
    The XYZ coordinates where the tool stops will be displayed in the communication window.
    I have set this command as a macro in UGS, as it is something I use often.
    Manually copy the current Z position (modifying for any offset from a touch plate) into your work coordinate system.
    Probe from any direction by changing the axis in the Gcode. For instance, A G28.2 X15 F10 command would move the tool along the +X axis.
    Remove the probe before starting the router.
    This concludes the basic probing tutorial.
1 Like

Bit on the wiki:

And one well-documented design. More at:

1 Like

Hi I have followed the steps and get it right till i have to put G92 command. I use carbide motion to run my machine from a macbook with Girl 0.9. in mm. I finish with G38.2 and remove the probe (everything ok till here), then i put G92 Z 19, and got mdi error, and i can not zero minus 19mm the z axis. Anyone know what i`m doing wrong?

I followed this video to get my touch plate working. I use Universal GCode Sender, so I’m not sure what issue Carbide Motion would be having. Have you tried UGS to see if it behaves better?

G92 isnt a supported command in carbide through this for more details.


Just to let any users know G92 isnt a supported command in carbide motion, because they disable some origin commands like G92. You have to use another g code sender, like Universal g code sender, bCNC and Chilipeppr to use a touch plate.

If you really want use carbide motion, users said to home with these programs, turn off the machine, power again the machine with carbide motion, verify the zero was still good and run the job.

I have set up my Shapeoko 3 and added he triquetra touch plate as described at Triquetra - Automatic 3 Axis Zero Touch Plate. When I send the g code using picsender, I get an error message “Line#2 G92 Z0”. I see from previous comments that G92 is not supported in carbide motion, but I’m at a loss as to what to do.

Use univarsal g-code sender

1 Like

I know g92 wont work on Carbide Motion. I dont know about PicSender. I tried it and I never could get it to work. Even talked to the developer and never could get it to work with my Shapeoko 3XXL. I finally gave up. Use UGS as Mark says above or bCNC would be my advice. Both are free. There is a new guy in town working on a new g-code sender. It is going to be fabulous from what I have seen and used so far. Wont be long till it is on the market.

Stacy, thanks for your reply. I downloaded the latest versions of Java and UGS, and success! Thanks again.

No problem. Glad to help.