Trim Vectors Issue

I’ve done this easily several times, almost to the point I don’t think about it too much (which may be the problem), but for some reason I keep running into an issue and I can’t figure out what I’m doing differently (wrong).

I’m trying to create an open-sided half circle. Typically I will create a circle, then a straight line, select both, trim vectors option, click the side of the circle to delete, it’s gone and then I delete the line (happy dance).

Whenever I’ve tried to do this recently, when I’m in the trim vector action it won’t delete the half circle. When I hover over the side I’m trying to delete the whole circle ‘illuminates’ (the grey shadow that indicates what will be selected if clicked).

I can trim the ends of the line, but not either side of the circle. It doesn’t matter which element I select first and has the solid or dashed line.

I’ve tried creating a box around the half I want to delete etc. same issue.

Just for reference, I’m using the Mac (v743) version of CC.

What am I forgetting?


I created a circle and line and experienced what you did.
Then I resized the circle…just a bit…and then it worked.

It must be something about the circle not being an acceptable object type. I’m sure @WillAdams will know immediately.

  • G
1 Like

Ah! Interesting.

After I resized the circle with the manual drag control I was able to trim the vectors I wanted.

I tried just adjusting the radius to a new size and then back to the size I want, but that was not enough to trigger the change.

Thanks @GJM at least I can move forward now with this workaround.

The problem here seems to be that the algorithm for detecting segments gets confused by coincidental nodes.

There’s definitely a nuance in Gary’s workaround; the drag and ‘snap-to’ sizing changes are not enough to make the segments identifiable - it needs to be made with the dynamic or smooth resizing.

This topic was automatically closed after 30 days. New replies are no longer allowed.