Trouble with bCNC

I thought I’d try bCNC since people seem to rave about it and it looked like it promised to allow storing some custom locations for oft repeated jobs. The howto video made it look really simple: home the S3, move to the job origin, set x,y and z to 0, load your gcode file and run it. Not for me, last night I spent a couple of hours and never could get it to work. As soon as I started the job, the spindle would race to the back right corner of the machine and slam into the corner if I didn’t e-stop it first. I tried different things over and over; rewatched the video assuming I was being an idiot, but nothing I could go would get it to go from the job origin to home. Finally, before going to bed I stumbled upon a posting that said the gcode generated by Fusion 360 had a line at the beginning of the file that said “G28 G91 Z0” which is a command to go home (I am not intimate with gcode yet). The person who posted the question reported that that fixed his problem.

So tonight I removed that line from my gcode, and sure enough the S3 doesn’t race home upon job startup. Instead, it goes to the location where it should start the pocket, the spindle raises up and the program locks with an error. The details on the error says it was a G43.1Z0.000, contact the author of the software. G43 is, according to Google, a tool length offset, but I don’t know what that’s supposed to mean.

The job runs fine in Motion. There’s no G43, G44 or G49 codes in the file, so I suspect it must have something to do with the machine configuration in bCNC. But for the life of me, I can’t find any documentation on how to set up an S3. I can’t seem to find adequate documentation on a lot of the features. Lots of things just don’t seem to work.

Maybe I should forget about bCNC. So far Motion does what I’ve asked it to do and all bCNC has done is give me frustrations.

There should be a list of G-codes relevant to the machine at: and it should also note which do/do not work in Grbl.

Carbide 3D has one page on using Autodesk Fusion 360: — not sure if it has any useful information in it or no in terms of all this.

The big question to me is which post-processor you are using. The community has some notes on this here:

The big problem here is that this is not so much a series of black boxes, but rather, links in a chain, all of which need to be properly located and hooked up (analogy breaking down, but hopefully I can explain below).

  • CAD has to create a file which can be imported
  • CAM has to accept the CAD file, agree on the units, prepare it for use
  • usually a Post-processor file is the key for matching up the CAM output with the machine — it has all the machine specifics in it, and selecting the right one is key
  • the communication / control software used to just be a black box passing commands on with nothing else happening, but both Carbide Motion and bCNC examine the commands and re-write them before sending them on to the machine — CM does this to facilitate tool changes (and possibly for other purposes, don’t know), while bCNC uses G-sharp to expand its G-code support

My suggestion would be to find documentation specific to Fusion 360, bCNC and Grbl and see what post-processor is used. Have you checked in with the bCNC documentation or the program author, or checked the tickets on Github?

1 Like

Fusion 360 has a post processor for Carbide 3D. The same job runs without fault on Carbide Motion. Fusion 360 does the CAD and the CAM and the postprocess all in one package.

They just recently updated the post as well. You can find them online at the fusion360 site.

Tonight I tried removing some other stuff from the beginning of the gecode, specifically things I believe are related to Motion starting out by raising the spindle and pausing while it waits for you to install the new tool. This got the job to start running. I was cutting “air” stock because I wanted to see it run all the way through the job. About 25% of the way in, it just quit. I couldn’t pause; I couldn’t stop. It wasn’t hung. It didn’t give an error. It just stopped. When I exited out, I saw an error message on the console that said the command was not recognized by the device.

My thinking now is that maybe I should be using a different postprocessor and not the one in Fusion 360 designed for Carbide3D. Is anyone successfully running bCNC with an S3 and F360 who could shed some light on the proper pp to run? I’ll ask over on F360 forum, too, I guess.

I’ve run a number of jobs after using the carbide3d fusion360 post.
Here are the up to date Autodesk posts - note that these are the same across several products, if it’s here, it works in fusion360. I don’t know if these are automatically updated when fusion updates. The grbl post was updated 18 days ago as of this post.

There are a couple interesting ones in there, including two that output DXF instead of gcode.

I have these other ones as well
There’s this one:

And this one I modified from that one that supports the speeds on the dewalt. I’ve used this one several times, and it hasn’t done anything untoward. (5.4 KB)

1 Like

I’m confused. You say you’ve used the Carbide post in Fusion 360 and run that through bCNC and had absolutely no problems? The gcode ran without any changes? Are you saying that instead of using the Carbide post to use the generic one?

So I downloaded yours and used it for the post and got this message: Invalid Work Coordinate System. Select WCS 1…6 in CAM software. Selecting default WCS1/G54. What does that mean?

Update: I took the gcode generated by your post and ran it on bCNC. It got to line 477 and just stopped. I quit out of bCNC and loaded up Carbide Motion it ran the entire job with the Carbide post without a problem. I don’t feel like spending more time troubleshooting software/configuration etc (that’s what I do at work all day) issues. I want to learn Fusion 360 and make things.

I hope this doesn’t sound like I’m angry or frustrated. I’m trying to understand this CNC thing because I’ve lusted for one for a long time. It’s difficult enough trying to learn everything you need to know without having to spend hours searching online for answers you think you shouldn’t have trouble with.

No. I’m saying I’ve used the carbide post, as well as a couple others, in Fusion 360, and used CM3/4 to send it, with no changes, and absolutely no problems. I was offering up a couple posts that might be helpful to you, as I don’t use bCNC any more, and should have called that out better. Do be aware that CM -does- do some interpretation of gcode: tool changes, for example, and I’m not sure what else.

If you’re getting frustrated with bCNC, don’t use it. I’ve tried a few senders, they each have pretty loyal followings, but keep ending up back at CM because it pretty much just works. Could it be better, more convenient, have fewer quirks? Well, yeah. Big time. But it is reliable, it doesn’t offer up options that I don’t need, and now that I know where it’s “weird” is located and how to deal with it I can make things happen without a lot of messing around.

1 Like

Thank you. That clears that up significantly. I’m trying to settle on my tools. I’ve settled on the S3 and Fusion 360 and I think I’m going to stick with CM.

Hey @Boothecus - If you haven’t figured it out yet, you’re going to want to set the WCS Offset from ‘0’ to ‘1’ in the last tab of Setup called Post Process.

1 Like

Please explain why. I read here somewhere that Carbide did away with all but the one main WCS.

I actually wouldn’t mind if someone else quickly chimed in on this, because I forget what the exact reasoning was and I’m heads down on building stuff for my daughter’s birthday party… Maybe @RichCournoyer can shed some light? In short, I thought it had to do with an incompatibility with G54. Setting it to 1 is what I’ve had to do with this workflow:

Fusion 360 --> Grbl Post Processor from @Strooom --> Universal Gcode Sender

This is partly how I ultimately stopped my machine from flying off to the far right corner like it has for you. I still occasionally have to edit the headers for my files to make sure they don’t do anything stupid, including Z retracting and hitting the limit switch.

(As @mikep mentioned above, Strooom PP: A better Fusion360 - GRBL PostProcessor)

1 Like

The reason for removing WCS support from CM was the addition of the Home button (X/Y) in mid 2016. At that time I was perhaps the only person who used WCS, to the new Home Botton was asked for my many. (Granted they could have added a G54, 55, etc home button…)

Now I just use Fusion 360 CAM Pattern to add additional setups when necessary and I use a Text editor to record the XY position on the table that I often use. It sucks, but it is a work around.

1 Like

Thanks, Rich. That is exactly what I do. I have a “scratchpad” document that I use to keep track of X, Y and occasionally Z.

I started a notebook to keep track of things like that. But it doesn’t make me happy.

I think I’m going to build a button box tether. I did this for some sim racing I do because it required too many button presses. I used an Ardiuno Teensy, which can be programmed as a joystick, keyboard or many other devices. My current thoughts are to use a thumbstick for x and y movement, a rotary switch for speed and two position momentary contact switch for Z height. Then I could add a couple of rows of buttons that would be programmed to do G0 x-200 y-214 so I wouldn’t have to look up anything and manually run the commands. I was also thinking of building a probe into it. My problem is that I don’t have enough experience on the machine yet to know what I need. This is what the box that I built to add buttons to my G27 steering wheel looked like. . I wish I would have had the S03 when I built that.

1 Like

Hy [Boothecus,
Stumbled accross similar issue w bCNC and sporadic but repeating hard reset. The sectet i was able to investigate calles me reckon single usb port to your mill. As soon i plug usb hub in or point a mouse in the workspacei get sooner or latersame an error. Anyone feel free t

o confirm. Cheers and happy milling and inventing, yeah job complete! Heeha! Finally