Upgraded to carbide 4 grbl 1.1 cannot manually set axis size?

Hello all,
I upgraded to carbide 4 grbl 1.1 without issue and ran test OK.
I have a suckit dustboot installed and need to reduce x axis length but using mdi to send $130=820.000 nothing happens?
Any ideas please?

Let’s start here:

Go to CM> Settings. Open a Log Window. GO back to MDI and type $$. Look at the settings (Hint, Click Stop). What does it say for $130 (in the log)?

1 Like

I do see the command and the change but when I jog I still hit the rails?
How do I avoid this?
I appreciate your help.
Thank you.

Sorry, baby steps, here.

So I assume, that 820mm worked before the 1.1 upgrade?

And for curiosity reasons, is it hitting X+ ® or X- (L-) rail?

1 Like

Andy -

This has been discussed in this thread:

It’s my understanding that when you perform rapid position jogging that Carbide Motion does not use the GRBL extents, so if you can avoid the “left/west” movements you should be good to go with CM4.


As Jim pointed out this is no longer functional with CM407. I just went through same issue and in the end rolled back to CM3 and Grbl 0.9. Hopefully there will be a fix, but in the meantime this is all I found that worked.


1 Like

Thank you for your help and advise.

Another thing to keep in mind when you are using $130, et al, that you set $20=1. This enables soft limits. The board will drive your cutting head as far as it will go unless you have $20 enabled.

$130, $131, $132 – [X,Y,Z] Max travel, mm

This sets the maximum travel from end to end for each axis in mm. This is only useful if you have soft limits (and homing) enabled, as this is only used by Grbl’s soft limit feature to check if you have exceeded your machine limits with a motion command.

1 Like

I will give that try Thank you

Posts 10-12 in this thread describe what happened when I messed with soft limits. Unless I’m doing something completely wrong CM407 will over ride the limits set in Grbl, or error out:

This was why I went back to CM3 Grbl 0.9.


I made an in-depth reply here:

How do you change the $20=1? I tried to enter it in MDI and it didn’t work. I have the XXL and my table dimensions are 450 and cannot change it…a

Make sure you click on “send” after entering each individual command.

1 Like

Of course, but it doesn’t seem to work…The soft is beta and it shows…

Strange. Open the log and send $$ to the MDI. that would show your settings in the log and verify that $20=1

1 Like

I need to roll back after upgrade to CM4 - pls tell me what the steps to roll back, where is the link to download grbl v0.9??? pls help