Upgrading to GRBL 1.1 fails

Hey Guys!

So I recently upgraded my SO3 to XXL. Finished putting the thing together and I am stuck at the upgrading software process. I downloaded the CarbideUpdater, and I am stuck at the second process. Whenever I run the updater, it would tell me to hold down the Z axis limit switch until the updating is complete, but a few seconds after I hit OK while holding down the switch, it would give me an error that says “avrdude error, please make sure that you hold down the Z axis switch until the upgrading process is complete” or something to that effect. I even taped down the switch just to make sure, but still the same issue.

Any help would be greatly appreciated!

I think I am using the original controller board. Should I still upgrade the software? Or just leave it be?

For the older boards, there should be a “Prog” or similar button on your board — hold that down instead of the switch.

1 Like

Oooooh. Like, on the actual board? Ima try that and let you know if it works.

So apparently, I don’t have the “prog” button on my board, there’s only one button and it says its for reset. I think the board that I have is the original/first board controller for SO3.

I have this board except for that the PCB is black instead of white.

Strange. The original boards aren’t supposed to require pushing anything.

Try one of the other firmware loaders listed at: GRBL 1.1 and Carbide Motion 4

If that doesn’t work, check in at beta@carbide3d.com and they’ll sort this out.

Do I need any HEX files for it? Sorry for all these questions, im not huge when it comes to these kinds of stuff. The title says reflashing to GRBL 0.9.

Yes, grab the hex file for 1.1 from the updater page: http://docs.carbide3d.com/support/carbideupdater/


And then i’ll just follow the same instructions?

Aaaaaand now im stuck on the “uploading” process. I don’t see any red light on the board blinking. What’s next?

I’m afraid that’s all I have. Please check w/ beta@carbide3d.com

I am not having any luck with emailing the support team. it’s been 4 days since I sent them 2 emails. Anyone else has an idea? Advice?

Please try support@carbide3d.com instead.

I just had the same problem. I found I had a intermittent problem with my z limit switch. I had to unplug the x from the board, also unplug the z from the board and connect x to the z position on the board. Then hold down the x switch and it updated. Essentially tricking the updates, using the x in place z. I still have the problem with the z switch. Boy the switches feel extremely cheap and unreliable.