Weird circles in 3D toolpath simulations

Hey Everyone, I’m getting weird circles in my 3D toolpath simulations for a terrain model I’m working on. I’m sure it’s an issue with my toolpath(s) themselves but after spending a few hours trying to fix them I’m at a loss… The attached simulation photo is the result of both a roughing and 90 degree finishing path. The terrain in question is the state of Arkansas and the work area is approximately 13 inches wide.

Any help would be greatly appreciated!

Screen Shot 2020-10-15 at 6.34.23 PM

What tools are you using for roughing and finishing?

Post the file?

Hey Will, I’ve tried all the default hardwood ball ends (1/4", 1/8" and 1/16") for roughing and the smallest two (1/8" and 1/16") for finishing.

I can’t post the file this exact image was taken from because I’ve deleted it and my computer currently isn’t available to re-run it. If you need it, I’ll be glad to send it over later tonight.

does this come from an STL?

I would suggest using “camotics” to try a 2nd opinion on a simulation of the gcode…

(and if is from an STL… I’m interested (example: The three volcanoes of N Oregon and S Washington ) and wonder what is going wrong…

(I’ve seen simulation issues like that before with 1/4" endmills… but some of that is JUST simulation artifacts)

3 Likes

Hey fenrus, I actually followed your guides to create the file using the following tools.

https://touchterrain.geol.iastate.edu
and
https://fenrus75.github.io/FenrusCNCtools/javascript/stl2png.html

Edit #1: I just tried “camotics” and I must be using it incorrectly because the results we’re much worse.

Edit #2: Would you mind sharing which 1mm tapered ballnose you’re using? When I add a 1mm ballnose finishing pass the issues I’ve been seeing seem to go away.

So I have seen these kind of simulation things when a ballnose got simulated as a flat endmill.

ON camotics; essential there is to make sure the tool library that is defined in that tool matches the actual endmills

I’ve been using one of these https://smile.amazon.com/gp/product/B015C61XX4 a lot

1 Like

Thanks for the endmill recommendation! Quick question if you don’t mind and please forgive me for being dense…

In one of your posts you mention a 1mm endmill, is this it? I see its listed as .5mm however I’m sure the taper needs to be factored in. How are you inputting it in Carbide? Should the size be whatever the tip actually is?

Thanks for all your help!

Radius 0.5mm ==> Diameter 1mm
(you don’t have to guess how I learned the hard way that subtle detail)

almost always you can ignore the taper… it only matters for super steep walls

Haha, you’re right! It didn’t even cross my mind that they might be listing the radius instead of the diameter! Thanks again for your help!