Well I killed my spindle and vfd today. How can I test the pwm output on the carbide board?

I’m still working with a mock up of my 1.5kw water cooled spindle. Had everything up and running on the cnc with all the controls ( vfd and I built a sub panel for the power supply). Has been working ok. Still trying to to find the right springs for the z axis.

Well today I started mocking up the controls for everything before I built an enclosure. I put a relay in the system controlled by a magnetic switch to control power to the vfd, cooling system, and the shapeoko power supply ( 3 pole relay controlling the 3 hots, vfd and chiller use the same power feeds)

Well everything was going fine I could turn on the mag switch. The shapeoko, the chiller and the vfd would all power up fine. Tested everything and it turns on and off as it should. Initialized the cnc, bit setter did it’s thing.

Sent command m3s18000 to test the speed control and I got sparks from the two small pins that I have in the 6 pin connector on the shapeoko for the speed control. Turned it off via turning the relay off. Checked and made sure that the the speed control wires were in the correct locations. Everything was correct , double checked everything Was all correct. . Went through the process again. Got sparks again and it blew the 15 amp 2 pole breaker that feeds the vfd and it blew the 50 amp 2 pole breaker that feeds the sub panel that the 15 amp is in.

So now I disconnect from the shapeoko completely. Go to power up and the vfd will not fire up. No fan no beep no screen display. Check and I have 240v to the vfd. So I unplug the spindle. Still won’t turn on. I can’t seem to find a fuse in the vfd. So I condemn that and go to check the spindle and I get about an 80 v shock with the spindle plugged in if I touch it. Un plug the spindle and I check for shorts. One of the power terminals is shorted to the ground terminal. The other two seem fine. So the spindle is dead.

I have sent a message to the seller on Ali express, only 2 Weeks old to me.

Now I need to check for any other causes. I can’t think of a single thing that would Cause the spindle to short power to gnd. But I want to make sure.

What’s the best way to check the pwm signal from the shapeoko board for issues?

Anyone got any other ideas of what the root cause could be? Other than the spindle deciding to ruin my 5 day weekend on day one?

For reference it is a g penny 1.5 kw water cooled spindle. HY 220v inverter. A cw300ag ( 220v) industrial “chiller”.

1 Like

What is your $30 setting?

And there is several discussions that has taken place here in the community, is is one of them:

$30=24000

But keep in mind I can’t even get the vfd to power up and the spindle has a short to ground in it.

I’m trying to see how to test the boards output on pwm.

If you want to check that the Shapeoko’s controller still outputs the PWM signal correctly, you can just use a Voltmeter (between GND and PWM), then use M3 commands:
M3S24000 should give you near 5V
M3S12000 should give you near 2.5V
etc…

Obviously, do that with the VFD and spindle disconnected, because getting SPARKS at the controller side on the PWM pins…oh my, there must have been something terribly wrong inside that VFD such that it fed back high voltage on one of its inputs… (PWM was connected to “VI” at the VFD?)

1 Like

I use a relay board off my PWN and ground pins to control my spindle (Router), what I did a voltage check while sending M3 S(1000 to 10000) to ensure a 5V output.

Yes connected to VI on vfd. That hasn’t changed in days.

Because of the sparks I believe the vfd/spindle were the cause and not the board but i want to check to the board for function. Everything else works on the cnc that I can tell.

I’m not sure if there could be a root cause other than the spindle. Can’t think of anything that would cause the spindle to short internally.

If I used a relay it would make my
Spindle On/off with now speed controls so that would take away half of what I bout it for.

I run different rpm for different tools and tool paths.

Yes Ryan, I understand, but YOUR question was about testing the PWM output…it is a voltage between 0 and 5V, based upon 0-255 setting from your $30. I was just providing you with MY method of checking the PWM. Now go get a volt meter and test your pwm and it’s voltages.

PS I also run different rpm for different tools and programs…

1 Like

I’d agree that it seems your major fault is in the VFD now. There’s no way that any “correct” VI or AI speed control input signal should be able to put the VFD in a mode that pops a 50A breaker, that’s fault current.

When you say you got a shock off the spindle housing, how was your earthing circuit wired up exactly? (For example, mine has utility ground to the VFD ground terminal where the four core screened VFD cable also has it’s fourth ‘ground’ core connected, my spindle tests 0.something ohms from pin 4 on that connector to the housing so I use that as my grounding)

Was the VFD power input live? (if not how long since you unplugged it?)

It seems to me that at least the internal 24V logic supply in the VFD is dead, the input rectifier on the other hand might still be doing enough to supply dangerous voltages, remember, if the 24V supply is dead then we can’t trust any internal discharge process to be working so expect the terminals to be “hot” until proven otherwise with a meter.

Were you connected to the ACM and VI terminals?

Did you test the spindle VFD combo without the Shapeoko controller? Did they power up and spin up?

I was shocked when the vfd supplied power but no action from the vfd.

The spindle Is grounded through the plug. I know the case and shaft were grounded as I’ve tested it all.

Again it wasn’t full line voltage I got shocked. More like what you get from static. The ground was doing its job. Your still going to get some feeling when you touch the spindle. Goes away when vfd power is cut.

I have not tried hooking the pwm controls back up as I have a short in the motor. One of the line pins is shorted to the ground pin. I know for a fact this wasn’t the case before as that’s how I determined the ground pin.

This was tested with and with out the shapeoko prior to this event on a test board . Was installed on the Shapeoko for a couple Of days I ran a couple of files but was still tweaking the springs. Although I think it’s a weak/ not strong enough stepper to be honest. Since the failure I have been trying to get operation with it disconnected from the shapeoko with no luck. I have power to the vfd. The chiller is on the same circuit and works fine. The vfd doesn’t make any noise, the fan does not operate, and the screen does not do anything.

I contacted seller on Ali express asking for an replacement. Got a response of if I setup the vfd correctly. Haven’t got any responses back yet. Going to give it until Monday and file a dispute I guess haven’t had this thing more than a couple of weeks

I really would not expect to feel anything when touching a properly grounded metal unless there is something else in the room creating a very substantial field and anything metal I touched caused a discharge shock (like when you’re standing next to the Klystron valve of a TV transmitter).

Running, stationary or powered off I feel nothing but cold metal when I touch my HuanYang spindle connected to (I think) the same VFD as yours. (HY02D223B, yours might be the 1.5kW variant)

Have you checked the ground in the outlet is good?

What about measuring voltage between the spindle and something else with a solid ground?

Yep that’s how I determined which pins were which in mine too, what with the complete lack of documentation with the spindle. I got about 1.5 Ohms DC resistance on any pairing of spindle pins.

I also agree the spindle is borked badly now that a winding pin connects to ground.

I think you’re doing the right thing not re-connecting the Shapeoko board, I see no good reason for the sparks and if they’re high voltage then they’re very likely to damage the Shapeoko board and leave you with more replacement parts required. When you get a new one, I’d put a potentiometer on the spindle VR, VI, ACM and test that before connecting it back to the Shapeoko.

Might also be worth using a multimeter in AC and DC volts ranges and measuring between the VFD and the Shapeoko board terminals to see what voltage is appearing there?

It’s possible you’ve got some horrid ground loop going on but it seems unlikely.

What is suspicious here is the spindle insulation failing out at the same time as you tried to connect up to the Shapeoko controller, also the sparks from the Shapeoko end where you should have a few volts DC. Those were either caused by the low voltage system in the VFD failing badly and managing to connect to the high voltage system or some sort of disagreement about where local ‘ground’ is causing a sufficiently high voltage to appear between the Shapeoko and the VFD to toast the VFD’s electronics.

So long as you were connected to the VI, ACM pins on the VFD it’s hard to see what config issues could cause anything other than a no-run. The VFD was clearly already set up for the right voltage, frequency etc. for the spindle or it wouldn’t have run before.

I can see the motor failing with short to ground if the windings were severely over-current and cooked the insulation but not any reason why.

Are you running the spindle on the regular Z axis?

Agree with that, wouldn’t let it near any other electronics until I had it working properly, fully grounded and the pot on the VI terminal driving it properly.

I suspect they get a lot of users who manage to cook the VFD or spindle by failing to set it up properly, of course, supplying better manuals would probably reduce that incident rate. Also supplying the drive pre-configured for the spindle it’s shipping with would be an expected minimum.

I’ll go through all that just to make sure. But every single time I’ve had a short in something I get the same low voltage tingle through the metal housing. All have had good grounds.

For example:
220v pressure washer.
2 failed power strips inside of metal tool boxes
A bench grinder
A brake lathe

I’m a master tech at a New car Dealer that been in business for 54 years so I’ve seen a lot of older equipment fail. The ground will give the current somewhere to go butt it still will follow the path of least resistance so some of the voltage will go through you if you touch it. Think of a basic circuit with two 10 ohm resistors in parallel. The resistance of the circuit will be less than 10 ohms.

Maybe I’m just sensitive to it.

I guess if you’ve got enough current going through the ground then yep, you’re going to see some voltage up at the housing due to impedance in the ground circuit.

I’m probably just too used to having residual current breakers on all the AC 220V circuits so there’s never any power left for me to find out what the ground impedance is.

Also, my working knowledge of US domestic power is very poor so I don’t know whether your “live” to your spindle would have a strong reference to “ground” earth. Over here in Europe 230V is delivered as “neutral” and one phase of 400V “hot” so any real earth fault gets a lot of current very quickly and tends to blow breakers.

It’s the appearance of the sparks when you connected back to the Shapeoko that’s really odd, seems that something had already gone wrong there and triggered the rest of the failure.

Yes something went really wrong.

At was connected to The shapeoko the entire time. It all went to hell when I commanded the spindle to rotate via mdi.

It must have really pulled some amperage because it blew the 15 breaker for the vfd and the chiller in my sub panel. It also blew the 50 amp breaker that feeds the subpanel that’s in my main panel.

And yes for now I am using the stock z. I had money put away for the hdz but if I can’t get this spindle/vfd swapped out for free then I don’t know what I’m going to do.

The spindle is the best upgrade I have ever done but it needs the hdz. I don’t have enough money approved by my forensic accountant( wife) for both. Well technically I didn’t have it approved for anything I’m just not able to hide it a second time lol.

1 Like

Ouch,

Well hopefully you can sort a new spindle and VFD without waiting too many months, I’ve not heard good things about the costs of returning things to China.

That could be a larger ouch than the VFD…

Dependent upon how the returns process goes, I’ve seen quite a lot of US folks on other CNC forums using Delta drives which have a manual in proper english, do things like vector control and can be purchased from resellers actually in the US who may give better support.

OTOH, HuanYang may quickly get on and help you, I’ll be very interested to see… Did you buy from HY or a third party? There’s support info for HY direct on the side of the drive.

No I bought it through a 3rd party who sells a “kit” with a g penny spindle and a HY inverter. Plus a POS pump and hoses

Starting to regret all of this. Every thing I read on the forums was this was the correct package to get. Don’t know if it was worth the trouble vs amazon now.

Well, let’s not pre-judge the third party.

As for the fountain pump that seems to be the standard supply, yes, it is a very special kind of nasty, mine ran for about 3 hours before starting to make ‘failed bearing’ knocking sounds and got replaced with something that had the flow / head pair of the plumbing and spindle somewhere actually within the operating curve.

Well a little more info. I pulled the spindle top off last night. Found a bunch of coolant in it. Wasn’t sure if it was from me pulling it apart or if the coolant was the cause of all this.

I blew it out and let it sit upside down over night. Just put it back together and I no longer have a short on a power wore to ground.

So I’ve got the chiller hooked back up and running now going to let it run for a couple hours and see if it shorts again. ( the chiller run with with the spindle unplugged)