Wireless remote jog control for $18 - 1 minute install

This was originally posted by @vkopr. I wanted to post it in the “how to” with a catchy title so no one misses it.

Don’t judge me because of my beat up dust shoe :wink:

For anyone wanting a SUPER simple mod for only $18 that makes improves workflow significantly here’s everything in a nutshell…

Its wireless so you can put the number pad right next to the router if you want to while you are jogging. Hot glue a magnet to the back of it so you can stick it to one of the front Y axis plates. Mine just sits in my enclosure for super easy jogging without stretching between the computer and the router to see what’s going on.

  1. Buy this wireless number pad from Amazon for $18 (https://www.amazon.com/G-Cord®-Wireless-Notebook-Computer-Compatible/dp/B00T5J6GK0?ie=UTF8&psc=1&redirect=true&ref_=oh_aui_detailpage_o01_s01)

  2. Pull the battery tab (battery is included) to power it on

  3. Plug in the wireless USB piece into a USB port (I bought a hub so I could still have plenty of extra USB ports)

  4. It installs itself and is ready to use right away

Here’s are the very simple instructions for using it: This applies to Carbide Motion… I’m not sure how it works with other software…
Arrow up/down = move Y in the positive/neg direction
Arrow right/left = move X in the positive/neg direction
Page u/down = move Z up/down

Press the “num lock” to allow jog speed changes
With the number lock “on” pressing…
1 enables “fast jog”
2 enables “slow jog”
3 enables 1 mm per press
4 enables 0.1 mm per press
5 enables 0.01 mm per press

Switch the num lock off to allow jogging again.

Thanks again @vkopr for posting this fast, cheap, simple and effective upgrade!!


@Tshulthise When i got to meet @twforeman he was using this in his workflow. I bought one and have never looked back. Using bCNC ± adds/removes steps. */ multiply/divide steps. Arrows move and home, homes the machine. I believe you can program macros as well, but haven’t done so yet.

1+ got the same one
Works like a charm :wink:

I use the same thing on my Linux laptop running bCNC (as @atrueresistance mentioned) and it works GREAT.

I love being able to jog and set zero without going back to the laptop. I also have a wireless touchpad that I use to move the cursor on the laptop, makes it much easier.

That looks like something I need!

How far away from the computer does it work reliably? I need about 10-12 feet.

I can’t imagine 10-12 feet would be out of range, but I can test it for you tonight (if I remember.)

It worked 20’ away and I was outside of the garage looking in through the window :wink: I didn’t try it any further since there probably should never be a need to reach nearly that far.

Okay thanks! Sounds like a wiener!

I bought this and I am extremely happy with the purchase and how it functions.

Same here. I can’t believe its not included standard with the SO3 and Nomad since it give such utility for so little cost!

Got mine and realized the C3D badge fits perfectly at the top. You can even drill a tiny hole in the “C” so you can see the status light:

1 Like

I got one for my Mac that uses bluetooth. It connects ok but doesn’t work with Carbide Motion. Strange, no?. Any ideas.

I just use an old wireless keyboard. Works great!

I bought one of these as well, best $18 I’ve spent on the hobby. It’s great being able to walk around all 4 sides of the machine, set zeros all with a tiny little wireless 10 key in one hand without looking at the PC. If you have an XXL, or probably any of the SO3’s this is a must have item. I don’t own a Nomad, but would think the small size might make this less important. I run mine on Win10, I don’t think there was anything to configure other than plugging in the USB Bluetooth dongle and installing batteries in the keypad, which I think it came with;-). Cool stuff!


I ordered this today… thanks for re-posting Bruno.

Anyone has this working on OSX in a Mac?.

Noticed a few days ago that my numeric 10 key is no longer working correctly after the CM 4.0/Grbl update. X/Y work like they should, but I can no longer set increments. Z doesn’t work at all. I put in a support ticket to the Beta team, but haven’t heard anything back yet (I know they’re probably super swamped). Figured I’d ask in this thread if anyone had noticed same issue, or if maybe it’s just me doing something wrong? Since my actual mouse and screen are not next to where I set my zeros on the machine this issue is somewhat of a show stopper for my current workflow. Anyone else notice this?



1 Like

I was wondering if this might be an issue with the GRBL 1.1 update? Just looking at the latest CM UI suggested big change, and I had wondered about 10-key compatibility… maybe others who have upgraded can confirm this?

I just find it odd that X/Y movements still work fine, but Z doesn’t work anymore. I can see where the increment control via Num Lock + 1-5 would be changed since we lost slow jogging, but not being able to set Z without using a mouse is a real killer for me when setting zeros unless I grow really long arms all of the sudden, this is where the keyboard shortcuts really shine.