X Axis off in some carvings, especially longer ones

Some of my (longer) carvings start to be off on the X axis at one point, which makes the carving look like a double vision.
It shifts the X axis to the right (when you look at the machine from the front) towards the end
of the carving (about 70-87% progress in Carbide Motion). It looks fine in the simulator (OpenSCAM). The X axis being off also causes issues on the Z axis of course because it off since it thinks its somewhere else on Y. I also attached a picture of my result. Its almost like the nomad has double vision.

-Carbide Motion 2.0.305 for Max OS Yosemite
-source is a STL that was imported into latest Meshcam Beta
-Screensaver did not come on
-did not pause the carving at any time
-I used soft wood and one of the 1/16th ball mills
-checked the drillbit itself and its tightly in the chuck and doesn’t move
-The wood itself did not move on the wasteboard at all, i measured its position before and after.

It seems very consistent that when the issue shows up, the X axis is moved towards the right at the end of a carving job.
Very eager to get this fixed since i am wasting more and more time and material on this. :frowning:

I have had that problem a couple times, when it happened to me I have heard the motor strain (and/or the bit bog down). When it recovers the bit doesn’t “jump”, but it is as if it did. When it happened to me I concluded I was trying to remove too much wood. Try slowing down the feed-rate, pluge-rate, and/or depth per pass.

I’m new at this, so I’m not sure how good my settings are but I have had good luck (so far). I’ve been working with pine, and when I use the 1/16th ball I have feed-rate of 1800mm-1600mm, plunge-rate of 450mm-400mm, stepover and depth per pass of .1588mm (1/10th the size of the ball).

I don’t have my NOMAD yet, but it would not surprise me if the knot in the wood caused some missed steps in your X axis. Knots in wood can be much harder than knot free areas. Maybe try again without the knot in your cutting region.

I had it various times in different types of wood, and often without a know being in the wood unfortunately, otherwise it would be an easy fix :smile:
I always use the standard settings from Meshcam for the Nomad so i would hope they are correct and shouldn’t cause that issue, especially since i sometimes have the problem and sometimes dont, even in the same type of wood (which is cut from the same board even). It wouldn’t think its the motor bogging down since it seems to happen towards the end of the carving when most of the ‘hard work’ is done already.

After a about 20 items i carved without issues, i had another one today after about 36% of progress in Carbide Motion where all of a sudden the X axis is moved to the left (towards the probe) by approximately 50% of the stock witdth.
That caused the drill again to (almost?) drill into the probe. I attached a video i took shortly before i stopped it.

This is really scary especially since its not the first time it has happend. The .nc file got created from a STL from the latest Meshcam via the Nomad Autopath.

I also attached the .nc file as a zip (you need a 5x5 inch piece of wood, center top is 0. Z max is 1 inch). Mill is #111.

Not sure if this is an issue with my machine in particular or something else but it takes a way the trust into the machine, especially leaving it running unsupervised.

The Mac i am using also didn’t go into sleep, i was using it surfing the web during the carving. No other USB device was in use.
I checked the belts with Jorge before and they are tight. Especially since the X axis is off by about 2 inches i don’t think its the belt that can cause it, especially since it didn’t creep slowly to the left, it all of a sudden was off 2 inches on X.

The file looks also good in the OpenSCAM simulator and doesn’t show any of the weird movements.

Any advise appreciated.


thomp.pdf (589.7 KB) (<-- Rename to zip)

I am starting the same carving from the same .nc file with the same type of wood again to see if the error is caused by the .nc file. If it shows up at the same time (or at all?), its the .nc file created by meshcam causing the issue. If the issue doesn’t reappear, then it must be the nomad itself that caused the issue.
If i calculated correctly, then 36% of the progress should be in about 50 minutes +/- 10 minutes from now.

Lets see…

Ok. This time the same .nc file, same type of wood, and same xyz 0 point and it came out fine without any issues.
That means the issue must lay with the machine. Any idea what can cause that?

I can’t prove anything, especially since it only happened three times, but I initially had the exact same problems and once I slowed down (slower than the auto-toolpath settings) the problem has not returned.

Yes it takes longer, but I’m more comfortable with the slower settings too the point that I don’t feel the need to stay in the room while it is working.

It might be worth trying clear-grained wood, Oliver. Knots can be really hard, and I’ve ran across knots that even slowed down a trim router. If the knot stalls the spindle (or even slows it down so that it isn’t really cutting) I can see where the axis drive could miss steps as it tried to drag the cutter laterally. Since the steppers are driven open-loop, the Nomad has no idea that anything has gone wrong. When a stepper motor is overtorqued, it doesn’t just slip a little–it stalls until the next commanded move. Steppers need to be ramped up to speed, so they can’t pick up in the middle of an existing move.


Hi Randy,

good idea, and i thought that was the issue with some other wood i used before, but this wood doesn’t have any knots at all. Plus being off for more than 2 inches is a lot i think. Its pretty hard and fine grained (Jatoba Wood).

It must be something else, since the same carving from the same wood (which came from the same board) worked without issues. Plus being off almost exactly half of the width of X makes it a little bit too exact to be a slip up, seems more like a miscalculation somewhere or so. Not sure though of course :slight_smile:

Hi Oliver,

The distance that it’s off by (approximately half) doesn’t rule out a slipped stepper—one option would be that it crashed about halfway through a rapid or linear traverse, so when it picked back up the X-axis was off a lot.

Also, remember, once it’s slipped it stays misaligned/disoriented until it has been homed again, and these errors accumulate. If you’ve seen it getting progressively worse then you probably have some lead-ins or transitions from a plunge to a traverse where it’s momentarily overloading the tool and losing traction.

If that’s the case then fixing it would just require adjusting the acceleration profile for the machine for the material, and/or setting a less aggressive feed speed.

I compared the Janka hardness of the Jatoba to other hardwoods that they’re likely to have set the automatic settings for—I’m guessing woods like white oak—and it’s rated at 2350psi whereas white oak is 1350psi, so per this write-up about guesstimating feed/speeds for woods, I’m betting your asking your Nomad to bite off more than it can chew.


thanks, yeah i will try to change the automatic setting then and see if that solves it. But i would think if thats it, it would come back every time i cut the wood and not just sometimes. Plus i had that issue with Douglas fir before, which is really soft (i think)

I have seen on my 3d printers, that the steppers can miss steps when ran on to high speed. Check the themperature of your steppers and stepper drivers.


and it happened again, this time with Renshape (using the Meshcam Renshape tutorial) and a very short .nc file.
It started all of a sudden drilling about 2mm off the spot where it should be (see attached pictures, especially the round holes on the left). the workpiece definitely didn’t move this time (in fact i have a hard time right now removing it).

It happened last night again too at a longer carving after about 6h, when the parallel run started. It was off by almost exactly 10 mm, and again on the X axis…

I really think something is up with my machine, maybe the board inside the Nomad is hanging and skipping some steps, or the belt jumps or so, i am not sure but this example above was really a very easy to drill piece, that didn’t take much time so the machine didn’t run for a long time, and I used renshape so it cannot be the hardness of the material or knots inside, and it was just some basic hole drilling involved.

Please advise!


To me it looks like you have been much deeper into the stock, than the lenght of the cutting area of your drillbit…


Hi Oliver,

I think we’ve found at least part of the problem—you’re using a tool that has a tapered shank, and making cuts that are deeper than the cutting length of the flutes, as Nahoj noticed. What’s likely happening is that you’re running the shoulder of the tool into the material, which of course isn’t cutting… so something’s got to move—in this case it’s the steppers skipping steps!

If you can go back through your setup and your tool selections where you’ve had issues, can you identify that you’ve been driving the tool deeper than the flute-length in the material along straight walls in each case? For deeper cavities you’ve got to get long-reach tooling, or you have to taper the walls so you won’t hit them with the tool.

Let me know if you can confirm the total depth of cut and wall angle as the issue or not :wink:


good point, at least for the item in renshape, not for the longer piece that failed last night. That piece did not have a frame at all where the tool could hit (its a landscape relief). No straight walls on that one, it started right at the point when the finish pass started.

so 50% of the case is resolved :wink:

I also wanted to add that i use the very same wood (Jatoba) for other carvings with the exact same settings in Meshcam and final cutting depth and it works well. The only difference is that the one that doesn’t have problems is only about 3h long while the problematic one is a 8+ hour job.

This thread is kinda stale now, but i want to bump this again since it happened again. And this time you can see it nicely, it was all fine until the ‘Cut X then Y’ started. You see the smooth part (where it started cutting off the part on the right side). I used a 101 cutter.

Can you post your .stl and your MeshCAM tool-path settings? That’d make it easier for the rest of us to have a look.

My guess is that your stock definition didn’t take into account the ridge you’ve got over on the right edge, so it looks to me like the cutter stalled while going rightward, into that ridge.

It also looks like that ridge is uneven, and perhaps even deflected a bit, can we get a “Front-view” of the stock in addition to the “iso” you’ve provided?