XXL Ball screw and linear rail help

I replaced all the belts with liner guide rails and ball screws but now the motors are not locking very well and it seems like the motors have no torque do I need to adjust some settings or did I mess up my motors or the board?

The screws are 16mm Diameter and the pitch is 5mm

When the motors are not attached they don’t take much force to turn the shaft while powered…something wrong I just don’t know what.

Screws or not, makes no difference to the motors. If the motors are energised and you can easily spin the shaft, the problem is somewhere in the wiring. Check all the connectors and that you have no loose wires.

Mind posting pictures of your machine?


Wires all seem fine

It’s a bit of a mess right now http://imgur.com/a/aqe28ns

Lol trust me, been there done that. Unless you somehow burnt the windings on your motors, it has to be the wiring. Unless you somehow fried the board, but if it connects to the computer and all the diodes light up then switch the motors around, check all the connectors. Google: “stepper motor troubleshooting”.

What’s the length of the screws you’re using - 1050mm? Also, I had a really bad experience with the couplers that you’re using. They’re okay for 3d printers, but not cnc routers where the forces are much higher. If you crash they’ll warp like there’s no tomorrow.

1605 screws will only give you around 2000-2500 mm/min with the stock motors and controller.

Unlikely all motor drivers are dead (unless you did a lot of plugging and unplugging while powered on).
Did you change any settings? What’s your $1 value? It should be 255.

Yeah the screws are 1050mm. I’ll see what I can find on the trouble shooting. I don’t think I’ve ever done over 1000mm/min during cutting so that should be fine.

@neilferreri All the settings are default.

Thank for the help guys. I’m losing my mind here lol

Default grbl or default Shapeoko 3?

I’ve only changed the settings in grbl for the z axis everything else is how the machine came

Can you jog the motors / move them in a homing sequence?

The z axis is going the wrong direction now when homing and won’t respond to my hitting the switch manually while it’s doing it

If your z is going in the wrong direction, you have to change $3. Try setting it to 4. Also, check that youre hitting the right limit switch. You might have plugged them incorrectly.

I’m not 100% sure (because I’m not near machines to check that) but during homing sequence, the Z limit switch have to be pressed first, so even if you press x or y switch nothing will happen. That’s why check, if you’re pressing proper switch.

Can you post your $$ settings?
You can invert the Z (if needed) with $3 setting.
If you hold the switch and send a ?, it should tell you if the Z limit is being recognized.

$$ isn’t working the z axis should have already been inverted since that’s how I had it before and I didn’t change anything other than adding the x and y screws the z axis is the same as I had with the belts. The other motors sent even trying the move when I home now just the z which I got the limit switch to work manually. But the other axis don’t move. After I get the homing done when u go to the jog screen it wants to home again

Ok the x and y are working after hard reset on the board. But the left y motor is not turning still and $$ still does nothing. I need to inverted all the axis now it seems like.

This is not easy to do as you have to simulate the feed, the release, and the seek.

Just unlock the thing ($X) and jog the motors. No reason to home if they aren’t set up.

What happens with the $$?

That’s not good.

Are you using CM? If so, you’ll need to open the log to see the results from $$. You need that info to decide the new value of $3.

$x didn’t seem to do anything it’s still asking me to home. I’ll post the $$ in a sec the system isn’t connecting to the internet in the garage

(2297): <- ok
(2296): <- $132=80.000
(2295): <- $131=850.000
(2294): <- $130=845.000
(2293): <- $122=400.000
(2292): <- $121=400.000
(2291): <- $120=400.000
(2290): <- $112=5000.000
(2289): <- $111=5000.000
(2288): <- $110=5000.000
(2287): <- $102=40.000
(2286): <- $101=40.000
(2285): <- $100=40.000
(2284): <- $32=0
(2283): <- $31=0
(2282): <- $30=1000
(2281): <- $27=5.000
(2280): <- $26=25
(2279): <- $25=2000.000
(2278): <- $24=100.000
(2277): <- $23=0
(2276): <- $22=1
(2275): <- $21=0
(2274): <- $20=0
(2273): <- $13=0
(2272): <- $12=0.010
(2271): <- $11=0.020
(2270): <- $10=255
(2269): <- $6=0
(2268): <- $5=0
(2267): <- $4=0
(2266): <- $3=4
(2265): <- $2=0
(2264): <- $1=255
(2263): <- $0=10
(2262): -> $$

If all axes are reversed…you’ll want to change that to $3=3.

Still no locking? Second Y-axis?

You can change $22 to $22=0 (disable homing) for testing.

it’s locking it’s just not moving when I jog https://imgur.com/aHyfhla

Looks like a wiring issue. Any chance you rewired the motor?