XXL help while jogging

Hello all, new to the forum and almost as new to CNC machines. It’s been a whirlwind of learning curves and trials and tribulations. And I’m loving (and sometimes hating) every second. I’m having a bit of an intermittent problem. While jogging and moving the router thru motion, the machine seems the “ghost move”. I can click x, y or z and they all seem to do it. I can click the mouse in fast, .01,001 it’s doesn’t matter it will move sometimes three and 4 inches at a time. With only 1 click. My computer is a touch screen so it will happen with the mouse or touch screen. It only happens now and then. But really is a problem when I’m setting zero on z axis. Any help would be greatly appreciated. I will try and take a short video if it does it again


Some folks on some computers get doubled motion — let us know at support@carbide3d.com and we’ll try to have a developer look into it.

Here is an example. I’ll try and email the link you sent as well. Just want to make sure it’s not something I’m doing. Which is more likely

I noticed the “BUSY” icon in the dialogue window appeared to show lag…
I don’t know how many times you depressed the inch buttons before you started recording.

I’m sure support will take care of that, but in the meantime:

It may be interesting to open the Log window, and see which traces are displayed when you reproduce this behavior. So as to know whether the machine actually receives jog commands, and which ones (the smooth jogging commands start with $J=, and I think this could indicate that somehow the laptop sees the button as continuously pressed).

Any chance that glossy touchscreen layer might “stick” in places, especially in the middle of the screen ? Silly idea maybe, but what if you resize CM window, and move it such that the jog arrows end up in a very different place, say near a corner of your screen. Can you reproduce the issue then ? Just for the sake of testing/understanding what’s going on.

And then again you mentioned that you can reproduce this with a mouse also, so it’s probably not that.

Thanks for the reply Julien, I did try and minimize the window placing the arrows in different parts or the touch screen but to no avail. And your right, it does it with the mouse or touch screen. Its definitely becoming more of an issue for me. Setting zeros mostly. When it does it for X and y its just annoying. But Z is down right frustrating. If it runs away and bottoms out then I have to start all over with the initiation and go at it again. I know I’m far from the “most spent” list at C3D but I’ve spent $2500 with them alone and didn’t think I would get this. But to be fair, even though this computer meets and exceeds the requirements to run the XXL I’m going to try it with another computer on Monday. Hopefully I can figure something out soon. Thanks again for the reply

I work around the doubled movement by reducing the increment as I get closer to the desired position — it’s tedious, but it works.

So you get them also? Its down right irritating. I get that it helps, but only marginally. If it only Double moved then it would be one thing, but mine will walk clear across the board! And it super sucks when Im setting zero for Z! This cant be normal

it almost sounds like a bad wire or EM or something… most digital things would at most be 2x the step

1 Like

I only get double movement — which can be quite a bit of distance a the Fast increment — hopefully the other computer will be better behaved.

Have you tried the keyboard shortcuts on a numerica keypad?

no but I will. thanks


That must be super annoying indeed, so let’s try to get to the bottom of this ?

  • what did support say ?
  • did you have a chance to capture the log window traces while reproducing this ? getting the traces from the log window corresponding to the behavior in the video would help better understand the “continuous jogging” effect, which I would think is different from just “doubled movement”. I’m intrigued by the very long “busy” state in the video while the machine is doing nothing and no key is pressed.
  • let us know how things go with a different computer. It might be some weirdness in the USB communication.
  • just a silly idea, but how is your keyboard “repeat rate” set ? (i.e. when you push a key to type in text, how long does it take for the computer to print multiple instances of that key). Just to clear a possible root cause, I would try and lower the repeat rate and see if that has anything to do with your problem (example instructions to do this in Windows10)
  • if all of the above fails, I would try a different G-code sender, if only to check if the problem also happens. If it does, then it’s definitely an issue in the computer/USB setup somehow. You could try with CNCjs for example
1 Like

i have a touchscreen and it works fine for everything except Carbide Motion. i had to just unplug the usb cable to the monitor and stay with a keyboard and mouse. As soon as I started Carbide Motion the touchscreen kept cycling being seen by windows. This only happened in Carbide Motion so there is something in the program causing this. It was not eniugh benefit gor me to waste time trying to figure iut the problem so I gave up and moved on.

1 Like

Would you please let us know the specifics of that setup? Send an e-mail in to us at support@carbide3d.com and we’ll try to have a developer look into it.

Will, I have a BeeLink BT3 Pro II (fanless PC) and a ViewSonic TD2220 monitor. Running Windows 10 with current updates, and latest Carbide Motion. Let me know if a video would be helpful. I sent an email.

1 Like

I usually run my machine with a cheap Windows tablet. It came with a keyboard and touchpad, but it always did weird things. I removed the keyboard and use a little Bluetooth one. No more ghost clicking.
Maybe it’s just noise on the line? Is the computer plugged in to the same circuit as the machine?

New computer with 12 gigs of ram and so far zero issues. I’m thinking the issue was on my end and not on the Shapeoko’s. I feel like will be a common theme with A lot of my future issues! Thanks for all the suggestions


It is most probably the computer. I have new laptop,works fine through keypad or mouse using the on screen buttons. Worked pretty well using cheap wireless number pad. Would have issues with busy error (I’ll call it error) on the z at fastest setting. Not so much on the 1 or .01 setting.
Added a contour shuttle to the mix to eliminating issues with the motion and having to watch monitor. Cheap number pad was a pain to change speeds. But the shuttle has issues with almost constant busy errors. Again mainly fast but on slower speeds to lesser degree. I stopped using shuttle, working with it to program differently.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.