XYZ issue after using Jtec laser LightBurn software

Have had my shapeoko for a couple months the jtec laser for a couple weeks. The first couple projects I finished up with the jtec using the LightBurn software no issues. Today I went to CNC a plaque and when I attempted to jog the machine to zero it doesn’t go where I’m telling it. It will go to rapid movements center etc. It’s movements are sporadic it will move left then back then left and back at the same time. Really weird. I even tried to see if the laser controls after to see if they would still work and they aren’t even working. The machines and software were both working as should earlier. I’ve powered down restarted unplugged everything and plugged them back no dice. Anyone had this issue or have any advice?

After running your job in LightBurn, did you run the “Run CNC” macro (might be called “Use CNC”)? It will reset the $$ settings in the Shapeoko for running CNC jobs. I’ve had issue with the BitSetter when I didn’t do that.


What version of LightBurn, and what version of Carbide Motion? I am on LightBurn 0.9.14 and Carbide Motion 513 and don’t have any new problems, but I have only been using the laser for a few weeks. I might have solved the problem when setting it up initially. I added two extra commands to my “Use Laser” and “Use CNC” macro buttons to toggle GRBL laser mode ($32) and to set the GRBL status mask ($10). The laser mode has to be set right if you want to laser raster images (it turns off movement pauses when the router speed (the laser intensity) changes. I think the GRBL status mask being set incorrectly was preventing jogging in Carbide Motion.
My “Use Laser” macro button runs:
G10 L2 P1 X-812 Y-812

My “Use CNC” macro button runs:
G10 L2 P1 X0 Y0

The X and Y numbers on the G10 line for “Use Laser” will vary depending on what size Shapeoko you have. @AutomatedBrad might be having the same problem as you, I noticed he had a question like this one yesterday but I didn’t have a chance to test and look up my settings till this evening.

What’s the point of that line? It just resets your work zero.

What and where is that located? Settings in LightBurn ?

Updated LightBurn today and the latest carbide motion (Deleted and redownloaded today to try to fix this)

That comes directly from the J-tech setup instructions for Lightburn on Shapeoko, and is used in the “Use CNC” button to reset the origin to the back right where Carbide Motion expects it to be. The “Use Laser” button moves it to -812, -812 (front left on an XXL) since that is where LightBurn wants it to be.

Won’t hurt anything, but I think there’s a misunderstanding with the LightBurn guys. Work zero can be wherever you want it to be.
I’ve seen that create a lot of confusion on their forums.

They are settings in Lightburn, the instructions on settings up the buttons are on step 11 in the J-tech Lightburn instructions. I just added a couple of lines to the macros. The macro buttons are on the “Console” tab of the window on the upper right.

1 Like

This is a step I forgot I even set up when installing LightBurn. This didn’t fix the issue though :face_with_monocle: still when I jog the shapeoko it’s doing nothing or not what I want it to.

It goes toward home every time I jog it…

When I press use laser or use CNC I swas is “starting stream” stream complete in 0:00 is this what you see?

Check your wiring on the steppers. Power off and make sure nothing came loose.

1 Like

So adding the “$10=255” and “$32=0” lines to the “Use CNC” macro didn’t affect it at all? Rapids are working as expected, it’s just jogging that is having trouble?


I see

Make sure the Shapeoko is on and connected to LightBurn when you press “Use CNC”

FYI: When I installed LightBurn, the installation created the macros for me. There are instructions that tell you to create them, but in their latest installs, it’s not necessary.

I decided to just leave my Shapeoko in CNC mode at all times, so as a matter of course, I click “Use CNC” every time I get ready to shut down LightBurn…and “Use Laser” every time I start it up.

1 Like

Japi42 added the code you suggested (didn’t comprehend this earlier) works !!! Dude thank you!!! This is a expensive hobby ppl in the forums are awesome always helpful.

OK Good. That’s the same code in my Use CNC macro. Just make sure LightBurn is connected when you run it. As I just posted, I run mine as the last thing I do before leaving LightBurn.

Here’s how I verify my setting when going from Light Burn to using the CNC.

  1. Redo your CM initialization settings for your Shapeoko model.

  2. Open the log/clipboard menu.

  3. In the Midi, type $$.

  4. Copy the grbl default settings to note pad.

  5. Exit CM.

  6. Open Lightburn.

  7. Run your Laser macro.

  8. In the Lightburn console, type $$

  9. Copy the grbl settings to notepad.

  10. Compare the CM and Lightburn grbl values.

  11. On Lightburn, make a macro for CNC and undo the $ grbl values that light burn changed.

1 Like

I’m glad I could help! Make sure you add the “$10=0” and “$32=1” lines to the “Use Laser” macro if they aren’t there already or LightBurn might not work as expected the next time you go to use it. I know if $32 is set wrong it will overcook the edges of filled shapes, and probably do bad things if you are burning a photo.


I am in information overload already with the CNC maybe I should waited for the laser upgrade :face_with_raised_eyebrow:. Again thanks for the help all. Seems like it’s always something I’m trying to figure out. Off to figure out why my machine is cutting above my zero :joy:.