Z Axis not moving as much as Carbide Motion says it is


I am very new and just bought/assembled my first cnc (Shapeoko 3 XL). During setup, the Z-axis was reversed, so we had to use $3 = 0 to reverse everything. We then reversed the y1 and y2. This seemed to work and allowed the machine to home. We were trying to do the introductory “hello world” project. We got the x/y to go to the bottom left corner of the paper, however we weren’t able to get the Z-axis to move down more than around 15-30mm. We looked at the limits and positioning, and I believe we have the right Z limits. However, the coordinates on Carbide Motion said that we were moving 95mm when in reality we were only moving 20-30mm. We got the project to work by using MDI to manually move it down, however even still we weren’t able to move it past the supposed 95mm limit using the “jog” feature. Any possible fixes?


Do you have the correct Z axis selected?
Is the machine configuration for a Z-plus?


Since this is a new install check your stepper motor set screws. One should be on a flat. Also make a mark across the end of the pulley and jog your machine and recheck that the line across the motor pulley and shaft are still lines up. The machine is commanded to move and it does but there is no feed back if it does not move as far as commanded. So start with the basics and check belt tension and set screws. Since you have been changing parameters you should go into the MDI interface and type $$. That will show the configuration and post that here. You could have accidentally changed a parameter you should not have.

If you get your machine working do a belt calibration. The instructions are in the wiki but basically you draw a square box about 4 inches or so and cut it and then measure it. It should be exactly 4 inches. If it is off by a little then you could change the steps of the motors but if you off a lot then look at mechanics. Additionally make a series of these boxes and if they are inconsistent then you have a mechanical problem. If they are consistent then it is a calibration issue.

I made sure the configurations were for z plus

Sounds like you have it set up for a belt drive.
If you check your $102 setting, I’d guess it’s set at 40. It should read $102=200

Configuration on the newer versions is a two-stage process, please see:

1 Like

Thanks! Worked like a charm

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.