Z motor goes backwards - Initial setup

New XXL Shapeoko set up - initialization fail

here’s a fun one I discovered after several steps of head banging…

Finally realized why my initialization and homing won’t work even though all motors are connected and all limit switches are working.

When my homing starts, the Z axis starts going down instead of up. It then of course does not find the limit switch, and declares the limit switch missing, and quits.

So why does the motor go the wrong way? The Z carriage and plates are all installed in the right direction. The wiring has been double checked and is connected to the motherboard in the only way possible (BTW I cannot for the life of me understand why the wiring harnesses leaving the motor and leaving the motherboard are 2 different sets of colors! What fresh hell is this?)

I am left with only one conclusion: this motor is wired wrong. Or the motherboard wiring is wrong. But if that is the case, then all my motors are backwards, because they are all wired the same way. But I won’t know about the X or Y until it gets past the Z step, which I can’t do with the motor going the wrong way.


try the following first:
Go into carbide motion, the settings screen (the sprocket at the right top)
make sure that you pick the rigth type of Z axis, and then use “Send settings” to send the data to your device.

Some Z axis types work in the opposite direction from others, and the machine needs to know which way to go


Please see:

I’ve never heard of that message… Can you get a screenshot?

Meant to say “can’t find limit switch” - I got the problem solved, thank you

Yup - that was it - I am frustrated by having a manual that predates Motion 5 - so the choices were changed, and you would think that after installing belts on my machine I was safe selecting “belt driven” - but that would be incorrect. It’s Z plus - would have been nice to have that noted in an addendum from Carbide 3D to save me the 3+ hours of troubleshooting that worked backward to this solution.

1 Like

Yup - it was in configuration - thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.