An issue with CM build 542

Good Afternoon,
I recently updated my Carbide Motion to the 642 build. the machine is now popping up new windows and not doing what I am used to. Before, I would find my 0,0,0 point, install the program for cutting. It would go to the Bitsetter, and get the depth of the bit, then move to the front-center and request me to turn on the router and to what speed. After doing that it would begin cutting.
Now, it is giving me some “would I like to measure the tool before jogging” message. I have clicked (yes) and tried it again and clicked (no).
It doesn’t jog at all it is still at the 0,0,0 point and telling me to turn on the router at the proper speed. I hesitate because the bit may be lightly touching the wood just a hair at that point. I don’t want to start spinning the bit and cause it to mark the wood.
Also now, when it is time for a bit change, the router comes up from the wood surface and tells me to change the bit. It is only an inch or so above the wood surface, it doesn’t jog forward and give me room to make the bit change.
Is there a way to override these commands? or what am I doing wrong? or do I have some setting incorrect.
I called Customer Service and talked to Eugene, but I don’t think I explained myself well enough for him to understand what my issue was. Also I told him I was using CM build 537 previously, but he was not familiar with that build he told me.
I know this got wordy. Let me know if I am not explaining myself well enough…

Thank you in advance,


With the new version you will need to acknowledge the prompts, and then you will gain control of the machine and be able to jog as desired.

For the endmill change, you will need to have a suitable post-processor selected in your CAM tool (for Carbide Create it’s “Carbide 3D Shapeoko”) and have a BitSetter installed, enabled, and configured.

You should be able to go back to 537 by uninstalling the new version, then reinstalling the older version from your Downloads folder.

Thanks Will. is that the fix though, go back to 537?

If you don’t wish to have the prompts which are now standard, yes, you will need to revert to a previous version.

This assumes that you had 542 correctly configured.

Well, I looked in my computer’s download folder to see if I still the file for the 537 build, and I don’t. :face_with_symbols_over_mouth:

As far as settings, I believe I have this 542 version set up properly. I guess I’m not sure what settings have changed?

I see folks here having issues when installing a newer version of CC or CM. My experience with SW has been if it ain’t broke don’t fix it. In other words unless there is some feature of CC or CM you need or a bug in your version I wouldn’t upgrade. Typically you will find when there is a newer version of any SW it includes bug fixes, but the newer version has new bugs. My position has always been if I’m happy with a piece of SW I don’t upgrade just for the sake of having the latest version. That said, I always download the latest version of CC and CM and keep all the older versions in case I violate Rule #1 and need to roll back to an earlier version. Just my 2 cents worth.

Also, I have a copy of CC 542 if you need it

Good Morning Loren

Thank you, but Carbide Motion 542 is the latest version. I was using version 537.

I understand bugs or fixes, but usually there is a ‘beta’ version for software that is very “buggy”. I figured that 542 had all the bugs worked out.

But looking through the download / changes page of Carbide 3D, Version 541’s change was "- (NEW) Added option to check tool length when entering Jog mode when BitSetter is enabled."

So what I am seeing, in this new version 542, I don’t think it is a bug, but the new programing of the software. I think it is doing what it is programed to do, but that is my question, it is asking me questions I don’t understand, and when I have a bit change, (before - it would move up on the Z axis a few inches and move the gantry forward so I could make the bit change.)

Now when it gets done cutting with one bit and needs a bit change, the Z axis comes out of the wood about a half inch and the gantry doesn’t come forward. It doesn’t leave enough room to pull a bit out of the collet and insert a new bit.

Like I said in my first post, I don’t think I am explaining this correctly. Me trying to explain this is confusing the issue…

for now, I’m going to uninstall Carbide Motion ver 542, and re-install the software. I don’t think that is the fix though. And I’m not certain what setting I have messed up with this new version.

Correct. 541 added some new prompts.

They are listed and discussed at:

Basically, when there’s a chance the tool has been changed the program asks if you’re not sure if you need to remeasure and affords an option to do so.

Well, I deleted Carbide Motion from my computer and re-downloaded it, and re-installed it. I initialized the machine, it used the BitSetter and measured the bit. I get this pop up window.

So my question still remains, what is the correct answer for this pop-up window?

If you’ve changed the tool w/o using the “Load Tool” button, click “Yes” to remeasure the tool.

If you haven’t, click “No”.

I’m curious, could this be part of the problem? I created the project in Carbide Create, saved the G-Code as I have in the past…

Then brought the project into Carbide Motion. Looking at the job info page, it doesn’t list anything under “Tools Used”. Before, the previous version would have #102 & #301 listed here.

I just dont understand why this is not working…

What are you using as a post-processor in Carbide Create under Edit | Select Post Processor?

It should be “Carbide 3D Shapeoko”.


I think…

I have time this morning to check Carbide Create, but I don’t have time to go in the shop and connect the computer to the CNC and cut the project. (I have to go to my real job now.)

And checking Carbide Create it was set to ‘basic G-code’. I have no idea why this changed. I haven’t made any changes or updates to Carbide Create.

I guess i was confused when you told me that several days ago, about what is set in your CAM post processor.

Thanks Will, and I’m sorry for being dense. smh :roll_eyes:


I have the same issues.
If some one at carbide 3d could put together a video on how to do a 3 tool change using the new version an show The screens that go with the tool changes and what to do on each screen I think we as users Know which tool change PP to use. It would be nice if you could talk to aTech persion that has shapeoko4xxl Pro and has run a tool change file that requires different tool to complete the design . Jeff Peters

I’ve been doing this for the boxes I’ve been making:

I’ll do a step-by-step w/ screen grabs this evening — will that help?

Ok Will where do I get the

will that would be great also could you explain how the bit setter works when a cutter pushes down the bottom ( what does it set)
Thanks Jeff

Please see:

The BitSetter works by measuring the length of the currently loaded tool.

When the tool is changed, the Z-axis is offset by the difference between the current tool and the tool which the Z-axis zero was initially set w/.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.