Brand New Nomad 3, Unable to Initialize, Homing Failed


Was hoping to get some opinions on how to resolve the following. I’ve also sent an email to support:

I bought a new Nomad 3, plugged everything in, and on pressing “Initialize Machine”, it moves the Z axis up, then the X axis to the right, and then the carriage stops. Carbide Motion then gives three errors:

“Machine Controller restarted unexpectedly and may be in an undefined state”
“GRBL Error: Homing Failed, couldn’t find limit switch”
“Homing Cycle Failed”

Here is a video of what it does and the error messages: New Nomad 3 Not Initializing - YouTube

I have sent the configuration data multiple times, and I have also checked that the limit switches work by holding a piece of metal to them; the red LED will turn on. I have also been manually pushing the carriage and table back to the center before trying again.

I see this person had the same problem but none of the resolutions in the thread work for me. She fixed it by sending configuration data, which didn’t work in my case: New Nomad 3 GRBL Error: Homing Failed, couldn't find limit switch unable to initialize machine

Any suggestions for the next step in troubleshooting this?
Thank you!

Just replied to your ticket on support — we’ll do our best to puzzle this out there.

What I did not see is you sending the configuration. The machine knows what it is but most of configuration is configuring Carbide Motion to it knows what kind of machine you have.

Connect to your machine but DO NOT INITIALIZE. Go to Settings and configure your Nomad and then in the first tab SEND the configuration. Then try to initialize.

Hello - thanks, I did try this multiple times, as it worked for that other Nomad 3 owner who had the same problem in the other thread. I am connecting, pressing send configuration, accepting that it will erase machine calibration, and then initializing. The machine will then go up on the Z axis, go right on the X axis, and then trigger the limit switch and abort.

The GRBL Active Inputs is correctly showing that X is being triggered when the carriage gets stuck. It is also correctly saying “No Active Pins” at the beginning of the initialization.

Still stuck on how to resolve this one - I noticed that when my carriage goes to the right, my table (Y-axis) doesn’t move at all, like how it’s supposed to in a video I saw of a normal initialization.

There was one time I managed to get the table to move - that was after I turned the machine on its side to look at the bottom. That time, the table moved all the way to the front and then triggered the Y limit switch, and aborted initialization. After that, the carriage keeps homing Z, then goes right and gets stuck and the table never moved again - back to the original problem. It’s like something shook loose during shipping and then I shook it back into place when I physically moved the machine, but there wasn’t a permanent resolution.

I am nearing the end of the return period of this device and will likely return it to the vendor - one of the main draws of the Nomad 3 was the supposed seamless out of box experience.

I am returning this machine - I have asked on multiple social media platforms for next troubleshooting steps, and despite public promises from Carbide 3D to resolve this, privately, I have been completely ignored by the actual support staff on phone and email for a week. I have responded immediately to their requests for pictures and more info, and then there has been no further response from them. It is a shame because it seems like there is a very helpful and creative community here and on Facebook, but ultimately the manufacturer should at least give some support for a device defective right out of the box. Caveat Emptor.

Not sure why things didn’t move after mentioning this on team chat — I’ve done so again — hopefully we can work out something during the weekend.

If not, please accept our apologies for having fumbled this so badly — it’s not typical, but we are human, and sometimes things go wrong as they have here.

EDIT: We have asked that you send the machine directly to us for repair.

I know this is an old-ish post, But I have run into the same issue. If my X or why is at the limit switch when I try to initialize, the CNC it will fail. What I have done is turn off the Nomad, then give a firm push on the build plate or the gantry plate to move it an inch or so. Then it clears it up. good luck,

1 Like

I too have noticed initialization fails if the switch is active however running a second initialization fixes it without the need to manually move anything.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.