New Nomad 3 GRBL Error: Homing Failed, couldn't find limit switch unable to initialize machine

Hi All, I just received my Nomad 3 and followed the tutorial, removed it from the box, cut the zip ties, plugged it all in, downloaded and installed the software. Opened up CM and tried to initialize the machine and I get the “GRBL Error: Homing Failed, couldn’t find limit switch.” So I have a brand new nomad and haven’t seen it move yet. It tries to move when I push the initialize button. It vibrates and makes an angry burrrrrr sound for a few seconds then I get the error. I put a piece of metal near the x, y, z axis and they all turn on the LED on contact so I’m assuming all the limit switches work. Maybe I’m doing something wrong? This is my first time with this machine…I’ve emailed support and tried calling support but so far no response (emailed wednesday night so maybe I’m just being impatient) but I thought I’d post here to see if anyone can help while I’m waiting for support to get back to me. I was just so excited to start and now I have the machine and can’t do anything with it.

Thanks all!
video of nomad trying to initialize

Did you attach anything to your base plate?
I used my threaded table screws for the mdf wasteboard on accident yesterday…
And the screws were so long it stopped my base plate from moving.
The length of screw was too long and hit the floor.

Check back in if this doesnt help

1 Like

I didn’t attach anything yet. I was just trying to get the machine to home but it won’t move in any direction…But I’ll remember that for the future when I can get this to make some moves.

1 Like

Next make sure you aren’t accidentally engaging your limit switches.
Turn the machine off and physically push x and y axis to center.
Put the z wherever.
Then power on.

I added a short video link in my original post to show what the initial error looked like.
I physically pushed the z to the middle and it went down towards the base plate and did the vibrating and burrrrr thing again and the same error came up.

1 Like

Haha that sounds like your y axis getting stuck.
Pull the table towards you and center that.

Your spindle left to right is x
Table is y
Spindle up and down is z

(Not laughing at you btw.
Just reminds me of things I do with my machine)

Nope, moving the table produced the same error as the initial error. Nothing moved the spindle just did the burrrr vibrate thing the table didn’t move at all.

Could you send another video or picture with everything centered?

I was changing my main-board, motor and motor controller on my Nomad 3 today and had some similar issues after wiring wrong.
Maybe not so much fun disassembling the machine and opening the control box before you even get it to move. But something might be wrong with the stepper driver plugs.
They are labeled Z Y1 Y2 X and i swapped Z and X. This caused the X axis to go the wrong way.
Might be faulty wiring…

1 Like

Thanks for your help. Had to leave and continue troubleshooting later tonight. Will send a pic then

1 Like

ohhh. thanks i’ll check it out tonight

1 Like

Wow I didn’t think it would have been something so involved.
Good find

1 Like

When the machine does it’s initial homing does it usually travel up the z axis toward the limit switch? After I moved my spindle up towards the middle and hit initialize it moved down…so that might be an indicator that it is wired wrong and traveling in the wrong direction. Since I haven’t seen a successful homing I didn’t think about that.

1 Like

Sorry I was leading you wrong dude.
What an odd problem.
I wonder if the machines are checked before they are shipped.
My v2, for example, was always non repeatable;
I thought it was tool deflection.
Turns out I had burrs in my baseplate.
And the screws on the v2 baseboard (is it a baseboard? Whatever the plate is referred too as) are tiny and maxed out.
Had to use a torch to get them out and I still stripped one.(those torches for cooking work so good for small bolts)
Used the cnc to cut itself free.

Keep us updated if you can,
I am curious.

I really thought it was your y axis being too high.

1 Like

Hmm probably not good to have that exposed. I’m going to ask them for a new wires for this one

As far as I can tell visually and after following the cables looks like the x,y,z are in the correct connectors labeled x,y,z

Wish they would respond to my email so I can get this machine up and running!


Damn… Those wires don’t look good…
That is really bad QC…
If you still need a reference to the initialization cycle. it is HERE


Both of your e-mails have been received, and assigned, and then re-assigned due to a recently implemented escalation process — I’m tagging the folks who have Nomads (still waiting on mine) and hopefully someone will chime in soon. It might not be 'til Monday, depending on staffing.

1 Like

Thanks! I’ll update you guys on Monday when I hear back from the support team.

Thanks for the video. Yup my spindle heads down and away from the limit switch when I start the homing sequence so maybe the motor is wired backwards or the software is telling it the wrong direction.

Did you send the configuration? Usually on Shapeoko when the Z travels the wrong way the configuration has not been sent (new machine) or the wrong configuration has been sent (Z-Plus/HDZ). Because you have a Nomad there is only one Z option but you still have to send the config.

Connect to your machine and do not initialize, go to settings and pick your machine configuration and go to second tab to check any options you have, then go back to first tab and SEND configuration.