Carbide create missing materials in material drop down list

I’m a new owner of the shapeoko XXL and have been tinkering with the software. And noticed that in carbide create 4.0 when setting up my material I only have 4 to choose from. Aluminum hdpe MDF and one other. But looking at videos and tutorials I see that there are loads of materials in this drop down list.

I have tried reinstalling and to no avail I still only get the 4 materials.

Any advice on how to fix this?

This is the result of Carbide Create changing from calculated feeds and speeds to a curated set of feeds and speeds which are still being tested/developed, and are being released with updated versions as they are ready.

For speeds and feeds with a 1/4" endmill please see:

(there’s a row matching dial settings to RPMs at the bottom)

There’s an interactive version at: https://public.tableau.com/profile/willadams#!/vizhome/Carbide3DCNCFeedsandSpeeds/Sheet1?publish=yes

See https://www.youtube.com/watch?v=S9bceJxpqG0 for concepts on this and see the series #MaterialMonday: #MaterialMonday on YouTube for specifics.

You should test feeds and speeds in a piece of scrap using the technique at: https://precisebits.com/tutorials/calibrating_feeds_n_speeds.htm

Another consideration is Climb vs. Conventional Milling and tooling engagement — where possible avoid slotting and add geometry and cut as a pocket (Adding geometry to cut as a pocket with a finishing pass ).

Extensive discussion at: Origin/consistency of chipload recommendations and https://shapeokoenthusiasts.gitbook.io/shapeoko-cnc-a-to-z/feeds-and-speeds-basics with a spreadsheet for this at: Speeds, Feeds, Power, and Force (SFPF) Calculator