Carbide Motion: BUSY (Shapeoko 5 Pro)

Carbide Motion Build 597
Windows 11
File created with Carbide Create 743
Machine SO5
Using the included USB cable

In basic testing, CM has been responsive and acting normally. I was able to set up Bitsetter and Bitzero and jog and rapid the machine.


  1. I created a test file in CC with the Carbide 3D Shapeoko post processor. Units are Inch (same as machine config in CM)
  2. Initialize the machine - Everything is fine
  3. Set the tool with bitzero - Everything is fine
  4. Run the program - Up to line 17 everything works.

Line 17 is G1Z0.4600F12.0
Motion controller hangs and CM shows BUSY

This has repeated after computer reboots, swapping USB cables, controller reboots… Not sure if other people have seen this or have a solution

Without exception every time I see this something is hogging computer system resources… usually the 10th Windows update that week. :confused:


I feel like this is going to ultimately be a bug in the software. My SO5 is similarly randomly stopping mid cut (busy). It’s happened on every file that I’ve run today.


I appreciate your advice Josh. The laptop is a new HP. For grins, I turned all the windows power settings to the max, rebooted, disconnected from wifi, turned off Bluetooth, disconnected all USB other than the controller. No user apps running other than CM and task manager

CM still hangs at line 17. CPU shows <10% and memory at ~50%

1 Like

Also tried disabling Bitsetter and Bitzero in CM. The problem remains :frowning:
Email sent to support just to log the issue

Same issue with my SO5 4x2. I reported it earlier today. Hopefully, there will be a quick solution.

Mine has run around 8 test cut files no problem. Hopefully tomorrow I will be able to run some more complex files.

1 Like

I’ve run many jobs over the weekend and all of them have failed at some point. I ran my file normally and it failed about 20 minutes in (busy). I removed my dust collection from the equation and ran the same file. Again, it failed around 20 minutes in. I then did an air cut without dust collection and the router off. The file ran to completion, about a 45 minute cut. Then I ran the air cut again with the dust collection on and again the file ran to completion. I then cut the dust collection back off, turned the router on, ran the file again with just the router and the machine. The file again failed about 20-30 minutes in (busy) displayed on screen. I’m not sure what’s going on🤷🏻‍♂️. I ran two previous machines a Shapeoko xxl and a Shapeoko 4 pro. Never had any issue on those machines.

Is there supposed to be two F’s?

1 Like

Good eye. Only one F in the generated gcode. Edited the original post to fix my typo

1 Like

I opened up the log file while trying to run again. This looks very much like a comms error over USB. The hang always occurs when CM does not see an “ok” response

I tried changing the USB COM port from 9600 to 115200. The program ran much further, but still hung eventually.

Editing this post to avoid confusion. The following are current in January 2023 and not likely to be part of the issue.
$I results

Josh, are you running Carbide Motion? CM build 578? Windows, Mac, Pi for the OS? Support asked for msinfo32 from my computer, but has not come back with any ideas yet.

If your SO5 is working, just trying to find the difference between my setup and yours.

I’m working on imaging a Raspberry Pi with CM today to try and see if there is a differential from Windows 11

Chris- Can you try this build and tell me if that fixes it?


I did just get the Raspberry Pi running and it made it through the full file! At least I know the machine, controller and USB are clean.

Thanks Rob. I’ll test that out this afternoon and report back as soon as possible.

1 Like

After putting a Raspi together to run my Pro4, I haven’t had a reason to run it with anything else.

580 does not fix the issue :frowning: I downloaded it, installed and tested. Machine still hangs with the test file
test1 circle.c2d (96 KB)

Then I rebooted everything. The program ran for a different length and hung.

Software shows Build 580, but COM port driver is still at 9600-8-N-1

Agreed Steven… If only RPI’s were not rare as hens teeth. My octoprint want’s it’s server back :slight_smile:

1 Like

I was running 579 on Windows.

I ran a project last night and it hung up once in around an hour of cutting MDF. After I restarted the machine and CM, I ran a ground from the grounding block to a plug with ad ESD cable. I restarted the same file and it ran to completion. I also don’t have anti-static dust collection hose. So I have that set to be delivered tomorrow and I will ground it.

Interesting concept. I measured from my grounding block (with the green/yellow bananna plug connected) to the power ground and it was ~1V AC

Pretty sure this is not the issue since the Windows laptop USB is floating with respect to ground and so is the Raspberry Pi. On the other hand, I’m willing to test since others have tried supplemental grounding.