Carbide reporting XY position DOUBLE the scale of actual position

After setting 0 and jogging 16 inches in positive Y, Carbide Motion is reporting a Y position of 815mm (approximately 32 inches) which is exactly double of the actual position! Please reference the images below. This is super strange - please advise. Thank you for your time!


Carbide Motion v3.0.368 Build Date 2017-10-20 OS Windows 10

Sounds like your settings might be off. Did you calibrate your machine and set your steps/mm values? Specifically, your $100, $101, and $102 values?

See this post on Calibration: Help with calibration

And here’s an image of the actual position:

Do you have an old machine w/ an old control board?

If so, does it have DIP switches?

If so, at a guess they’re set to 4x micro-stepping — please power down and switch them to 8x.

Hi Adam, thanks for your help!

I entered ‘$$’ into the MDI and the log window showed the values of $100-102 to all be 20. I set all three to be 40 and it looks like the jog output is matching the physical travel. I think we’re in business.

Thanks again!

Hi Will thanks for your help. I’m not sure how old the machine is as I’ve inherited it (it was purchased a while ago but never used). As you can see in the thread changing my $100-102 values seems to have worked. Do I still need to worry about the DIP switches? I assume these can be accessed by removing the shield mounted to the rear of the gantry?

Correct, you’d need to remove the electronics enclosure to access them (not a big deal), but 40 is the right value for 8x micro-stepping which is what’s suggested, so you should be good to go.

Awesome, Will. Thanks again.

(Just ran my first program - dimpling the spoil to register hold-down screw locations - worked perfectly!)

1 Like