Error (1) error in line 20: arc endpoint error?

Thx for finding that article Griff. I’ve been busy past couple days with in-laws…lol!

I know installing the post processors are a pain. Took me a long time to figure it out too.

1 Like

I can’t get the openbuilds post processor to work either on cm 4.10… Is there going to be an update to the Carbide3d post processor?

Hmmmmm, I wonder why. I’ve been using that post exclusively for CM 4.410 since my last comment above. Works every time. Just have to get used to it starting the job the instant you hit START (no tool change dialog). I like the fact that when the job is done it just raises the spindle and stays put, no auto home cycle.

1 Like

This is the gcode I produced in F360: (70.6 KB)

If someone gets a spare moment and could see if it loads for them in cm 4.4.10 I would greatly appreciate it!!


I just ran your gcode on CM version 4.4.10 and received the following error: “ERROR (6): Error in line 56: Bad Arc Format, No I/J”

Reference attached screen shot.

I’m experiencing this issue as well having just updated GRBL and Carbide Motion.

Would welcome solution as community identifies.

1 Like

Tried your file, got the error.

Sorry, don’t know what to tell you. You are sure you are using the f360-easel.cps?


I just also ran your on version 4.4.07 and received the same error. My file, which did not work on v4.410 did run on v4.407. Both used Carbide3d PP out of Fusion360. My error code did not include the No I/J just the Bad Arc Format when attempting to run in V4.410. May run down the No I/J error and try your code on v4.4.07.

1 Like

ahhh I was using the openbuilds cps file not the easel one! This is post processed with the f360-easel post processor: (326.1 KB)

Even if the easel post works it seems a bit ridiculous if the Carbide3d post doesn’t work with carbide motion… Pls fix this Carbide3d!!

That one loaded ok. But as soon as I hit Run it immediately threw a Door Open error and Limit Switch hit error.

This is so weird… I’m just going to use bCNC until Carbide3d fix this :slight_smile:

I’m gonna send another email to C3D - the other post processor does not work. I can’t used CM and probe and have jobs to do :frowning:

Thanks for posting this code, we’ll try to take a look at it on Monday.

The current build of CM requires both I and J to be defined and this gcode doesn’t do that. We’ll see if we can get it updated quickly.


Thank you for your response.

Here’s a test build for everyone to try:

It’s got the potential to open up other bugs so we’re not eager to post it on the main site before a big holiday. Let us know if it works for you.


I just got in from work and have downloaded and loaded a program using the original post processor - it’s not throwing back any errors! :slight_smile:

I will run a complete job in the morning, but this looks promising.

Thank you for turning this around so quickly

1 Like

Nice. Been working other projects this past week, I’ll give this a shot soon.

Your file ran fine on 411. FWIW.

1 Like

Thank you for such a quick turn around! not getting any errors now!

Thanks for the feedback. We’ll try and get it released to everyone on Monday.