Finished size issues

Please see:

I got back to my machine after work and thought I would try a test with carbide create to see if my issues were based in fusion360.
In CC I inadvertently set the tool path zero to center. When I ran my 1" circle and 1" square the router ran directly to the front. I hit the power switch as soon as I could, I don’t know if it crashed or not. However, now the manual jog doesn’t work. Rapid Positioning works as does the Homing Cycle but when I click on X,Y or X I get nothing.
I thought I read to go to MDI and send $20=1 and $21=1 and $22=1 but nothing seems to happen.
I am running CM Build 4.0.416.
How do I get my manual jog back so I can get back to working on my other issues.
I have restarted CC,CM and my computer. I have nothing else running.

Mystery solved, at least my latest issue about manual jog. Sometimes I overthink things.
My jog was set to .01 mm and I didn’t notice it.
Now back to my size issue.

2 Likes

Back to my size issues.
Using CC cutting a 1" square and a 1" circle with a .25" sq end mill I am getting a .983 x .967 square and a oval .993 x .968 circle.
The movement by hand in the x axis is a bit tight and a little bumpy. Does sawdust get caught up in the v rollers and the belts? When I clean those should I expect better accuracy.

  • have you checked whether your machine is square ? when you bring the gantry all the way to the front, or all the way towards the back, do the Y plates contact the front plate on both sides at the same time / with no gap on one side ? If not, you will probably need to go back and fix that first.
  • manual movement of the axis : if you move it slowly by hand, is it smooth ? The “bumpy” part of it can happen if you move it faster, then the stepper motors start generating energy which flows back in the controller, and that’s normal. If it really feels too tight, maybe you tightened the eccentric nuts too much. Check both X and Y axis.
  • measuring the dimensions of one pocket is ok, but to take the endmill dimensions out of the equation and minimize the measurement error, it would be better to cut several pockets, aligned along X and Y axis, spaced e.g. 10" apart from each other, and measure the distance from edge to edge, like this:

(ignore the “depth” arrow for now)

It looks to me like the ~0.99" for 1" on X is ok and belt calibration will take care of the residual error, but 0.97" for 1" on Y is a bit more suspicious, so I would first check the Y axis mechanically (eccentrics, belt tension)

THEN once you are confident that mechanically everything is fine (square and smooth), you can start adjusting the $100/$101/$102 parameters following the procedure @WillAdams mentioned earlier

When moving by hand, if the wiring is attached the stepper motors will generate current which will occasionally cause a movement to the next full step position — please don’t push the machine hard enough to cause that, it can damage the electronics.

To adjust see: https://docs.carbide3d.com/support/tensioning-eccentrics/

Yes, if dust and debris get caught up on the V wheels, V extrusion, belts, or pulleys it can cause problems — please keep the machine clean per: https://docs.carbide3d.com/general-faq/machine-operating-checklist/

Thanks everyone for the advice you have given.
I recalibrated my machine as best I can.
The bed is square within 1/16 on an inch.
The X gantry touches almost the exact same time, the right side touches leaving less than a 1/16 [f an inch. I don’t know how to get it any closer or if I need to.
It appears the back of my waste board is about 1/8 of an inch lower than the front. Is milling it the only way to adjust that?
I have cleaned everything and re-tensioned all the belts.
Now when I run a square and circle test I am only 1.5-100ths short on X and 2.5-100ths short on Y.
I am almost happy with these results since I am only cutting wood projects with high tolerance but I know as time goes on I am going to want more accuracy. I am sure I can adjust the offsets to get where I would like to be but I dont think I should have to.
I don’t think understand what the $20=1 grbl and the like is all about.
Where do I go from here to find more accuracy?

Please see:

@ScottB:

You can certainly cut a lot of projects just fine with machine squaring being just 1/16" off. In case you want to get it perfect, you can shim the ends of the X-rails. I wrote a bit about this here:
https://shapeokoenthusiasts.gitbook.io/shapeoko-cnc-a-to-z/squaring

The 1/8" front/back height difference on your wasteboard can either be addressed by surfacing the wasteboard, or by going back to mechanical assembly and checking/adjusting the leveling of the two Y-rails with respect to the steel plates (but it’s a pain in the neck to do this after initial machine assembly)

Now that you are within 2/100th of an inch of the expected dimensions, the belt calibration procedure that @WillAdams mentioned OR using offsets in CAD will get you there. I have written a bit about this also as well as other sources of dimensional inaccuracies here:

https://shapeokoenthusiasts.gitbook.io/shapeoko-cnc-a-to-z/x-y-z-calibration

To do the belt calibration thing, you will need to play with the GRBL settings ("$" parameters) in the MDI console, but it’s easy enough, and you don’t have to understand them to adjust them.

1 Like

Thank you guys for all your help.
I followed your advice and now I am within 2 or 3 thousands. I wasn’t sure if I believed i could get it that close. I am very pleasantly surprised.
I thought I would show you the first real project I made. Its a suction boot. I know I can buy one on line that is probably better but the learning experience has been well worth the effort. And I made this one with no $ out of my pocket.!
(Not sure if I uploaded photos properly.)

1570550101462884121706|375x500

2 Likes

I’ll try sending another photo!
Thanks again.

20191007_160755|375x500

2 Likes

making a dust shoe is something of a rite of passage, congrats ! :slight_smile:

2 Likes

I still have alot to learn.
In fact could you point in the direction of leveling my waste board?

Here:

I wrote a bit at: Notes on rapid positions and wasteboard leveling

Hey guys I am having some issues surfacing my waste board.
I created a toolpath in CC to start in the center of my 16x15 waste board. From left edge center to right edge back i as off about .02 so I set my toolpath about .025. Everything was fine until it reached 13.25"x12" and stopped. It showed an error (14) Limit Switch Hit. So I start over and home my machine. I do a rapid move to anything on the left side and and it seems tp hit the left frame and I can hear the stepper motor jolt or the belt skip not sure what’s happening. I do a homing cycle again (by turning off and on the power then re-connect and hit jog it of course asks to do a homing cycle). Then it does it all again. Do I need to reset my home position? And how do I do that? It acts as if it thinks my x is longer than it is. Is my toolpath in CC to large?

Hi Scott,

Yes your toolpath is too large. The wasteboard needs to be slightly smaller than the advertised cutting area, or the router won’t be able to reach the edges while surfacing, as you found out the hard way.

By default in the Shapeoko, the "soft limits"in the controller are not enabled so the controller itself will let you happily crash into the left side of the machine if you command it to (and I can’t remember how/if CM enforces travel limits, you may want to double-check if your shapeoko “configuration” is correct in CM, there is a dropdown list for selection SO3 or XL or XXL)

The actual max travel along X and Y that one gets on their shapeoko depends on a variety of things (e.g. whether you have dust boot arms mounted on the sides of the router, etc…). What you can do to figure out the max possible dimensions for your wasteboard is to jog manually to each travel limit, make a note of the current machine X/Y position there, and do the math.

1 Like

Thanks for the quick response. (Do you guys ever sleep?)
I measured the size of the useable space on my waste board by manually jogging in X,Y,+and-. I penciled a mark and used that as my size in CC.
I believe I could jog the machine around and finish the remaining couple inches.
Even with no toolpath loaded, after homing on any west rapid position it crashes into the west plate. Something must be amiss with the Home settings.
BTW what machine do I have? Its total size is 28"x24"? What should be my working waste board size?

1 Like

We are fortunate to have an international group here, so someone is usually awake somewhere.

28" x 24" physical size should be an SO3:

https://carbide3d.com/shapeoko/

Footprint: 28-1/2″ W × 24″ L × 16″ H

so you should have ~

Cutting area: 16″ × 16″

(but note that several inches along the Y is the overhang area at the front of the machine and is unsupported)

I wrote up a bit on machine sizes at:

https://wiki.shapeoko.com/index.php/SO3_Function_Test#Shapeoko_3

so ~5mm + 400mm + 5mm × 9mm + 350mm + 15mm for supported — add 50mm or so for the unsupported area (but note that the front rail is in that area as well).

Go to the Settings page in Carbide Motion, make sure “Shapeoko3” appears in the drop down list (not XL or XXL), click “Send Config Data”, and rapid position to West should not crash anymore. It seems to me like your Shapeoko is probably currently configured as an XL or XXL, hence tried to reach a rapid position that is way beyond the limits of the standard shapeoko

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.