Fusion360 Machine definitions revisited

@Julien How did you select the correct parts for the axes movements?
Can you share your model?

Turns out it was a known bug (this is a preview after all) and the unmodified machine definition was cached/not refreshed hence the error. So I have a modified post that’'s compatible, but now the simulation has the machine in the wrong orientation and it’s moving the whole machine around the piece. My test file is so messy right now that I won’t share it just yet, I need to restart from a clean state and will share then

Moving parts selection is also kinda buggy, I had to add the (~60) individual parts one by one down to the last screw

1 Like

I realized the same. I couldn’t get the XZ assembly to move with the Y.

Did you figure out the “Offset” and “Range” params in the machine configuration ?
I had to use a -xxx for min and +yyy for max to get the axes to move within the Shapeoko model limits, had to use yyy slightly different from xxx, then I tried various values for Offset, with no effect (and offset reset to 0 when re-editing). Sounds like another bug. Or a non-yet-implemented feature. Anyhow I’ll watch the two available videos one more time, just in case I missed something

I was thinking it might be worth losing all the fasteners in that model just to reduce the part count, complexity and how long it takes Fusion to handle things with it.

1 Like

Possibly. But right now Fusion does not seem to struggle with the part count on the machine model (and that’s a good thing considering the example video uses a Haas VF2 model, slightly more complex than a Shapeoko :wink: )

But I’m not doing it right (yet), and the simulation is an epic fail so far:

First off, the machine is oriented correctly when in machine builder (as illustrated in my previous video), with the X/Y/Z axes as one would expect. But still, when I select the machine for the simulation, it shows up oriented like this (which is how it WAS oriented in the original model, but then I rotated it in machine builder). That’s mystery #1.

Mystery #2 is why the simulation does not move anything on the machine model, and rather moves the stock. I’m sure it’s something I did, and I’ll probably post on the Autodesk forum, just not tonight.


Ah, that’s probably my fault, I think the whole thing has inherited the XZ plane as the backplate of the HDZ as that’s the first thing I drew and I didn’t know how important that was to start off right when I did that.

Perhaps Fusion is just programmed to be snarky about machines that weigh less than 5 tons and say they shake around when trying to cut the stock :wink:


Not sure it was worth it, but I’ll sleep better tonight.

Model HERE. Not sure yet if all of the Machine Config comes with it.
I just used the generic machineSimulation post. I did not bother with updating the one I actually use. I’ll evaluate the potential value of this later.


Awesome! And this frees up my evening today, even better.
I’ll download the model and check out the model definition you used.


@neilferreri That looks great!


Anyone confirm that the machine definitions are attached to the file?
@Julien The key for me was realizing that I had to drag axes to the spindle on the machine definitions. Least intuitive thing I’ve ever done.

1 Like

If it’s this, then yes

Ha. Would never have figured that out. Let’s see if the Autodesk support guy spots it immediately too.


When your own support team can’t figure out how to use your new feature you know you’ve got a UX problem …



Here’s the weird, non-intuitive part that needed to be changed. Who knew you could drag and drop the axes? They all need to be moved to “Spindle” which makes sense (once you get past the UI) as we don’t use a moving table on our gantry style machines.

Exported from the Machine Library Menu. (Too big to upload here)
SO3 XXL Machine Simulation

By the way, @LiamN, is that your SO3 model?


This is really awesome guys, thank you for all the effort!

1 Like


That’s why it’s got the funny T track layout and the extra bolt down braces underneath.

I had a go at loading the machine definition you put together (thanks to you and Julien for the great work) and I think I must be missing something basic.

I can load the file and Fusion comes up in Machine Builder mode, but I can’t seem to put that machine in my machine library.

I tried saving it from the Edit Machine Configuration dialog and then importing it into my machine library in a new file and Fusion got upset

Are there some docs I should go and read about how the machine builder thing works?



Is it just because of the post processor? It’d be nice if that would be packed into the .f3z rather than try to link you to my downloads folder!
This is the one I used.

1 Like

The (single) video about Machine Builder does cover it when he talks about creating the kinematic model, and my mistake was a) assuming that his example did not apply to a Shapeoko because he showed a 5 axis machine with A/B rotations and b) beeing fooled by the fact that the machine preview operates apparently ok the way I had defined it. It does make total sense to “attach” (drag and drop) the spindle under the Z axis in the kinematic model.

I only found those two videos (which do cover a lot of ground)

1 Like

There’s an interesting live stream recording discussing the machine simulation too

Promisingly they state several times that they //intend// to keep machine simulation in the basic, available to all users, part of Fusion. Depressingly they also make it clear that such decisions are above their pay grade.


This topic was automatically closed after 30 days. New replies are no longer allowed.