Help! Shapeoko XXL toolpath

My toolpath won’t stay consistent. I have double checked x y z thickness all the setting in motion and it initializes fine. My problem is I start the tool path and about 30 seconds in it goes hay wire and cuts off path does it’s own thing. Anyone have a similar issue while carving happens with toolpath?

Hi Garrett,
Without more information, the usual guess is that your cutting is too aggressive and you’re losing position.
Can you provide information on your toolpaths, endmill, machine model, Z axis, etc?

I think it might be my settings because i have even slowed it down and it does the same thing. What are the settings supposed to be for the Shapeoko 3 XXL.

And im trying to upload a video give me a sec to figure that out for an easier explanation of whats going on.


Please post the .c2d file and step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes and a photo showing an attempt at cutting still in place on the machine.

A and M.c2d (132 KB)

Securing stock by t track and setting 0 by the left lower corner and paper method for z.

just tried another and it goes off track stuck to the same thing again.

Please help me figure this out will LOL i have so many builds to do for Xmas and now i’m out of service can’t do anything until this is fixed

also single bit no change out its a 1/4" downcut straight

Do you have the original Z axis? The belt driven one?

I have this one

That is a z-plus also refereed to as LeadScrew in configuration.

You are cutting a slot deeper than the flutes on the endmill you are using:

Add offset geometry and cut as a pocket down to at least tab depth:

Change the contour toolpaths to start cutting at the bottom of the preceding pocket:

Attached as a v7 file.

A and M_v7.c2d (252 KB)

I looked at your file and you have a pretty big stepover on the #201 bit.

Here is the stock #201 Softwood parameters

The stepover is 10% so that would be 10% of .25" 0.025

Here is your tool in the file.


You have stepover at 50% at .125 on the pocket toolpath. That may be causing you to miss steps. You are getting a lot of tool engagement and that may be causing you to miss steps.

Maybe try to lessen stepover or use the stock stepover of 10% and see if that improves the performance. You are making a full engagement of a 3 flute bit. Also if you have a #251 (downcut bit) try that but stick with the stock F&S. An upcut bit like a #201 is trying to pull the material up where the downcut #251 is pushing down on the material.


tried your way will on the E and check it out still goes rogue after initial cuts.
Are my shapeoko settings off or what? what could cause this? Is this mechanical you think or a setting ive overlooked?

I feel like this is a setting or computer issue because all the mechanical parts look to be good the v wheels are on and moving the bands are normal and its weird it staying in line and then its like the computer just sends a message and it goes off course without hitting or changing paths or anything.

The possible culprits are:

  • wiring issues
  • mechanical issues
  • feeds and speeds

The file is fine once edited to have pockets.

To check the machine mechanically. Per the machine operating checklist: Machine Operating Checklist - Carbide 3D , the basic points of adjustment for a machine are:

Pulley set screws — verify that these are in-place and secure — for further details on checking them on a Shapeoko 3 see: Checking Pulley Set Screws - Carbide 3D — be sure to check all axes/pulleys (including Z on machines w/ belt-drive Z-axis, for an HDZ, check both coupler screws).

(for the SO3/4, X- and Y-axes) V wheels / eccentric nuts: Tightening Eccentric Nuts - Carbide 3D

(for the Pro, and SO4 Z-axis) Lubrication of the linear rails:

Belt tension (see the relevant step in your instruction manual, e.g., Step 5 Belting - Carbide 3D) Note that the X-axis motor is held in place on standoffs and if those bolts are loose this can cause belt tension issues. Also, belt tension for the Y-axis stepper motors needs to be even/equivalent on each side — a significant difference can cause skipping on one side eventually resulting in lost steps on both. Measuring belt tension, squaring and calibration

Ensure that all screws are in place and secure, esp. on the linear rails on a Pro.

In the video you posted after the machine looses it’s place (while cutting into the stock) it then moves beside your stock and started air cutting and this looked like it was following the correct path but the video wasn’t long enough to say for sure. Maybe try air cutting and see if the machine follows the expected path and if it does maybe it’s related to your settings or maybe something physical on the machine in the X-axis movements. You said the wheels are good but did you check your belt (are the teeth used) or is the the grub screw securing the pulley/sprocket loose allowing the stepper motor shaft to occasionally spin freely inside the pulley.

EDIT: It appears to push through the material moving from left to right but in the opposite direction right to left is where you notice the jerk in the Z-Plus. It’s almost like something is slipping (little force pushing right to left) and the Z-Plus gets pushed around by the rotational forces of the bit in the material.

1 Like

Pulley set screws are always my favorite to check when I see this :slight_smile: