Help understanding what went wrong - Shapeoko 5 pro 4x4

I’m new to CNC’s and just getting my feet wet. I cut a couple of items already and thought I was getting the hang of it, until I tried surfacing my machine. I created a file to surface the machine 1mm and it ended up 4mm off. I don’t understand why that happened, and so I stopped the machine after a few seconds and edited the file in carbide create to remove 0.5mm. I ran it again and it continued to take off the same amount as before, so I just let it run since it would have left a hole in the center anyways. I used bit bitzero on the corner of the MDF spoiler board and probed just the top, so it should have had the correct height and the bitsetter checked the bit height properly at it’s lowest point of the bit blade, so is it a setting in carbide create that was wrong? I’ll attach some screen grabs of the file and the bit.

The other issue that I don’t understand is what happened while surfacing. While the file had the bit start from the center of the machine, I realized after a while that it didn’t start in the center, but was off by about 6 inches from the front. When it got further out near the backside the machine would hit the back and grind, then come to the front and it’s position was off. I went to have a look at the back when it happened and the gantry slammed into the limit switch on the back and bent the entire plastic switch back way past where it should have. Luckily it didn’t break anything, but how was it possible for this to happen? Even if the orientation was thrown off, do the limit switches not keep the machine from colliding into them? The switch works fine when initializing the machine, so why didn’t it stop when it made contact with the sensor in this case?

Now I barely have any wasteboard left which makes me a bit nervous, especially since the amount the bit took off was way more then what I input. I don’t want to have future problem of bits going in too far and hitting the aluminum mdf holders.

Where was the origin set in the file?

How did you set zero relative to the MDF slats?

The switches are used for homing only, not limits.

My suggestion would be to source a thin sheet of MDF and cut filler strips to lift up the current set (but I’m cheap) see:

The origin was set in the lower-left in carbide create. When I jog the machine to the lower left this is what carbide motion shows:

I used bitzero to probe the top of the mdf wasteboard to get the height.

That’s interesting, but why aren’t the switches also used as a safety feature so the gantry never exceeds it’s safe area? Seems like a easy way to prevent accidents or damage to the machine doesn’t it?

I was thinking about doing the same thing you mentioned, finding some thin MDF, cutting it up, and adding it above the current MDF wasteboard pieces. I still need to know why it cut so deep though or the same thing might happen in the future.

I think I see the issue. When you use the BitZero for XYZ, it sits inside the lip like you have it. When you’re doing just one axis, in your case it sounds like you just set Z, then the whole BitZero needs to sit on top of the work piece. It kinda shows that and explains it in Carbide Motion, but not is a way that everyone may fully get.


Ah ok, that would explain the extra 3 mm’s it added since that’s about the height of the border plastic around the BitZero. This was the first time I probed only the height so it didn’t occur to me to put the entire unit on top and not off the edge. That solves the depth issue, now I just need to understand why the surfacing area was off and the gantry was slamming into the back.

If I job the machine to the SW corner in carbide motion, should the x and y read 0? The image I attached has it saying x: 0.329 and y: 0.341. The position was off way more then that, so not sure that’s the issue. What else could have thrown off the Y axis position?

The X ,Y will read what ever you had set after the last time you set zero using the Bitzero. Unless you set the X,Y zero to the Rapid SW position it will show your last known X,Y zero.
I agree with Josh about the Z being off when using the Bit Zero the way it’s sitting in your picture. I did the same thing when I 1st got my machine. :slight_smile: There may have also been an issue when using the Bitsetter, you need to make sure the carbide cutter portion is what makes contact with the pad. (Another mistake I made)


1 Like

So carbide motion retains the last X,Y position I used bitzero on, even after turning off the CNC and computer? I didn’t know that. I thought it reset every time you restart and uses the home position on initialization to get it’s origin. So for future reference, I should have used the BitZero on the SW corner MDF wasteboard slat and probed not just the top but the X and Y using one of the cylindrical bits that would fit into the BitZero to get the coordinates if I’m understanding this correctly.

Also, if that’s the case, I assume the only time you would probe only the top of a material, is if you are cutting multiple pieces that always start from the same X,Y position?

Appreciate all the feedback!

Did you do the forward gantry shift? Or is your machine gantry in the default position?

One thing that just occurred to me. It would make sense that the Y axis was off if it remembered the last position I used BitZero in, but why was the X centered in this situation? I doubt the last time I probed a project it was directly in the center of the X axis.

What is the gantry forward shift?

An option to move the gantry forward to allow cutting in the overhang at the front of the machine.

I suspect your Y-axis issue is that you ran out of travel.

Where would this setting be found? I don’t recall doing anything to the gantry.

It was mentioned in the announcement:

Gantry Shift for Joinery

Gantry Shift

Some users like the machining area to come off the front of the machine to make edge machining, to make tenons or dovetails for example, easier. We’ve added a gantry shift option to the Shapeoko 5 Pro that allows you to move the gantry forward by 3.2”. Users that want a little overhang can get it, while the majority of users get to keep the machining area directly over the table.


I just checked but no, my gantry is in the regular position.

In the jog menu, if you touch (tablet) or click (computer without touch screen) the “Position” it will toggle between the relative and machine coordinates.

Relative is set when you set XYZ. So it will show 1" if you’ve jogged that far away from that XYZ zero.

Machine is the distance from the homing switches, so the absolute zero the machine bases everything off of. So if you jog all the way to the front right, it will show the actual distance you can move away from the back right, and how much of a square you can make.

That is correct. I have actually set 1/4" steel Dowel Pins on both my X and Y on my waste board so I can use these as a constant reference when setting boards in place. That way all I have to do is change my X axis zero. The pins are removable should I need the whole area for larger cut, but 99% of the time I leave them there.


The rapid position points do not map to the corners of the working area.

Please see:

This is the method I used to resurface my 5Pro 4x4. I use Vcarve but I expect the same can be done with Carbide Create. Also, I use the metric system. If you want to use the Imperial system, divide these numbers by 25.4. I used a 1.5” surfacing bit.

Move the gantry so the centre of the bit is at the left edge of the first MDF strip and jog it forward as far as it will go. Set X and Y zero at this point. Set Z at the existing surface.

In your CAD program, create a material setup of X=1207mm Y=1234mm.

Create a rectangle X=1230mm Y=1261mm. Centre this rectangle over the material. Since it is larger than the material, it will extend past the edge of the material on all four sides. The toolpath created will use this rectangle as the outer limit of the cut. We need it to be bigger than the specified material size in order to clear the corners and to make sure the full length of the surface is milled. Because we’re using a 1.5” bit, the centre of this bit will be 3/4” inside the surface being cut thus keeping the gantry within the travel limits of the machine.

I used a depth of cut of 1/32”. If that doesn’t clean it up, re-zero and run the toolpath again. Also, please don’t forget to remove your bitsetter before you start the job. The cutter will shred it if you don’t get it out of the way.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.