Losing position during cut

Machine 4xxl
Im pretty new so im guessing/hoping this will be something simple but ’ve been having trouble with my machine losing position during a file typically I start seeing problems right after a tool change.

I’m using vcarve pro and carbide motion both the most current versions. I have checked to make sure everything on the machine is tight including the belts, all bolts and vwheels. I have tried using different usb ports on my pc. With and without dust collection and nothing seems to be helping. Even tried a laptop instead of the tower I typically use. Grounding supplied with the machine is tight and made sure to remove finish to ensure good contact.

Place material
Secure material
Initialize machine with bit setter enabled
Zero on stock with bit zero v2
Start job
Insert bit as prompted
Bit zeros on bit setter
Start router and the first set of paths is fine
Turn off router as prompted
Change tool as prompted
New tool zeros on bit setter exactly where it should.
Start router
Machine runs and starts in the wrong area of the stock and ruins the project.

I’ve noticed that I seem to get very jerky movement from the machine whenever this happens and that I can’t even jog it back to remove the bit without turning off the machine and booting everything back up. This has been happening more often than not (4 out of 5 carves probably) and has happened on multiple different files that I have created (same file reloaded will sometimes complete as programmed and shown in preview of design software). Very frustrating because I’ve ruined several hundred dollars worth of wood at this point trying to troubleshoot the issue on my own.

Gcode is being created using inch automatic tool changer post processor and carbide motion is set to inches as well.

Machine is in my garage which is heated to 65-75 for about an hour or longer before I start to run anything. Humidity is pretty high currently as we had a big rain storm so I wouldn’t think it would be a static issue.

Usually this is a mechanical issue.

Note that there is a troubleshooting video: https://youtu.be/tnWFB9iW8Sg?si=5MtGVaj7N-O51_ab

Per the machine operating checklist: Machine Operating Checklist , the basic points of adjustment for a machine are:

  • (for belt drive machines) Pulley set screws — verify that these are in-place and secure — be sure to check all axes/pulleys (including Z on machines w/ belt-drive Z-axis, for an HDZ, check both coupler screws).
  • (for the SO3/4, X- and Y-axes, and the belt-drive Z-axis on Launch and summer 2016 SO3s) V wheels / eccentric nuts (per assembly instructions)
  • (for the Pro, Pro 5, HDM, and Z-Plus and HDZ Z-axis) Lubrication of the linear rails: CNC Machine Maintenance and the video https://youtu.be/SE-36MmjrMQ?si=i3zgKQbyx7VlJMBU
  • (for belt drive machines) Belt tension (see the relevant step in your instruction manual, Note that the X-axis motor is held in place on standoffs and if those bolts are loose this can cause belt tension issues. Also, belt tension for the Y-axis stepper motors needs to be even/equivalent on each side — a significant difference can cause skipping on one side eventually resulting in lost steps on both. Measuring belt tension, squaring and calibration

Naturally, this assumes that all the wiring is in good condition and all connectors secure per the Machine Operating Checklist. Verify that all wiring is in good condition and all connectors are secure, and that all wiring leading into connectors are properly in place and are secured so that the wiring leading into and away from connectors will not shift.

A good video overview on setup:

Tramming the Z-Plus: https://youtu.be/rGOGlNurglE

Ensure that all screws are in place and secure, esp. on the linear rails on a Pro.

The best check for a machine is to install a probing pin, power up, jog to the center of all axes, and then grab the tip of the pin and try to shift it in all directions — it should be rock solid — investigate any shifting and address what allows it to occur.

I can certainly triple check everything again but belts are tightened evenly. All bolts are tight. All wiring I can access is in good condition and secured. Issue only comes up when using multiple tools in a single gcode. This makes me believe that it is less of a mechanical issue and is more likely in the software, bitsetter, bit zero or controller board but again I am pretty new to the machine. Also unsure as to if it were a mechanical issue why I would get a jittery action that would no longer allow the machine to move in any axis properly once this occurs.

If everything checks out mechanically, prepare a small test file such as:

and let us know step-by-step how you are securing your stock, setting zero relative to it and managing all tool changes, and post photos showing how the cut turned out and the machine at the origin or a specified offset from that position and we will work through this with you.

Got home and checked all bolts.
checked belts
checked wheels
checked wiring and could not find any issues.

Booted up the pc and shapoko. initialized the machine without any issues. jog the machine to the center and everything is solid as can be. Jog the machine to a couple more positions and everything is moving just fine then all of a sudden it no longer wants to move left or right and starts to make a terrible noise. Unfortunately im not able to upload the video i took of this.

Shut the machine back down. Remove the belts, remove wiring, remove steppers. Stepper motor shafts are in good condition not seeing anything bent. Grub screws are tight. Re-install all motors, wiring connections and tighten the belts. Turn everything back on and now everything is moving just as expected. No more grinding and now moving in all directions. Rapid all the way around the machine multiple different times and no trouble.

Created the recommended file to run a single bit as well as a version that runs multiple. Both files end up running just fine. Carve is exatly where I expect that they will be. All shapes come out as expected. Depths measre nearly exact (within.002"). Shapes measured in multiple different places measure to within .01" of what is programmed. Due to the holiday I have yet had a chance to run any additional projects at this time.

Any insights on other things to check into before I try running again this evening?