Lots of random errors in carbide motion


I’m brand new to the CNC world and am having a really strange issue with my Shapeoko Pro Standard.

Firstly my setup:

MacBook Air running latest OS
Carbide Create latest version
Carbide Motion latest version
Shapeoko Pro Standard
File designed in Carbide Create
File executed in Carbide Motion

The issue:

For the last few days things have been going fairly well learning the software and running a few simple jobs. I was starting to get some errors in Carbide motion in the middle of the jobs but nothing that I couldn’t do a full reset and restart to get the job done. Kinda annoying though as you have to restart the job after it has been carving for 30 minutes.

Today I was getting errors right and left in carbide motion and the system would just stop for no reason in the middle of the job.

The errors I literally got tonight while trying to cut one project are:

  • There are unused, leftover G-code words that aren’t used by any command in the block.

  • Machine contoller restarted unexpectedly and may be in an undefined state. (Yes carbide motion has a spelling error in the error message)

  • A G-code word was repeated in the block.

  • G-code words consist of a letter and a value. Letter was not found.

  • Numeric value format is not valid or missing an expected value.

This, to me is really random

What I Tried:

  • Uninstalling and reinstalling Carbide Create and Motion
  • Using a different usb dongle adapter
  • switch out usb cable
  • clean out control board box
  • checked cable connections
  • Tighten belts (this seemed to help for a while)
  • switching out where Shapeoko is plugged in just in case there are electrical pulses on the circuit confusing the control board
  • try a different bit
  • re save the tool paths with newly installed software
  • try with and without vacuum (just in case static is the issue)

I’m at a loss as to what I can try. Does anyone have any thoughts?

Thanks in advance.

Your Carbide Motion is error like this??

Such errors are usually caused by a loss of communication — this could be either a loose USB cable, or EMI.

Try running an “Air Job” w/ a file which has this problem and let us know at support@carbide3d.com and see:


This is one of the errors. The others look the same but saying the different things from above.

maybe this post can help you… ive never got the error like that…
what software you used to design the toolpaths? maybe when you generate the file into gcode, there is something missing Gcode Line on your file… if you using Vectric… the Post Processor for Carbide Machine must be selected when you generate your file to gcode

Which postprocessor are you using? Can you post the top 10-15 lines of the G-code?

1 Like

I’m strictly using Carbide Create then into Carbide Motion.

I did notice that the usb connection on the Shapeoko is sloppy. There is no solid “click” into place when plugged in. I tried a different usb cable with the same results.

I did an air job with the same random results.

I did have another thought regarding the possibility of EMI. I have my shapeoko set up right next to a chest freezer in my garage with the power cord literally draped across it. Could the freezer be causing any EMI?

If you are referring to Carbide Motion that is what I’m using. I can get the opening code for you later.

Carbide Create



I’m totally going to have to check. I was unaware of that setting.

Is the machine or computer on the same circuit as the freezer? That can be a problem.

I do believe so. I’ll test it on a different circuit.

Ok, so I have tried unplugging the freezer
turning off the fluorescent lights in my shop
turning off and disconnecting my shop vac
turning off any other devices in my shop so the only thing running is the shapeoko and my laptop
I have made sure that my post processor is set to Carbide 3D Shapeoko
I have tried lubing the rails/bearings
I have tightened any loose linear rail nuts

The last thing that I can think of is…could the router itself be adding EMI? Maybe the router is failing?

Yes the router can cause that as the brushes wear down. It causes arcing. Brushes are easy to check and replace. You should have gotten an extra set with your machine.


I pulled my brushes and they are both chipped up. I’m actually going to try a brand new router. This one just sounds like it’s failing. It sounds like a tool that has been sitting in the garage for years.

Chipping is ok. As long as the amature does not have massive grooves on it, it will be ok.

I had to buy another router from C3D, took the old one and changed the bearings. Put it on the shelf to have as a spare.


Ok this one is really stumping me. I have tried even setting my z height high so I can run an air carve and completely unplugging my router to see if it is causing EMI - no change. I have tried running my file on a windows computer instead of my Mac. I have completely redesigned my c2d file just in case it got corrupted some how. I have isolated my power sources. I am really at a loss. Does anyone have any other thoughts?

Let us know about this at support@carbide3d.com

Other things to do:

  • get a circuit tester and verify that wiring is correct
  • have an electrician verify the wiring, and if budget permits, install a pair of dedicated outlets, each on a different circuit, and each pulling from a different leg/side of the circuit breaker box — consider making the one used for the spindle/dust collection 20 amps