Phantom tool paths?

This is the second time this has occurred. I edit tool path, save. But when i run it, it runs (im guessing) the old tool path?. Im doing a pocket operation to only cut down .075”. But first pass is easy 2x that. ??
2nd part ruined

How do you know that you didn’t set the origin relative to the stock so as to cause this difficulty?

Post the file?

1 Like

When you copy an object/objects that have a toolpath the tool path gets copied with it. When you go back and physically edit only one of the copies the other one is not updated. So if you are duplicating object/objects then wait until it is complete to copy it with a tool path. You did not say if you were coping objects or not but I have noticed that problem. Now if you only edit the tool path then both objects, the original and copies, get the tool path updated. For instance if you change bit, depth of a pocket or something like that but changing an object by resizing or things like that only the one you chose gets modified and only that one object gets its tool path updated.

im not sure i understand your question?
i just deleated all tool paths, saved, then made new tool paths. Ran the program and the first cut for profile is about .250 deep. Should only be .125".
leatherman OHT front 4.0.c2d (56 KB)

Your first cut is the outline contour w/ tabs which should be the last operation:

Ok, so whats the remedy in that scenario ?

Thats fine, but why is depth of cut . 250"?

When making tool paths always cut the least invasive first. Make contour cuts that will cut out last. You can change the order by going to the tool paths and simply dragging your tool paths to the order you want.

For instance you cut out something that had vcarving and then a contour cut to cut it out. Make sure the vcarve is first on the list and the contour cut last. If you had pockets also cut them before you cut out the contour. There is a lot is a lot of stress on your material during cutting any tool path. However when you cut out a contour with tabs that is all that is holding the center in place. When the contour is cutting until you get down to the tab depth you have a lot of material holding the project in place. Once you get to the tabs and specifically on the last couple of passes there is not a lot holding your project in place. The part of the project that is on the outside of the contour is being held by your clamps but the inner part is only held in place by the tabs.


Sure, dually noted. Sounds like good practice. But not my primary problem right now. Is there no way to delete these hidden toolpaths and redeem this design?

I have not used layers but it is available in v7. Is it possible there is more than one layer that is causing your problem?

I went to “edit”, clicked “show layers” and see this. Does not seem to indicate more than 1 layer.

So next I deleted all toolpaths , duplicated the design without toolpath, deleted original design, moved the duplicate back into place, made new toolpaths (and made contour the final step). Saved it all, ran the program and the depth of cut on the first pocket was .200” instead of .075”.:slightly_frowning_face:

Your retract height is set to .750", is it possible your crashing at the top of Z and losing steps?

Also, your contour toolpath for the cut out operation is going to be hard on that bit as it’s a deep slotting operation. I added an offfset slightly bigger than your tool and made it a pocketing operation most of the way through finishing with a shallow slotting at tab height. Hope this helps
leatherman OHT front 4.0.ver2.c2d (76 KB)

Are you certain the file you are running on the machine is the latest version of the file from CC?
Are you transferring files to the machine? Did you “Load New File” and reselect the same file after editing?

1 Like

I did verify my z zero between operations.
Im machining MDF, but ill be more cautious with aggressive cuts.

Its v7, loaded it in August for the first time.

Second thought, maybe the Z resets at initialize? But the first Z axis move loses? Ill investigate that this morning.

How are you setting zero?

The 1/8" discrepancy sounds a lot like probing a BitZero for only Z, when it is positioned for XYZ, see:

Not the version of CC. The version of the file you are cutting.
After editing you need to save the toolpaths, save the file, and reload the file into CM.

1 Like

Is the bitzero on top of the workpiece or clipped over the edge (the lip of the bitzero is about an eighth isn’t it?)
My understanding is probe XYZ the lips of bitzero off the top pushed up against edge
probing Z only bitzero lips on top of the workpiece


1 Like