Please help🙏Upgraded to 1.5kw 220v spindle and having disconnect issues 😭

Last Tuesday I was in my shop and heard a “pop” sound in the area of my xxl and heard the dewalt router slowing down in rpms but the machine kept moving. I have been buying up parts and components to upgrade to a 1.5kw water cooled spindle (Gpenny 1.5kw spindle huanyang vfd, cw3000 chiller, a wider drag chain etc…) but was waiting for some down time to do the install. That night I ran to lowes and home depot but they were both out of the dewalt and makita routers. I figured I may as well install the new spindle! I started by running a dedicated 220v outlet for the vfd and the water chiller. Got all of that hooked up, then the 16/4 wire from the vfd to the spindle making sure pin 4 is definitely ground and also checked to make sure pin 4 was ground to the body of the spindle. I checked the parameters from luke and Julien’s guides to get the vfd set up. All this being said, I flipped the breaker, and started running different spindle speeds but after a few clicks it would disconnect. I didnt think much about it and started running gcode and it would get maybe 30 seconds to a minute ish, it was totally random, and would keep disconnecting. I reached out to poor Luke Bonathan who tried to help me with our foreign working lol and better yet my ignorance to answering his questions. Basically what we discussed is I was running 2 hots and a ground with no neutral. I went to home depot and got a whole new outlet with 2 hots, 1 neutral and 1 ground to try and mediate my disconnects, well 50 dollars later and an entire day wasted, I’m still af square one… I did run the program with the vfd OFF and it ran just fine.

I’m sure I left some things out as I’m super frazzled, have orders getting further and further behind, I also ordered a replacement dewalt router as an absolute last resort… I am literally willing to give a 20 dollar venmo or whatever to who can figure this out for me🙏
Please help!!!

1 Like

Is that cable to the spindle shielded?

Do you have a noise filter between the VFD and the power outlet?

Have you tried disconnecting the auto speed control and just setting the RPM manually?

it doesn’t look like your VFD cable is shielded (but the pictures can lie)… Some folks have had issues without shielding the cable (and remember that the shield needs to be connected to ground on at least one side of the cable)

Are you using a powered USB hub? (if you happen to have one, use it… especially if it has a ground plug)

another wildcard is trying to see if the frame of the shapeoko is properly connected to ground

Starting with Liam, it is NOT a shielded cable, does everyone use one? I ran it straight out to the top of the spindle up and back to the vfd, clear away from anything else. Not saying you’re wrong by any means, it would just be my luck to have to go to this extent lol.i ordered a 220v emi filter.
I tried setting pd0013 to 8 to factory reset but couldn’t control the rpms with the vfd but I also didnt move the jumper back to the 2-3 position. Which may be the reason.

1 Like

No, the wiring is not shielded, I briefly looked a few people who said they’ve never used shielded cables and its worked great :roll_eyes:, of course I would… lol
I am NOT using a powered usb, I wonder if best buy has one?
What would I need to do to ground the frame?

Arjan raises a good point, checking out the grounding is a good move as you have the interference issues, here’s a guide and video about that;

VFDs inherently make a lot of electromagnetic noise, especially on the output between the VFD and the motor. These cheap HY units also send a lot of noise back into the mains supply (thus the interference filter on the input which you ordered). I have a shielded cable, both foil and braid shield which is grounded at the VFD earth, it seemed like simple insurance.

Your routing of the VFD cable away from all the others is a good move, one I’d endorse even with a shielded cable.

As you’ve connected the VFD to the Shapeoko controller you have the possibility of a ground loop and much harder to resolve interference due to that. I’d suggest getting the VFD to work using the control knob on the front panel and trying it without the connection to the Shapeoko. You may need to move the jumper on the board, there’s also a setting to tell the VFD to use the built in control (PD002 I believe). On mine you can turn it down to stopped so try turning the pot clockwise too.

Be careful with PD0013, you can burn out the VFD or motor with the wrong settings and the factory default may well not be ‘right’ for your setup.

It would just figure for me and it being the wonderful 2020 year that I would have issues like this after so many people post praises of how much they love their spindles :roll_eyes:

1 Like

Non shielded user here, no problems when running up and out . Is the spindle power cable resting on your computer monitor?

1 Like

Hah :wink:

You’ll get to love it once you’ve invested the effort to make the dang thing work…

1 Like

I bet so!!! I wish I didnt have 3 weeks info orders piling up :tired_face:

Lol, :flushed:yes
Care to make a quick visit up to Wichita Fallls? You’re in TX right? Lol

I used mine unshielded for a bit but then got chicken and added a sleeve:
which I just grounded at the spindle side at the stress relief thingy.

bestbuy will have powered USB hubs for sure. Check the power cord before you walk out of the store to make sure it has a ground

before changing the frame, with power off, you can check the resistance between ground and the frame (you have an easy to access ground wire at your VFD)
you could just run a single wire from there to your frame… a little crimp O connector on the screw that holds the belts could work easy enough

Are you saying you ran 2 hots and a ground instead of neutral and fired things up?
You might sniff around for burnt windings…?
or maybe I am reading it wrong?
if you do have to go to town for a router, try for Makita or Bosch that will fit your bracket. The dewalts 611 are pretty much standard junk anymore… imo

Good idea… I’ll do that!

I have 2 separate 20 amp 220v outlets for my tablesaw, jointer and metal cutting bandsaw that have plus with ONLY 2 hits and 1 ground available for 3 prong plugs. I thought this would be no different because it’s still low amperage. Lol Luke seemed particularly perturbed by this idea so I ran to home depot and got the 30 amp 3 pole, 4 wire receptacle and matching plug. This didnt help literally at all :tired_face:.
I did go to my local lowes for a dewalt 611, out of stock then to home depot for the makita, out of stock.
I’d really LOVE to get this spindle running as the lack of deafening noise is addicting. Again guys. I’m offering at least 20 bucks to who gets me going :pray:, I can’t afford this crap right now

there are many makita clones in the various stores… they’re “close enough”

Just ordered the sleeve you mentioned!

Now you have the phase inputs sorted out I’d look to buy a 4 phase emi filter and run the VFD through one of these. No idea where you would buy one in the USA.

I don’t run shielded cables on anything at present and don’t have any issues here, a VFD will generate emi into your circuits. I’d also look to put one on the Shapeoko it’s self as a cautionary measure.

Our of curiosity what limit switches are you using?


The ones you used to sell from beaver

1 Like

I bought my 20 foot spindle cables from this guy on ebay. around 200 dollars shipped each. He makes them double shielded. You might need to ship him the spindle plug.
He does a very nice job but very expensive.

1 Like