Ramping in Carbide Create Pro

that’s a really helpful video. most of the bits I’ve broken have been from a slightly too aggressive initial plunge. That said during the 5deg ramp, it really slows down, is it safe to increase the plunge a bit while using the ramp feature compared to plunge? or is it still best to keep it slow?

I kept it stock and increased my DOC a touch. Particularly with the NOMAD3 and Aluminum, I was able to use a deeper DOC with a slightly smaller stepover, with the same 278 bit, because the plunge wasn’t stalling the machine. Similarly, this will ease the initial load on the router, which is what most people are running.

This way you gain time through DOC not plunge rate.

I played with the ramping features last night, it was so nice, I had such a big grin on my face.


Does this mean that if a want a literal ramp, say 1" x 2" rectangle or a similar parallelogram that drops by .25" that it will handle that? I’ve got several points in a current project where that would be wonderful,

1 Like

You don’t get to choose the length of the ramp, the direction, or the pattern, only the angle. So, no you couldn’t cut an angled face with it. It just replaces plunges as a way to get into the material.

1 Like

The only way to get such an angled cut in Carbide Create is to either model it in Carbide Create Pro:

Or to approximate it w/ a series of objects and toolpaths:

Not having used ramping before…I’m wondering whether it’s beneficial for processing in woods?

Also, I tried it out on my latest project - I was pocketing a small hole (not drilling), and I noticed that it started to try to cut about 1/8" above the board, circling around cutting air for a couple of revolutions before making contact with the wood. At first, I thought I didn’t zero it right, so I stopped the job and rezeroed and restarted, but the same thing happened. Is this normal?

Ramping does help in all materials.

It should start cutting at the same depth as an equivalent operation w/o ramping assuming zero was set correctly.

Post the .c2d file, step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes and we’ll do our best to puzzle this out w/ you.

OK…this is as simple as it gets:
Here’s the C2D - it’s the layout for drawer front pull holes…
Handle Layout.c2d (60 KB)

  • The stock is clamped using regular old hold downs and is flat and dimensioned to slightly under 3/4"
  • I did a fresh start of CC, Initialized using the 1/8th bit I will use for the holes
  • After the bitsetter initialization, I zero on the center of the drawer front using he “trap the paper” method and set all zeros
  • Load and run the C2D

After going through the bitsetter process (same bit, no changes), the cutting starts about 1/8" above the wood and is clearly ramping downward. There are about two rotations before contact is made. The hole goes all the way through a 3/4" piece of stock, so it is cutting to full length, despite starting high…which is what made me think it’s the ramping code that’s starting it high.

EDIT: I’m not by my machine or I would try turning off the ramping and seeing what happens

It should start the retract distance above the hole, plunge to the first cut depth, the cut the circle.
With ramping it should start at the same retract distance.
Ideally, you would be able to set the height, angle & pitch of the ramps to make it more efficient.
I guess pitch could be the same as Depth of Cut.

Apparently ramping cuts do start above the surface — which makes sense — it affords one a bit of safety margin:

That’s definitely it! It’s the retract height. got it.

OK. Thanks folks…Thanks @WillAdams , I see you also answered the same.

Mischief managed.

  • Gary

Has anyone found any bugs in the new pocket code? We’d like to move this to the main download page today or tomorrow if nobody has found any new problems.


I’m experiencing a weird issue with ramping in build 738:

I have a series of rectangular plates set to machine out of some aluminum plate. I have a contour operation with 2 degree ramping set up.

On the start of the first cut it plunges into the material to cutting depth then raises the z back up to the start of the ramp and ramps as normal. I’m pretty sure it was only introduced after I made a change to the file, though I don’t remember which change caused it (I’m batching out a bunch of these plates and making adjustments to settings here and there).

Edit: In checking the gCode, it seems the first command for the cuts are:


I have zero set to the bed, so it attempts to plunge though the sheet for an instant before starting the ramp.

Can you share the G-code and the C2D file?



Here are the files:
15988-00B-toC3D.c2d (56 KB)
15988-00B x6-toC3D.nc (61.6 KB)

I think we found the problem. We should have a new build out tomorrow.

1 Like

It turned out the be a post processor thing rather than a toolpath problem.

Grab 739 from Carbide Create Beta Downloads and it should be fixed.

1 Like

I can’t believe you’re limiting me to 20-million triangles. Sheesh. If I need 20,000,001, what then?

EDIT: An observation: If you try to cram 20-million triangles on the usable bed of an XXL, each triangle would take up 0.00004805 sq inches.

You’re preaching to the choir here. I’ve been trying to tell people that their homemade MDF CNC machine will never resolve the difference in anything over 200k triangles or so for literally 15 years. (With significant pushback!)

In the defense of those that need a lot of triangles in CC Pro, they’re generally not making the files, they’re buying them from someone online. They either need to decimate the file in a third-party program or we make it work as-is. We got an 800MB STL file the other day that someone bought, which triggered the change.