Shapeoke Pro XL Probing cycle problem

Hi,

Just build my Xl Pro and all looked good. Everyrhing connected and i started the machine for the first time. Homed it and under settings gave the right position for the bitsetter. Like I did with my “old” shapeoko. I need to home again and the machine goes to the front and I have to place a bit. But then, it goes above the bitsetter and goes down for lets say an inch and stops. Not touching the bitsetter, way above it. It says Probing cycle failed. Is there somwthing i did wrong or are there people who had this also?

Is your BitSetter’s red LED turned on all the time ?
We had a case recently, turned out to be a faulty wiring:

1 Like

Julien,

When I look from above it’s glowing red. I think it stays on.

So that’s why the probing cycle fails, the BitSetter thinks it is triggered all the time. You can confirm this by checking the status in CM’s Settings screen as I mentioned in that thread.
Do you have the wires reversed maybe, as in the thread ? This could explain the issue.
Anyway, it’s better to get in touch with support@carbide3d.com and tell them about this to get advice on how to proceed to fix this electrical issue.

1 Like

I have checked and my bitsetter is all the time active. Probe active it says.

1 Like

Right, so this confirms the electrical/wiring issue. If you get in touch with support and provide that information, they should tell you what to do (likely swap two of the wires, or wait for a correct cable to be provided to you)

1 Like

Pull of the front right plate and check the wiring on the bit setter where it connects to the cable to the controller. Mine was wired backwards.

wiring

1 Like

Baricl,

That was the problem. I swapt the connectors and checked it in CM. No more probe and when I pushed the button it showed up. So enabled the bitsetter and tested it, and it worked like it should. Thanks, I’m very happy. Now those black fill stips and then I’m finished.

1 Like

Great. I fixed mine by just taking a small jewelers file and filing a little bit on the outside male plug connections coming from the bit setter. The connectors are keyed. Kind of looks like an O with a little flat on one side. I just filed off the corners a little bit. Then i was able to just flip the plug around and plug it in the other way. That puts the latch on the wrong side of the connector, but who cares. Its not like its going to come loose or anything being its inside the frame. Support sent me the correct cable but its working fine with my fix and i dont feel like tearing everything apart right now

@baricl

I did the same. When you push them firm together they never come loose. Only thing now are those fill strips. I hope they respond to my email.

Same exact problem as original post on my newly assembled Pro XL. Will let you know if I find bad wiring. My LED is dim red…then full red when I push down on the bit setter button. That seems to indicate it’s “off” and then “ON”…why else would it get two levels of power to the LED??

Update!! Yep, my plug for the bitsetter (the one that’s inside the right rail behind the front right cover plate) was also wired backwards. I shaved the indexing pin on the opposite side so I could just turn the plug over and insert it again. Ran perfectly as soon as I did this (and the LED was no longer on unless you pushed the bitsetter button down). Made my first cut already and worked like a charm (hey Carbide, someone run over to the station that’s making up the bitsetter wiring and bribe them with a latte or something :-).

2 Likes

mine was also wired backwards …