The dreaded disconnect / static electricity

Hi all,

I finally made the plunge, after years of watching, and purchased a barely used S3 XXL that was built in June of this year. I’m struggling to get more through moderately complex designs without the machine freezing. No error codes, just a dead halt and needing to restart the process.

I’ve been super impressed by Carbide Support. William has been crazy responsive - even late! However, it seems like we’ve hit a dead end. I’ve tried every trick in the list, with the exception of adding a toroid to the spindle (Carbide Compact) and humidifying the air (it’s a basement).

I’m fairly certain this is static related. An air job (as William referred to it) worked great. On the next job, I removed the vacuum line to suck up some chips and putting it back the hose bumped the Z motor and it froze.

I’ve added grounding straps to the vacuum hose and across the machine resulting in excellent continuity between any bolt one might choose and the ground. I confirmed the ground is properly wired and functioning.

My feeling is the logic board is very sensitive to and potentially has been damaged by static. I’ve seen similar things way back when with computers from the early/mid 90s.

Any other angles of attack you might suggest would be appreciated! Below is the list from William:

  1. arrange the AC cable for the spindle (trim router) so that it doesn’t cross or be near any of the other cables
  • Done - no impact.
  1. if you’re using a laptop, ensure that it is plugged in, preferably to a grounded outlet using a 3 prong plug if possible
  • Was always true.
  1. if you’re using a USB extension cable or unpowered USB hub, please directly connect the machine using a shorter than 6 foot USB cable — if your cable doesn’t have a toroid (metal cylinder often molded into the end of the cable) and you have a cable which has that feature, try it, if not consider adding one or getting a cable which has that feature
  • Cable has toroid and no extension.
  1. try a different USB port, esp. if you have the option to switch from USB3 to USB2 — if using a laptop try a good-quality powered USB hub — some laptops undervolt the USB ports to save power. Make sure that the cable isn’t being jostled or disturbed.
  • No change.
  1. if your spindle (trim router) power cable doesn’t have a toroid, try adding one (note that what seems to be a toroid on most trim routers is actually an anti-theft device on all the ones I’ve seen). Note that worn carbon brushes or a loose connector on a trim router may cause arcing which results in EMI.
  • Will add one.
  1. if possible, connect the spindle (trim router) and the machine through a different circuit
  • Tried, no change.
  1. if you have a surge protector, please connect the machine through it
  • Tried with and without.
  1. check the ambient humidity, if low, consider a humidifier
  • Not viable - this is a slightly damp basement already.
  1. if using dust collection, ensure that your dust hose does not allow static build-up, or is properly grounded
  • Done, no change.
  1. Connect the machine with a galvanic isolator such as this one:
  • Definitely an option, but seems a little ridiculous.

Vacuum and Router on separate circuit from machine/computer? That helped me.


I tried that. No change. If this were electromagnetic interference, I could see that as a resolution. This seems to be static discharge.

Have you checked the continuity between the router body and ground ?
Some folks wrapped a copper wire around the body a few times and grounded the other end.

1 Like

I hope the likes of @Jorge and @Luke hear or read about these issues.

I was the same with my XXL, spent over a year trying to sort it out7 with Carbide3d, and I eventually did by purchasing a 3rd party motion controller and ditching the carbide board.

It didn’t help me but I think a lot of people have had some luck ensuring everything is grounded to a single common ground point, the vac hose, the router, the control board, the frame, all of it.

You don’t hear many disconnect issues with competitors machines, it’s time to come up with something more robust.


Interesting! Which board did you go with?

Yup! After to adding the strap off the Z motor mount, it shows solid connectivity.

1 Like

I bought a Gecko g540 which has 4x 3.5A drivers, enough inputs and outputs to run estop, coolant, probe, homing switches and spindle control. It has a parallel port which then plugs into a Cncdrive UC300ETH-LPT5 motion controller. This gives me virtually unlimited inputs and outputs (even though I don’t need them yet). A 12.5A 48V power supply is also required.

The UC300 has an Ethernet port, i have it plugged directly into a PC, but it can be plugged into a network/router and used across the network.

A cheaper option is the UC100 which doesn’t give you any extra I/O and converts the parallel cable to USB rather than ethernet.

It runs on UCCNC (replaces carbide motion) which is very powerful and super easy to setup, you can also edit each screen to show exactly what you want it to.

10/10 would recommend if you are confident running a few wires… I can plug everything into the same circuit, run noisy power tools - I have tested every single tool I own without a disconnect, I have none of my dust collection earthed, my spindle is earthed by default but I haven’t gone above standard.

See My Gecko 540 + UC300 + UCCNC story

1 Like

A troublesome situation indeed.

Trying to think out of the box, in your original post you said you bumped the Z motor and that froze things? Do you think it was the physical contact or did you cause the Z motor to move?

If you manually move the motors when the machine is powered off, they generate enough power to light up an LED on the controller board. I doubt the Shapeoko stepper drivers are so finicky, but maybe its possible the motion caused an unexpected power surge?

EDIT: The more I think about this, the less likely it would appear to be. It would be reproducible by gently tapping the axis with a rubber mallet when the machine was on.

FWIW, they did state that the new controller board (Nomad3/SO Pro) has “better EMI performance”, so it seems like they took that feedback into account already.


We will be sending @penumbra a USB Isolator which will hopefully address this issue.

1 Like

Are there recommended USB isolators?

There are several readily available USB-CAT5-USB adapters that claim USB2 speeds over a 50m cable. Maybe that increase in signal stability would also improve stability over shorter distances.

There are a couple listed at:

Some folks have had success with USB powered hubs/repeaters.

Thanks Will… being a Nomadder, I often overlook the wiki. Now I’m the proud owner of @tink07’s XL, I really should read it top-to-bottom.

Is there any gut feel for a different level of USB issues for laptop users as opposed to desktop users?

USB issues seem to be specific to certain chipsets/motherboard layouts and are pretty rare — either it works or it doesn’t for the most part, and these days mostly it’s works.

I was thinking more of the considerable differences between the power supply and grounding between the two types of systems.

Got to say - Carbide Support is off the charts awesome. Thanks, Will! I hope the USB isolator fixes it!


I have had this intermittently since purchase in 2016. I thought running a ground wire from the spindle mount directly to electrical ground had solved it until this year. It certainly appeared to have for 6+ months. However, with no change in setup or hardware, the disconnects are back. It’s outrageously frustrating, so I’ll be interested if the isolator they are sending you works.

Usually if disconnects arise after a period of successful operation it’s either low humidity, or worn carbon brushes in the router — let us know about your situation at and we’ll do our best to work through this with you.

Using mac it’s more better than any other for this issue it’s have very strong connections
Things go different with my laptop sometimes it is from the laptop very sensitive USB ports !