Z axis off using bitsetter

tl;dr bitsetter is off casing Z to go deeper than it should.

After starting a cut yesterday I noticed that a pocket was going beyond the .20" that I had specified. Thinking I must have done something wrong. I stopped the job, powered down the machine, and started from the beginning. Power on, initialize, correct endmill in the router, and the bitesetter did what it does. Next I used the BitZero to get x,y,z, and ensured that I had the correct endmill selected there. The BitZero was properly placed on the material. All those steps were completed with the previous job too.

I jogged the device to the center and used the rapid movement back to x, y, and z to see if everything registered properly. What you can see in the photos, is that the z is not at the 6mm mark. The endmill is against a .25" piece of MDF for reference as I did not have a ruler that would fit in the tight space.

With the Z off, you can see that the pocket is pretty deep and there are remnants of the endmill dragging across the face.

Next, I moved to test Z using a piece of paper and as you can see, the Z is at .125 when it should be at zero.

I saw a previous post with odd Z behavior that seems similar to what I’m experiencing.

Everything up until now has been going well and everything I’ve made has been pretty straightforward using the create and motion combo.

Any thoughts?

It could be that you have lost Z steps while dragging across the material. Do you have a retract height setting that is too low to pass over your surface? The machine will go to that height before performing rapid moves between cuts.

Good question. The retract height I’ve been using is 0.1250" which is why I think it barely scratches the face. The bigger question is, why is the bitzero not registering Z at 0?

The root causes we tend to see:

  • problem in the zeroing procedure itself => it does not seem to be the case, if you installed the probe overhanging the corner and choose Probe XYZ. This is best investigated by jogging to the surface after using the probe and before running the job, to triple-check the surface is at 0.0. If is, but then the cut is too deep, then focus turns to the BitSetter. If it isn’t, then focus on the probing/zeroing part.
  • not following the BitSetter workflow, for example swapping the cutter without using the Change Tool button or when prompted => it does not appear to be the case here
  • a problem with the BitSetter “sticking”. Does the plunger mechanism feel smooth ?
  • if you want to eliminate the BitSetter hypothesis, you can also temporarily disable it in the settings, and run a single-tool job.
2 Likes

Problem solved and it’s all user error.

Probing just z requires the probe be placed differently than probing x, y, and z.

Over corner

On surface

At some point in my workflow I must have switched to just probing z and did not follow instructions and place the probe on the surface.

Lesson learned.

Thanks!

4 Likes

I am glad I read this article. I would have missed the probes position. Of course I have never used the probe height only the probe corner. I don’t think I will ever use the probe height setting now as I like to double side tape my probe in place during the probe and putting it on the surface rather than the corner for me would suck. I will stick probing the corner always.

Although, I do realize why they do that. If your start point is in the middle of the job you don’t want to go to the corner to probe so it would be natural to have the probe sitting on top of your job, hence the needed offset.