Z Axis randomly starts 6mm high or low


I have a 3 XXL, and ever since I’ve had it, it’ll randomly decide the Z axis should be about 6mm too high or too low (and dive into my material). I’ll stop the job, re-zero the Z axis, run the exact same file, and it’ll work fine. Any ideas?

Using Carbide Motion and Fusion 360.

Do you have a BitSetter? If so, is there any chance you changed the bit bit without using the button in CM?

1 Like

Sorry, forgot to add that. Yes, I have a bitsitter. I use the paper method instead of the probe because my probe tends to be off by a couple millimeters sometimes.

I do the tool measuring process each time CM asks to do it.

It happens around 1 out of 8-10 times I run a job. I’ve tried to see if I’m doing something wrong sometimes, but I haven’t been able to figure it out.


Ok, but the important part is - do you ever change the tool without first pushing the “Change Tool” button in CM?

If you have the BitSetter. you should only change the tool when CM prompts you to.

1 Like

What Z-axis are you using: belt, z-plus, HDZ?

I just did a write up on the Z-Plus and failure in the leadscrew nuts:

And if you’re on the belt drive, check your pulley set screws:

The random 6mm high, 6mm low sounds a lot like a slip in the pulley on the motor shaft.

Also check your motor mount screws regardless of which Z-axis you have.

1 Like

No. I set the tool and let it measure on the bitsitter, and I don’t touch it after that. I do most of my cuts with an 1/8, so I don’t change tools very often.


Thanks! I’ll definitely read those posts and see if that could be it!

Check your belts as well if you’re on the original belt drive Z-axis. Troubleshooting similar accuracy problems on mine over the last two months, I found 2 stretched belts (the X axis and one on the Y axis, replaced all), 4 v-rollers that lost contact, bad bearings in my router, and worn nuts on the Z leadscrew. So, lots of deferred maintenance :laughing: .

But what yours sounds like is the pulley slipping on the motor shaft. Mine was doing the same thing on the Y axis and was hard to diagnose. What happens is those grub screws look like they are snug, but don’t have enough force to hold. They slip one direction and catch against the flat spot on the shaft. They hold there for a while until there is enough force to slip the other direction and catch on other side of the flat spot. You end up with this random slip a few mm in each direction.

That’s why I switched those all out to socket head screws with a touch of low strength thread lock. You can put a little more force on them than a tiny grub screw and the thread lock holds them there.


This topic was automatically closed after 30 days. New replies are no longer allowed.