BEST-FC300 VFD help

$5 to anyone who helps solve this problem.

I have a 1.5kw 220v BEST vfd running a 1000hz 220v 1.2kw 60k spindle rated for 4.5 amps. For the life of me… and too many hours…I cannot get this thing to output enough power. Maybe its the torque curve? I also have tried to loop the pid because it’s not connected to a 10v output, it’s a long story.

It feels like a Makita has 2x the power. Obviously I’m doing it wrong. Please help

This is a great thread that includes cm board setup and English manual https://community.carbide3d.com/t/best-vfd-drive-connection-to-carbide-motion-board/14669?u=vince.fab

2 Likes

@Vince.Fab - so how do you know you are not getting enough power - is the motor stalling, or are the RPM’s dropping off?

I don’t really know how to fix it - but I would start by changing the parameter P056 (start display selection).

You probably have it set at 4 (RPM). I would set it to 1 (motor current) and do a little test cut so you can see what the display says. Then change P056 to 2 (bus voltage) and do the same cut - again, note what the display says. Then change P056 to 3 (output voltage), do the same cut - and note what the display says.

With these figures - maybe we can deduce what is going on.

Make sure your test cut is sufficiently taxing to make the thing work a bit - don’t just tickle it.

1 Like

@Vince.Fab - just another question - you have a 1000Hz motor (mine is 400Hz), you have entered that value in the right parameter? This needs to be set in P003 and P021.

I’m guessing you’ve done this - but just to doublecheck make sure you have.

3 Likes

@Vince.Fab
@Julien seems to be having issues with his VFD’s motor current readings - maybe you are too? You can use your clamp on current meter to measure the input currents to the VFD when the motor is not cutting and is cutting. That will provide a ball park idea of the actual motor current increase when cutting to compare with the VFD’s displayed increase when running full speed (60,000 RPM @ 800 Hz).

The attachment shows how I think the VFD should be configured for manual control without PID to help test/debug, but I’m sure @3DGG knows best since he uses one.

2019-09-20 Edit: The attachment has been corrected.
2019-09-20 Pages from VFD manual in english (2).zip (2.0 MB)

2 Likes

The motor is definitely dropping speed, even with only 1/8 endmill. P056 is just the display speed right, its easy to jog through on the controller while the spindle is running. I tried all those and nothing changed, but might flash stock settings back and start from scratch.

I can stall the spindle by hand and only see a 2amp output realtime on the controller. It goes up with load, just not enough. Even from a full 60,000, a gloved hand can bog it easily just touching and applying pressure on the spindle nut.

It just doesn’t seem to have the same type of settings as a Huanyang and I’ve only talked to one other person that used one and he complained of under power as well.

Some people have said that it might not just have the power but I find it hard to believe a 1.2kw 4.5 amp 220v spindle cant outpower a brushless Makita.

Did you purchase the vfd and spindle motor from the same supplier? Any chance you could ask them for advice?

Yes it was a package deal and so far they are having trouble even sending a manual. That’s the only option they gave.

I’ll try to measure the current manually but honestly im going to switch spindles back to a 1.5kw 24k 110 for now, it doesn’t seem to bog at all.

What are your other spindles and VFD(s)? They can probably be used to independently test your 60,000 RPM spindle and VFD.

0.8kw 24k 400hz 110v , 1.5kw 25k 400hz 110v with a 1.5kw 110v 15amp nowforever vfd.

I clamped a spindle wire and amp output seems to be on point with vfd output display. On a forced stall I see 2amps that slowly climbs, slowly.

Getting somewhere and at the point if it goes up in smoke so be it.

I charged my motor rated frequency (p003) to 200 and it now actually starts up quick and I can’t stall it. However I’m pushing max amps now at minimum rpm lol and current goes down as rpm climbs.

That’s probably because the VFD’s feeding the full 220V to the motor instead of the normal 220X200/800 = 55V that it should need for that 15,000 RPM.
Your clamp on current probe would be more accurate measuring the VFD’s input current than it’s output current.
Did you ever check the speeds?

It appears to me that there is no way to reduce the 15A output current of your nowforever VFD, so it’s probably not a good idea to use it with your 60,000 kRPM spindle (or even your 0.8kW?). But, it should be ok for a quickie test. You’ll only get the maximum speed that it’s setup for though (24kRPM?) but tons of torque.

It appears that there is no way to reduce the 220V output voltage of your Best VFD, so its probably not a good idea to try it with your 110V spindles.

After reviewing the manual for the Best VFD, I learned from page 6 that a “4-pole motor is standard” and unlike @Julien’s Huanyang, there doesn’t seem to be a way to tell the VFD otherwise. So P057 would need to be set to 150.00 to have the proper speed displayed. It can’t be set higher than 100, so it should probably be set to 75 so the displayed speed is half the actual speed.

Also, P058 sets the “carrier” frequency which determines the number of pulse width modulated (PWM) pulses per cycle of output frequency used to produce the voltage waveform fed to the motor. The likely current setting of 1 only produces 5000/800 = 6.25 pulses per cycle at your 800 Hz maximum frequency. That’s probably way too low and may well be the primary source of your problem. @Julien uses 20 per cycle of his 400 Hz maximum frequency. I think you should set P058 to its maximum value of 5 to get 13000/800 = 16.25 pulses per cycle at 800 Hz. I’ve updated the compressed pdf provided in the previous post to reflect these thoughts.

3 Likes

The spindle is rated for a 1000hz maximum to reach 60,000rpm.

Today I set the 003 to 600hz and honestly its run the best its ever run. The P057 is set to 60 and while I haven’t tested the actual rpm (need a 9v for the tach) it seems to be accurate based on actual cutting. The carrier frequency on mine goes from 1-13 and I had actually settled on 5 from from earlier testing!

I feel like there is a translation issue with the manual…but we’re getting somewhere. I’ll clamp the vfd input and hopefully get the tachometer up.

Tool pressure was too light in the first vid and not enough leeway in the fed override to stabilize the cut. Later increased radial opt 50% with awesome results. It’s all about that sweet spot.


Yup- wrong manual and manufacturer for BEST-FC300!
and another one

WTF: Can’t even download the manual from their Google translated Chinese website! Try email?

Talk about barking up the wrong tree and shooting in the dark!

Spindle apparently is 2 Pole though.

2019-09-21 Update: @Vince.Fab This is probably the correct manual. iBEST FC300 Manual.zip (816.3 KB)

2019-09-22 Update: @Vince.Fab The FC300 manual says that the rated motor current (4.5 Amps) (PD001) is entered as a percentage of the VFD’s rated current (7 Amps) - I.E. 4.5/7X100 = 64, rather than 4.50 that the other manual (FQD300) suggests. Other than that, there doesn’t seem to be much difference in the manuals.
From FC300 Manual: “Setting range:20 -110% inverter current, depends on the rated current of actual used motor.”
From FQD300 Manual: “Setting range : 0.00-1000.00A Setting range : 20-110% inverter rated current.”

It also looks like Best VFD should be able to safely drive your 100 Volt spindles after all, if the spindle voltage (PD002) is set to 110 and the currents and frequencies are set appropriately. You won’t be able to get more than 7.7 Amps out of it though.