Carbide Motion Beta with New BitSetter Workflow

It’s here, use it at your own risk:

https://carbide3d.com/carbidemotion/beta/

With the better write up here: BitSetter Changes in Carbide Motion

Let us know how it goes in this thread. If you have problems specific to this release, please post them here, do not contact support for help with beta releases.

PS- We went far enough in removing popups that even Winston, who values every second, was a little worried. Assume that any time you do anything to affect a Z zero, the machine will take off moving. We can always add warnings back in there, but we wanted to give minimum warnings a shot.

(This is a single-topic thread, so please only post about the new workflow or a new bug in this build)

19 Likes

Maybe have the extra nag mode configurable in settings for those that want it.

Weren’t you talking about a change to restart at various places in the code some time back? Is that still in the works?

1 Like

@robgrz I’m getting a new pop-up when I run my VFD spindle warm-up routine from the Quick Actions menu.

!

Interesting- if you go back to the prior build now, does that popup happen?

Any chance of stopping the +Y movement when connecting to the cutter in this next CM release?

Even though it is slight, if for any number of reasons the machine has disconnected during a run and a reconnect is required, the steppers roll north and can cause loss of steps and/or worse damage a workpiece. With Sweepy attached and the tool likely in contact with the workpiece, there isn’t a way to release the tool from the spindle to prevent unwanted movement against the workpiece.

If movement is necessary at connection +Z would have the least potential for issues.

Sorry, not entirely within the BitSetter workflow topic, but seems relevant to a CM update.

1 Like

Yes it does, the popup is now showing up in CM622.

I also noticed this morning that CM626 did not remember where my previous X/Y zero was set. Normally I don’t change my X/Y zero from day to day because I work along a fence on the spoil board. This morning with 626 I got a popup saying I had an invalid zero. When I jogged off home then tried to Rapid to Current XY it took be back to home position.

@robgrz I ran the setup wizard just now in CM626, the VFD popups are silenced.

1 Like

I tried the new carbide motion beta. In my case there was an issue. The software install and machine configuration seemed to work well. When I initialized the machine and loaded a file there was a problem doing the probe. I have a version one bit setter. When I selected the bite and selected the probe the z moved up not down and then errored out. When I moved the see manually the up and down movement was correct.

I have the pro version. Please let me know if I am doing something wrong. I did no multiple installs. When I went back to the current working version everything work fine, thank you.

@Ed.E reported that one yesterday and we think we found the problem. There should be a new build posted in the next 5 minutes.

2 Likes

Verified that it is fixed, works good

1 Like

Thanks for the confirmation

I read all this and the writeup and still have no idea what you are taking about. I have a Pro-5 4 x 4, VFD, BitSetter and BitZero V2.

How does this download effect my machine, if any?

Older versions of Carbide Motion, when the BitSetter was enabled had a workflow where:

  • tool was measured at initialization
  • tool was measured at job start
  • tool was measured at tool change

and there were various prompts warning about changing tools when the program didn’t expect it.

The new version minimizes this, and removes prompts by limiting measuring the tool to the bare necessity of times:

  • when one sets the Z-axis origin
  • when one moves to the Z-axis origin or 6mm above it using the Rapid Position tools
  • when one starts a job

I’ve been using it quite a bit, and it seems quite reliable, but probably best for new folks to start with the current version:

then, when a version with the new workflow gets moved to Stable, you’ll be glad of the change.

That said, if you’re adventurous, and willing to test, and won’t be doing any cutting of really expensive stock (we advise against that when first starting out), please try the beta — I think a new user’s perspective would probably help us a lot.

3 Likes

Thank you for the feedback. You know what really works the best for conveying a change is a video comparing the old way it works to the new way with showing the new change in the software.

We are visual creators by design and learn best that way.
Cheers.

1 Like

Enjoy the upgrade. Bit zero moves faster. Took a min to trust the change in workflow.

3 Likes

Love the updates, with one exception. Gantry still travels to the front after being initialized. Can we disable it? For me, it would be nice for the machine to initialize and then just stay there until we’re ready to use it.

The time now saved skipping measuring Z is still wasted having to wait for the gantry to travel to the front and then having to manually move it back out of the way so we can set up our table, etc.

1 Like

I set up my table before I turn on and initialize my machine.

3 Likes

I am trying out the new CM 628 beta and discovered that the nice feature button in the Jog menu to turn on or off the spindle is now missing. I use the bitrunner V2 with the Carbide Compact Router (and yes, the box is checked to enable using bitrunner in the CM setup wizard). This spindle on/off button in the jog menu in earlier CM versions (always was there up until beta version 627) is an essential feature for pre-checking the spindle operation with the bitrunner. Without this button there is no way to test the spindle operation before running a program.

Is this a SW bug in the new beta version or was removing it intentional? Please provide reasoning if intentional. I can’t imagine why this feature would be removed.

Thank You,
Joseph

1 Like

I updated to CM 628. After Initializing machine, jogging was restricted to about half machine size in x direction and couple inches in Y direction (couldn’t reach bitsetter).

I didn’t see any comments on various postings on this release (popup readme, blog, etc, or I missed it) that says you will need to do a Setup Machine after updating to this version. Don’t typically have to go through the Setup Machine process for a non-major version (within 6xx).

If what I saw was expected behavior, maybe add a note that a Machine Setup will be necessary with this update.

Shapeoko 4
Updating from CM 622

You’ll need to re-configure and re-send the machine configuration.

https://my.carbide3d.com/docs/shapeoko-setup/

1 Like