Desparate, disappointed, po’d

“not connected”! Again!

Some weeks ago that error happened more and more often. I bought a new controller, replaced it, and after I could cut some few pieces that error happened - again! In the middle of a project. With the controller replaced the zero settings are gone, so the Applewood stock is wasted - again, that is not really cheap.

Shaepoko: get your quality ducks in the row!!!

I only can warn customers: beware of that company.

First some years ago I had a CNC from Inventables, internet needed always, was an issue here upstate. But run for a while, long enough that the router brushes broke. Then the machine gets stuck, stock and bit - broken. Ok, learned the lesson. For the issue with the internet connection I switched over to Carbide3d.

Went well for a while.

Then -still with a makita-router- the router got stuck. Again not always, once in a while. Destroyed stock and bits. A lot. Eventually I could locate it to a z-zero-switch. Customer service sent a new one. Did not repair the problem. Now they sent a controller Again exactly the same. Now they sent a complete set of zero-switches. So far several weeks for waiting for shippings (almost a week for each part) and for endless repairs. At the end with a new controller and a new set of zero switches: the z-zero-switch was broken, AND! the z-zero-switch replacement also was defective! Who would ever think of that!

Now the brush of the old Makita-router was due, but I changed to the router that came with the shaepoko-machine. Few hours later that stopped working, again!!! stock and bit broken. A was furious, you can imagine. Warranty was not so much the issue, but the repair with the cable carrier is a very contemplative work, unproductive and embarrassing. I had some experience now after several times replacing the zero-switches. Temporarily I used the Makita-router again, because I decided to get a brushless spindle, the VFD-spindle, expensive, but expected to be bought for eternity and beyond. Shapeoko was kidding me! The spindle did not rotate. Of course I thought something must have been wrong with my settings, some contacts with Shapoko: nope. They replaced the spindle, that thing kame broken already! Now, several weeks of trying and waiting for replacement and again back and forth cable carrier work that thing eventually worked like a charm.

Not for long.

Because now there appeared an error that was new: in the middle of a project

so the connection to the controller was lost, means the CNC stops in the middle of a project, bit running. Happened more and more often, again not always consistently, so I had to re-start projects all over more and more. However since the controller board was relatively new, I replaced the laptop with a brand new one and of course the cable to: same. I asked customer service, recommended to buy a new controller, what I did, another week wait, another night changing the controller, and few pieces cold be cut.

That error also happened to another user, as may be seen somewhere here in the forum, so it is NOT new or unique to Shapeoko!

Now all the sudden the spindle showed a wiered behaviour: it just did not rotate faster than 10.000, at 14.000 it just stopped, after the breaker of the power plug went off. So I contacted customer service again, they asked me to send the VFD controller to Shapeoko. Again nice cable carrier work, sent it back some 2 weeks ago, no response so far for now from Shapeoko.

Today now again the screen with “no connection” appeared in the middle of a project, after very few minutes, several times after re-start, always the controller has to be switched off and on again, so it must be clearly the controller, what else.

Of course I will get another controller, is warranty now, from Shapeoko: another week to wait, another unproductive night changing that thing. When I change the controller all zero-adjustments are gone again, that means also that stock -Appleply- is wasted again. And: how long until the same happens again…

So: the Shapeoko-hardware is crap, except the frame. Everything else is not worth the money. I am really fortunate that I do not need to earn money with that kind of quality: I would be completely broke.

I do not know how to proceed. I completely lost any kind of confidence, because immediately after one thing is barely fixed the next one stops my workflow again. TERRIBLE! I am really furious and absolutely pissed. That item is a nice decoration for the ambitious woodworker that proudly walks visitors through his/her shop, but never for any productive work.

1 Like

I don’t see an open ticket for you, and none of the tickets I could find seem to mention EMI.

Are you cutting slots as narrow as the tool? That makes the machine work quite hard which can increase EMI. Where possible avoid slotting and add geometry and cut as a pocket


and consider leaving a roughing clearance and taking a finishing pass.

For the VFD, I see that we are expecting the RMA — please send us an e-mail with the shipping specifics if possible (did you drop it off at a location and get a receipt?) — I’ve re-opened the ticket and we’ll do our best to check things at our end and let you know what we find out.

For troubleshooting EMI itself we usually have folks run an “air job” where there’s no stock and the tooling isn’t installed and the spindle and vacuum aren’t turned on — could you go ahead and do this?

Will: for that issue what just happened I did not contact support yet. Before Tuesday I do not expect anyone to read it. And yes, the cut is always 1.5mm wider than the bit. However the event described happened already after the first round at 1.2mm depth, the bit could not be stuck already.

The whole device is properly grounded, and it is standard equipment. If the controller is that subsceptible to EMI anyone at your company should have a very serious conversation with the development engineers ASAP.

1 Like

Hi there,

You are super frustrated, and that really sucks. Don’t be hard on the Carbide folks, they have been top notch on the service and help with me and my problems over the few years I’ve had with my used 3XXL. Like above and beyond what I could have expected…

I’ve had the same problems as you, where the controller would randomly and regularly disconnect. I worked through many possible solutions, running bonding wires between all the moving parts (and connecting to the ground pin in my electrical), updating all the firmware and software, changing the mechanical homing switches to the proximity sensors… Still had disconnect issues. I even thought I had it narrowed down to an issue with coatings on bits causing a static build up, I quit using the Onstrud bits I had.

But here’s what I’ve found is the root cause of my issues, and I recommend you try if you haven’t already: Run your spindle and your controller on 2 different electrical circuits, and if you have Arc Fault breakers, take them and pitch them in the bush - I had those due to my recent upgrade of a sub panel in the shop, and they were a total headache. I found that once I separated the spindle power away from the controller, it simmered right down, and I don’t have the disconnect issues any more.

I also don’t run a vacuum on my machine due to space constraints in my enclosure. I’ve wanted to use one, but I’m too nervous it will induce more static discharge issues. Try and keep the depth per pass on the lighter side, every time I’ve thought to take a bigger bite to save cutting time… well, it takes its own bite out of my rear end and usually fails…

Anyhow, I really hope my comments have some value for you. This CNC is definitely frivolous for my shop, but I use it all the time, and it’s helped level up my traditional wood working skills…

Take care, and good luck!


DnSWW: thanks for your time and attention!

Yes, the different circuits are crucial for a good working environment. A while (“normal” shop vacuum, router) I ran all from the same circuit. Then I got the VFD part, and -since now the vacuum eventually broke, these home depot kind ones are not made for hours of work- now the vacuum was the by far loudest thing in myshop, I replaced it with a quiet one. That was obviously stronger, so the breaker did what it was expected to do: it went off. Luckily I have 6 independent power outlets installed when we moved in our new home 2.5 years ago, so that was an easy fix.

I probably expressed my anger in a wrong way: support is extraordinarily good! We -me too of course- get support even on the weekends, since they are located on the west coast most of us get them on the phone or answers to emails deep at night, even deep at night for them. No, support is excellent! It is just frustrating that in my machine so many things went south, is it cursed? Should I have it blessed? I am almost so far. Since I mostly can do things over the weekends, like time consuming repairs, and I work a lot of time on the machine instead of with it, next shipping is sent out next beginning of week, arrives mostly withing the week, and repair then next weekend. So even small things that need replacement need a lot of time, even with the best imaginable support, they cannot perform magic of course.

Back to some facts: I still think the controller could and should be more EMI proof. But for now we must work with what we have. With these connection losses Will always refers to EMIs. I think, that these connection losses indeed did not appear while my VFD worked. Now you and he mentioned, that the routers may produce EMIs whith hard work. That gave me the idea that a router needs more power when with constant moving speed due to rather slow rotation the power per chip -because it cuts slow and against the moving pressure- needs much more power per time. That probably draws more current through the brushes, causing more sparkles, what produces EMI. And that is probably exactly what you mentioned: keep the power draw for the router as low as possible.

Now what if I turn the router to the highest rotation speed? Now the power per chip produced should be much less, since the chip size necessary to be removed per distance of the sled moved is much lower. And: it worked. I tried it, and the key for me is to run the router with the highest rotation speed as possible, and with my next project probably with the 1/8inch instead of the 1/4 inch bit.

And yes, I love to work with wood, but I never got any training in traditional woodworking or carpentry. Therefore I cannot work as precisely as all the “traditional” carpenters I adore, and I would need much more machines, like a band saw, a planer, a jointer…, what would not fit into my small basement.
I use the CNC machine to give me the precision I lack to my shop and my projects.


I see in one of your screenshots that you are running Carbide Motion build 635. I strongly suspect that there are issues with that build that can cause erratic movements (not out of path but abrupt feedrate slowdowns/up), delays and disconnects. Please try build 636, and see if that doesn’t improve things.


You say your machine is grounded. What have you done to ground the machine?

Does this problem occur with your dust collection turned off?


Quicky06: Hey there, I wasn’t sure if this question was for me…

For grounding, what I did was bond the machine chassis components, starting at the spindle (an ancient Makita), working my way through the moving trams, to the base, going through the drag chains. I then I ran the wire to the ground pin on a cord end, then plugged it into my spare receptacle. This helped (I think) to eliminate any possible static build up in the moving assemblies. For the bonding, I just selected 1 wire out of an old phone wire and crimped on some terminal ends, screwing them into some of the assembly bolts on the CNC, linking the whole machine together, including the controller box to ground in my shop’s electrical system.

My theory for doing this was that the belts and wheels may not provide a reliable continuity for static dissipation. In winter, it gets so dry here, that static is a wicked issue, just turning lights on in the house I can get snapped when the humidifier is off for a bit. Similar to Emmess, I was ready to take my whole rig and throw it in the dumpster with continual disconnects.

I recently had another disconnect issue after I re-did my enclosure. After a few more, I did a palm slap on the forehead, I realized the spindle and controller were plugged into the same circuit. I changed the spindle to another circuit, and no more problems.

For anyone struggling with the disconnects and reading this, I would like to say, give running separate circuits for the spindle and controller a try. It finally stopped my problems.

As for dust collection, I don’t use a vacuum. I built an enclosure for the machine that functions as a table-saw outfeed, and then I used a bathroom fan with a filtration assembly to create a negative air pressure. I vacuum out the chips after they build up for a while.

1 Like

I had similiar issues with my shapeoko 3 when first got it. I bought a powered usb hub and a usb isolator.

Never had issues after that. Im not sure why a usb isolator doesn’t get recommended more often.


How I grounded: connected the Y-carriage (?), the main frame, the Z-frame and the spindle (as I still had it working), brought them all together to one power outlet with this plug:

No other plugs plugged in there. All other plugs (router / VFD, vacuum, controller, laptop) are connected to separate circuits, I enjoy the luxury of having installed 8 separate circuits in my shop.

The problem appears unrelated to the dust collector I think, very rarely I do not switch it on. I already ignited a fire by running the machine in dust, so I strongly belief that the wood dust / chips must be removed immediately.

I clearly could stop these disconnection issues -for me!- by running the router at highest speed. It does not need so much torque, and therefore produces less sparkles at the brushes (I think), and therefore probably produces much less EMI. Increasing the rotation speed is the only setting I changed, and I could cut two pieces of stock w/o any issues, while before that I could not run longer than 20min.

Hey good evening :slight_smile: I blew up at EVERYONE at Carbide when I first got my machine too. But… once I got over the initial “man I’m hot” phase, everything just fell into line. Connection issues? You’re going to laugh but start at the basics. I had that happening to me, but it wasn’t anything other than a bad USB cable believe it or not. Like I’d shake the table the machine’s laptop was sitting on and boom… connection lost in the middle of a test run. Frustrating! The end that was connected to the USB port was all wiggly. So I bought a new cable, plugged it into a different USB port and viola! No issue since then. Someone above mentioned a new USB hub resolved it for them too. Might be something worth checking out. If that’s all it is… you can be up and running as fast as you can run to walmart and back :slight_smile:

One more thing… the machine? Is awesome. I’m running an SP5 Pro with the VFD. Dude. We are entering our final production tests on two new product lines using this thing and its accuracy matches our Axiom production machines. Like the same nc files produce the exact same results on both brands. We do Victorian Architectural Reproductions focused on the New Orleans and Biloxi markets. So a lot of casings, trim, gingerbread, etc. Incredibly detailed work. If it’s 3 axis work, then it stands up.

did you do it as a “star grounding” getting every single point to one central grounding point, or a “serial” grounding, pulling one wire from one point to the other, and eventually to the ground? And do you use a resistor?

I just linked it all together in a chain. No resistor used. I deal with airplanes at work, and it’s always been the critical thing to keep static noise at bay, by bonding all moving parts to the main airframe, to be dissipated to atmosphere through the wicks. I was going on the same principle. Things seemed to work out in the end, so I never gave it any further thought.

I did the Star. All to one point, then to electrical ground, also a ground bar that has two ground rods at opposite sides of the shop. The next shop will have copper sheets under the floor to ground bars.

sure. Cables changed. Even a brand new laptop bought. And today: looked good, I approached the laptop: no machine connected. Switched off and on, re-initiated machine -without anything else running, no router, no vacuum- : when I zeroed the Z-axis, and the machine went to the Z-axis-measuring point: again: no connection. ok, same off and on, re-initiated: and doom: after the initiation the same. No connection. EMI rather unlikely. Will again bother the customer service. May be they have any newly produced, new version or at least a new batch of controller boards. Will see.

Check your usb connection between your computer and the CNC. In fact, change out the usb cable and any cable connections. I had the same problem, and it turned out to be the cable. Second, does your computer run out of RAM during the processing? Make sure you are only have what you need open on your computer.
Your frustration is well described. You have bumped up against the barrier to entry for this skill. It is worth it to work through the setbacks.

Einar, thanks! I did not know about the new version. I CERTAINLY! will install it right away.

Chris: cable change, laptop changed: no change at all.

The error that bother me now -after some 2 years with other, in part self inflicted problems (possibly something later for beginners…), but several ones caused by hardware from Carbide3d- is this one:

while the error that pops up when the cable is disconnected is this:

this appears to me that a cable problem should not be my issue at this time.
Will try to reduce the RAM load. Will see…
thanks anyway for your time. Certainly I will not quit. I love working with wood, and I do not have the skills for precise work, therefore I need a CNC to substitute my lacking skills.

Have you tried a different 24V power supply? If you’ve changed the CNC controller, laptrop, USB cable, etc: then the only other thing I can think of which might be causing a problem is the power supply unit. Or else some pinched/nearly shorted conductors somewhere on the machine.

Joel: Indeed that appears one of the items I did not change yet. Will do.