Having a problem with my bitsetter?

I just got done running a code made in Aspire, Vcarvepro, something nothing fancy just drill some holes, make a vcarve, cut out a profile.

Well I am making a simple spinning wheel for a local bar, for prizes, and i drilled some holes around the round which is 18" this worked out fine on my shapeoko 3XXl, like normal I ran the Probe for Zero, , then it used the bit setter and all is well to measure the bit 90degree vcarve bit

Well i run the Vcarve for the numbers, and to y surprise the bit was hovering about the work piece about 28mm, it checked the other Vcarves they did the same thing, so i ram the probe again, and the bit setter again, same thing…

So i cannot figure out what’s going on, in vcarve my start depth is zero and carve depth about .125 like i always do… i double checked all of that. i initialized teh 3XL i also reset the conjuration to the board, and still the same thing…hovers to carve about about 28mm …now my probe after teh probe i looked at the x,y zero were 0 but my z was 28mm so is it suppose to be 0? i cannot remember as i just went thru the motions and everything just worked for years lol…

I can send the file from aspire or Vcarve for someone to look at if they can see if it works from them.

But i am at wits end…

thanks for any help, I tried to provide what i could, if you need more let me know… this is nto a fancy carve just simple basic stuff.

Is your VCarve file set up to use the material surface or the bed as Z zero?

If the file is set to use the bed as Z zero but you actually set Z on the surface all the cuts would be in the air.

1 Like

I set it up as Material Surface

Have you recently updated CM and possibly selected the wrong Z axis type?

After setting Z and measuring the bit can you go back to the material and check that Z looks correct?

1 Like

As far asI know the probe sets the Z then the bit setter sets the tool length

Right. And after the bitsetter has measured the bit you can jog over to the material and lower it to see if Z zero still looks correct.

If you have the latest CM it will measure the but right after you zero the Z axis whether that is manually or with the BitZero probe.

1 Like

The thing is, the tool length offset will depend on the machine moving as much as the software tells it to — if the steps/mm for Z-axis are wrong the machine will move more or less than it ought resulting in an incorrect Z.

Jog to the surface of the MDF, set the origin there, jog up 1 inch and then check the movement of the machine — does it move 1 inch as expected? If not, re-configure for the correct Z-axis.

Will can i give you my File so you can check if i missed something?


Just upload it here.

The thing is, using a BitSetter is deceptively simple, but it requires the following things:

  • correct Z-axis configuration: Shapeoko Machine Setup
  • correct setting of the Z-axis zero: Movements + Zeroing — if using the BitZero see: Using/verifying the BitZero
  • correct functioning of the BitSetter — if it has a magnet that magnet has to be in the same position at all times, and the interaction of the tool placement/geometry and the BitSetter measuring the tool has to allow for a correct measurement of the tool length
  • the correct post-processor selection (in Carbide Create this is Edit | Select Post-processor, but I believe that if sending a .c2d file it is moot)
  • only changing the tool when prompted
  • the correct electro-mechanical functioning of the machine

We’ve written up a bit on this sort of thing at:




Archive.zip (384.9 KB)

I have uploaded i am using the shako 3XXL setup and GBRL post possessor mm, i don’t think it ever made a difference if i used inches or MM on that… i tried both and still the same result. let me know what else you need.

Simulating all the files in a 3rd party tool seems to yield the desired result:

So the problem would seem to be with the machine or how tool change is handled.

I would suggest a very simple test file in Carbide Create such as:

(scroll down a bit and there’s a version w/ a tool change which should load)

If you have trouble cutting a .c2d file with a tool change we can look into that with you.

Now, when I ran my carbide create files, the machine works fine, so I’m wondering if there’s something wrong with my aspire

Is there a way you can convert that into a carbide create file for me because the last time I used it on carbide create, file worked great even with the bitsetter and probe, but of course, it was a different file. I was making a grill scraper.

Or, it’s some aspect of Vectric’s software or the post-processor.

In my experience if you make a pair of as nearly equivalent files in Carbide Create and some 3rd party software, then the two files can be compared to determine what the issue is.

Can you try to recreate this in CC? for me, I know its alot to ask but hen I can run a test, before this I ran CC files and ran it under the same CM and it did great, same probe, same bit setter etc…

You helped me so much back in the # XXL days lol, and i made som many things and made so much money, but this is messing with my mind lol, and its so simple as you can see, i do not beileve its the machine, i think it has to do with aspire which i never used until now…

im maybe thinking its a post processor of aspire…but as i stated it teh the drill holes code just fine so thats weird

Export an SVG from Vectric and post that here?

one thing i did not mention was that i did chnage some of the GRBL parameters in Lightburn for my Jtech laser, the normal ones like $30=255 that went from $30=1000 and another one was $30=1 or was it $30=0 well either way it was one way or another on that.

But i thought if i reset resend the config file from CM to the board it would change that all back anyway? but then again maybe it did not and that would be my problem? and i used Carbide Motion and a Carbide file before but i sent the config to the board so thats why they worked i assume, and then i as stated changed them in LB, but again i resent the config to the board with CM… so again i’m lost…here is hat SVG
Spining Wheel Rustic Lanes edited

Spining Wheel Rustic Lanes edited

So then in your opinion the file is fine?

It seems to be, I’d suggest verifying that the machine is mechanically sound, all wiring is in good condition and secure, and that feeds and speeds are appropriate to the tooling and material.