Is there a new Zeroing procedure for this Version 6?

I have a Bitsetter and Bitzero. I used to, on the pervious version, initialize the machine, put in my zeroing bit then it would take it to the Bitsetter. Then I jogged it over to my Bitzero and got the zero for my piece. I then would click run job, chose my job, then it would instruct me to insert the bit I chose for the job which then would take to the Bitsetter to get correct height.

Now after initializtion and Bitsetter procedure, when I jog over to the Bitzero it asks me if I want to insert a new bit, but I can’t because I cannot zero with a Vee bit. So when I jog with the same zeroing bit, it will zero on the Bitzero, then will not instruct me to insert the correct bit, but instead immediately start the job.

I hope I explained that well. How do I fix this?

1 Like

Sounds like you are doing the procedure correctly. Just check your post processor since you upgraded to a new version of CM. When you upgrade CM you need to send the configuration to the machine. Not only does this configure your machine it also configures CM for your machine.

1 Like

Did you select the “Carbide 3D Shapeoko” post-processor using “Edit | Select Post Processor”?

1 Like

Nope! Totally forgot about that. I am sure that is the reason. Thank you!

Well, actually now it just busted my 1/8 endmill because it decided to plummet through my piece. You are correct that was the issue with the post processor. But no idea why when the job started it plummeted. Since the job was just initialized I shouldn’t have to select new tool.

Was there an odd sound? Usually the cause of an excessive plunge is a disconnect in how the origin is set in the file and where it is set relative to the stock. Other possibilities are changing a tool w/o using the BitSetter and Carbide Motion tool chnage prompts, excessive retract height. Sometimes it’s a mechanical or wiring issue.

I didn’t notice an odd sound. It seemed to be performing as normal. Retract height I believe is .75 and I don’t see how the wiring would be messed up because all of this started happening when I got a new laptop and downloaded the updated version of create and motion

Everything should be the same — post the .c2d file and generated G-Code and step-by-step notes on how you are securing your stock and setting zero relative to it and managing all tool changes?

I am securing this piece with double sided tape. I initialize the machine, insert Bitsetter bit, machine brings to Bitsetter, I jog to the Bitzero, run job, chose my job, then hit start. Tells me to insert bit (in this case 1/8 endmill) then goes back to bit setter. Job started and plummeted through my stock

Harris going away.c2d (1.0 MB)
Harris (312.5 KB)

Do you probe after jogging to the BitZero?


File and code seem fine.

Do you get an awful noise which signifies lost steps when retracting?

If you initialize and set zero w/ the first tool, (the #102 endmill) does this work?

So i am currently trying again. I just initialized and inserted my probing bit. It went to the Bitsetter, now i want to jog it over to the bitzero. But a popup comes up "If you have loaded a tool without pressing “Load Tool” this is necesary to make sure the zero is set correctly. If you are not sure press “yes”

I have never had this message with the pervious version

When I click “yes” it brings it back over to the bitsetter and just stays above it.

So I just tried clicking “No” and it performed the job in the correct spot but again plummeted a half inch deep instead of 0.1

Also, I don’t want to set zero with the first tool because the reading won’t be as accurate, especially if the first tool is a Vee bit

You have to allow the system to measure the tool, and it has to be done using the prompts.

Since you have a BitSetter, it should work to use a probing pin, then change to the #102 when prompted and allow the system to measure that tool when it’s loaded after being requested.

So do I click yes or no when that prompt comes up? When I click no is when it lets me Jog over to the bitzero. Then it does that process as normal. i click Run job and chose the job then it tells me to insert my endmill. Then it goes to the Bitsetter and starts as normal but plummets. So either way clicking Yes or No neither work

The problem seems to be that you are losing Z-axis height when you measure the tool — presumably on the rapid up — please capture this on a video and send it in to along w/ photos of your Z-axis motor wiring, including the wiring extension connectors, including at the controller.

So is this a version 6 issue? Because the older version on my other laptop works fine. None of these issues happened until I got this new laptop with the update

I suspect it’s caused by the faster rapids in Carbide Motion, see:

perhaps reduce the acceleration and so forth to the old defaults.